Назначение

Инструменты Secret Disk NG Alarm 3.1 предназначены для подачи сигнала «тревога» серверам Secret Disk Server NG 3.x. В зависимости от настроек сервера и защищённых дисков, получение сигнала «тревога» приводит к:

· отключению защищённых дисков;

· уничтожению защищённого хранилища.

Уничтожение защищённого хранилища сигналом «тревога» означает полное удаление ключевой информации: даже если злоумышленники завладеют электронным ключом или смарт-картой eToken, узнают PIN-код и будут обладать полным доступом к серверу, без защищённого хранилища они не смогут прочесть информацию.


Состав

Инструменты Secret Disk NG Alarm 3.1:

· основная утилита Secret Disk NG Alarm 3.1 - утилита для настройки и отправки сигнала «тревога» с помощью графического интерфейса пользователя;

· «красная кнопка» - устройство, подключаемое к порту COM (кнопка с проводом или радиоприёмник с радиобрелоком);

· sdsalrm.exe - утилита для подачи сигнала «тревога» из командной строки.


Новое в версии

Secret Disk NG Alarm 3.1 имеет два основных отличия от Secret Disk NG Alarm 3.0:

· возможность настраивать время удержания кнопки;

· новая схема подключения кнопки к разъёмам порта COM.

Введение настройки времени удержания кнопки не означает, что вместо обычной кнопки в Secret Disk NG Alarm 3.1 нельзя использовать датчики пожарной или охранной сигнализации и т. п. Однако для того чтобы подача сигнала «тревога» происходила при каждом изменении разности потенциалов на соответствующих контактах порта COM необходима специальная настройка: вам потребуется установить время удержания кнопки равным нулю.

Использование в Secret Disk NG Alarm 3.1 новой схемы подключения кнопки к разъёмам порта COM не вносит несовместимости:

· при необходимости кнопки с новой схемой моожно использовать с программным обеспечением Secret Disk NG Alarm 3.0;

· при необходимости в Secret Disk NG Alarm 3.1 можно использовать кнопки Secret Disk NG Alarm 3.0.


Требования к программному обеспечению

Инструменты для сигнала «тревога» могут быть установлены на компьютере, работающем под управлением одной из следующих операционных систем:

· Microsoft Windows Server 2003;

· Microsoft Windows 2000 Advanced Server с установленным пакетом обновления (Service Pack) 2 или выше;

· Microsoft Windows 2000 Server с установленным пакетом обновления (Service Pack) 2 или выше;

· Microsoft Windows 2000 Professional с установленным пакетом обновления (Service Pack) 2 или выше;

· Microsoft Windows XP Professional с установленным пакетом обновления (Service Pack) 1 или выше;

· Microsoft Windows XP Home Edition с установленным пакетом обновления (Service Pack) 1 или выше.


Требования к аппаратному обеспечению

1. Рабочая станция должна удовлетворять требованиям к аппаратному обеспечению соответствующей операционной системы.

2. Для подключения «красной кнопки» необходим свободный порт COM.


Необходимые полномочия

Для установки и удаления Secret Disk NG Alarm 3.1 необходимы полномочия локального администратора.


Установка

Для того чтобы установить Secret Disk NG Alarm 3.1, выполните следующую последовательность действий.

1. Убедитесь в том, что компьютер удовлетворяет системным требованиям.

2. Для запуска программы установки Secret Disk NG Alarm 3.1 в меню компакт-диска Secret Disk Server NG 3.x нажмите Установить утилиту подачи сигнала «тревога».

Примечание: Более подробная информация о меню компакт-диска изложена в документации Secret Disk Server NG 3.x.

3. В окне приветствия программы установки нажмите Далее.

4. Для начала процесса установки нажмите Установить.

5. Процесс установки займёт некоторое время.

6. Убедитесь в том, что процесс установки завершён успешно, и нажмите Готово.

Отказ от установки

Отказаться от установки Secret Disk NG Alarm 3.1 можно в любом диалоговом окне программы установки, кроме последнего. Для этого:

· нажмите Отмена;

· в окне подтверждения нажмите Да;

· нажмите Готово.


Удаление

Для того чтобы удалить Secret Disk NG Alarm 3.1, выполните следующее.

1. Щёлкните Пуск/Start > Все программы (All Programs) / Программы (Programs) > Secret Disk NG > Alarm > Удаление.

2. В окне подтверждения нажмите Да/Yes.

3. При необходимости закройте требуемые окна и нажмите Повторить.


Переделка устаревших кнопок

В «красной кнопке», использовавшейся с Secret Disk Server 1.x, замыкались контакты 2 и 3 штекера DB-9 (контакты 3 и 2 штекера DB-25). В «красной кнопке» Secret Disk NG Alarm 3.0 замыкались контакты 4 и 6 штекера DB-9 (контакты 20 и 6 штекера DB-25). Если вы хотите использовать устаревшую кнопку в комплексе Secret Disk NG Alarm 3.1, подключите жилы, замыкаемые кнопкой, к другим контактам:

· для штекера DB-9 - к замкнутым накоротко контактам 4 и 6 с одной стороны и контакту 5 с другой стороны;

· для штекера DB-25 - к замкнутым накоротко контактам 6 и 20 с одной стороны и контакту 7 с другой стороны.

Примечание:

Переделка кнопки Secret Disk NG Alarm 3.0 рекомендуется, но не является обязательной, поскольку Secret Disk NG Alarm 3.1 поддерживает кнопки, входившие в состав Secret Disk NG Alarm 3.0.


Подключение «красной кнопки»

Для того чтобы подключить «красную кнопку», выполните следующее:

1. Выключите компьютер.

2. Отсоедините провод электропитания.

3. Подключите разъём к порту COM.

4. Закрепите кнопку. Место крепления должно удовлетворять двум условиям:

· оно должно быть легкодоступным;

· случайное нажатие «красной кнопки» должно быть исключено.


Отключение «красной кнопки»

Для того чтобы отключить «красную кнопку», выполните следующее:

1. Выключите компьютер.

2. Отсоедините провод электропитания.

3. Отключите разъём от порта COM.


Настройка

Прежде чем начать использование Secret Disk NG Alarm 3.1, необходимо:

· осуществить настройки сервера, задав пароль сигнала «тревога»;

· настроить Secret Disk NG Alarm 3.1 на рабочей станции для подачи сигнала «тревога», указав заданный на сервере пароль;

· обеспечить доступность сервера по сети с рабочей станции для подачи сигнала «тревога».


Настройка сервера

Для того чтобы осуществить настройки сигнала «тревога» на сервере, выполните следующее.

1. При открытом сеансе управления в дереве консоли выделите Управление Secret Disk Server.

2. Выполните одно из действий:

· в меню Действие/Action щёлкните Настройки сигнала «тревога»;

· щёлкните правой кнопкой мыши и выберите Настройки сигнала «тревога».

3. На экране появится окно Настройки сигнала «тревога».

4. Задайте пароль сигнала «тревога». Для этого введите желаемую последовательность символов в графы Пароль и Подтверждение.

5. Если вы хотите, чтобы при поступлении сигнала «тревога» удалялось защищённое хранилище:

· установите флажок;

· на экране появится окно с предложением сохранить копию защищённого хранилища;

· если вы располагаете актуальной резервной копией защищённого хранилища, нажмите Нет;

· если у вас нет резервной копии защищённого хранилища, нажмите Да и перейдите к процедуре сохранения резервной копии защищённого хранилища.

Важно: для того чтобы после удаления защищённого хранилища вы легко могли восстановить доступ к данным, сделайте резервную копию защищённого хранилища и храните её в надёжном месте.

Если вы не хотите, чтобы защищённое хранилище удалялось при поступлении сигнала «тревога», снимите флажок.

6. В окне Настройки сигнала «тревога» нажмите OK.


Настройка рабочей станции для подачи сигнала «тревога»

Для настройки Secret Disk NG Alarm 3.1 необходимо иметь полный доступ к разделам реестра HKEY_LOCAL_MACHINE\SOFTWARE\Aladdin\Alarm\Plugins\ALRMCfg\Parameters, HKEY_LOCAL_MACHINE\SOFTWARE\Aladdin\Alarm\Plugins\RBEvents\Parameters и HKEY_LOCAL_MACHINE\SOFTWARE\Aladdin\Alarm\Plugins\SDNotifier\Parameters. По умолчанию такой доступ есть только у администраторов.

Для того чтобы осуществить настройку Secret Disk NG Alarm 3.1, выполните следующее:

1. Убедитесь в том, что программное и аппаратное обеспечение установлено.

2. Щёлкните Пуск/Start > Все программы (All Programs) / Программы (Programs) > Secret Disk NG > Alarm > Alarm.

3. На экране появится окно Secret Disk NG Alarm.

4. Укажите серверы и соответствующие пароли сигнала «тревога»:

Примечание: нажатие «красной кнопки» будет приводить к подаче сигнала «тревога» на все указанные серверы одновременно.

· для добавления сервера:

· нажмите Добавить;

· в окне Свойства сервера введите имя или IP-адрес сервера;

servset

· введите пароль сигнала «тревога» в поля Пароль и Подтверждение;

· нажмите OK;

· для редактирования свойств сервера:

· выберите сервер из списка;

· нажмите Редактировать;

· в окне Свойства сервера измените полное доменное имя или IP-адрес сервера;

· введите пароль сигнала «тревога» в поля Пароль и Подтверждение;

· нажмите OK;

· для того чтобы нажатие «красной кнопки» и подача сигнала с помощью основной утилиты не влияли на какой-либо сервер:

· выберите сервер из списка;

· нажмите Удалить;

· в окне подтверждения нажмите Да.

5. При необходимости укажите порт, к которому подключена «красная кнопка».

6. По умолчанию для подачи сигнала «тревога» с помощью «красной кнопки» нужно нажать и отпустить кнопку. При этом время удержания кнопки должно составлять не менее 90 мс. Такое значение параметра обеспечивает:

· подачу сигнала «тревога» обычным чётким кратковременным нажатием кнопки;

· предотвращение случайного срабатывания.

В некоторых случаях вам потребуется изменить минимальное время удержания кнопки:

· увеличить его, если при текущих настройках наблюдается самопроизвольная подача сигнала «тревога»;

· уменьшить его, если при текущих настройках кратковременное нажатие «красной кнопки» не приводит к подаче сигнала «тревога»;

· назначить параметру значение 0, если для подачи сигнала «тревога» вы используете датчик пожарной или охранной сигнализации и т. п.

Примечания:

· Чем больше минимальное время удержания кнопки, тем дольше надо удерживать кнопку. Чрезмерное увеличение значения этого параметра может привести к тому, что кратковременное нажатие «красной кнопки» не будет приводить к подаче сигнала «тревога».

· Если параметр принимает значение 0, то подача сигнала «тревога» происходит при каждом изменении разности потенциалов на соответствующих контактах порта COM. Это необходимо, когда вместо обычной кнопки контакты подключены к датчику пожарной или охранной сигнализации и т. п. При использовании обычной кнопки нулевое значение параметра может приводить к самопроизвольной подаче сигнала «тревога». Для того чтобы предотвратить самопроизвольное срабатывание при подключении к датчикам используйте экранированные кабели с заземлением.

Для того чтобы увеличить минимальное время удержания кнопки, переместите ползунок вправо, а для того чтобы уменьшить - влево.

7. Если вы хотите подавать сигнал «тревога» с помощью мыши, установите флажок Значок на панели задач.

8. Нажмите OK.


Использование «красной кнопки»

Для того чтобы подать сигнал «тревога» с помощью «красной кнопки», просто нажмите кнопку (обычную или на радиобрелоке).


Подача сигнала «тревога» с помощью мыши

Основная утилита Secret Disk NG Alarm 3.1 позволяет подавать сигнал «тревога» без нажатия «красной кнопки». Для этого:

· на панели задач щёлкните правой кнопкой мыши по значку сигнал «тревога» ( icoalarm);

· щёлкните Подать сигнал «тревога».


Подача сигнала «тревога» из командной строки

Если Secret Disk NG Alarm 3.1 настроен на подачу сигнала «тревога» нескольким серверам Secret Disk Server NG 3.x, то использование командной строки - единственный способ подачи сигнала лишь одному или некоторым из них.

Для отправки сигнала «тревога» одному или нескольким серверам Secret Disk Server NG 3.x из командной строки предназначена утилита sdsalrm.exe. Для того чтобы послать сигнал «тревога» серверу, вы должны знать:
имя или IP-адрес сервера;
пароль сигнала «тревога».

Для того чтобы отправить сигнал «тревога» с помощью утилиты sdsalrm.exe, выполните следующее:

1. Убедитесь в том, что на рабочей станции установлен Secret Disk NG Alarm 3.1.

2. В меню Пуск/Start выберите Выполнить/Run.

3. В поле Открыть/Open введите:

sdsalrm "<пароль1>@<сервер1>" ["<пароль2>@<сервер2>" ...],

где:

<парольN> - пароль сигнала «тревога» для сервера N.

<серверN> - имя или IP-адрес сервера N.

Примечания:

1. При отправке сигнала «тревога» нескольким серверам имя/адрес и пароль для каждого сервера указываются в командной строке через пробел.

2. Если пароль сигнала «тревога» для какого-либо сервера (например, сервера 1) не содержит символов пробела, соответствующий параметр команды sdsalrm можно вводить без кавычек:

sdsalrm <пароль1>@<сервер1> ["<пароль2>@<сервер2>" ...].


 Защищённое хранилище - объект, хранящийся на системном диске и содержащий информацию об администраторах Secret Disk Server NG, а также зашифрованные копии мастер-ключей защищённых дисков для всех администраторов Secret Disk Server NG.