АктивИкс

АктивИкс

Класс "АктивИкс" / "ActiveX".

Класс позволяет размещать на формах 1С:Предприятие элементы управления (далее ЭУ) ActiveX и обрабатывать события, возникающие в ЭУ. При возникновении события вызывается процедура модуля формы с именем:

<ИдентификаторЭлементаДиалога>_<Событие>

где ИдентификаторЭлементаДиалога - идентификатор элемента диалога, на месте которого создан ЭУ, и Событие - наименование события ЭУ (например OnClick). Например, обработчик Процедура ИДБраузер_BeforeNavigate2(Параметры...)

Класс может служить базовым классом для классов, определяемых пользователем.

В этом случае, если в модуле реализации КОП-наследника определены процедуры или функции с именами, совпадающими с именами событий (например, OnClick) без указания имени реквизита:

<Событие>

где Событие - наименование события ЭУ (например OnClick), Например, обработчик Процедура BeforeNavigate2(Параметры...)

то при возникновении соответствующих событий они будут вызваны. Если определены обработчики в модуле формы и в модуле реализации КОП, то сначала будут вызваны обработчики из модуля реализации КОП. Для обработки событий в модуле реализации КОП экземпляр класса должен быть создан следующим образом:

АтрФормы = СоздатьОбъект("АтрибутФормы");
АтрФормы.УстановитьАтрибут(Форма,"ФДерево");
Дерево=СоздатьОбъект("Дерево");//класс-наследник АктивИкс
АтрФормы.СоздатьЭлементУправления(Дерево); // СоздатьЭУ
Дерево.СоздатьЭУ("MSComctlLib.TreeCtrl");

Свойства

Объект / Object | Обеспечивает доступ к свойствам и методам созданного элемента управления.
ОбработкаСобытий / EventProcessing | Управляет вызовом процедур - обработчиков событий.

Методы

УстановитьАтрибут / AssignAttrib | Указывает размещение создаваемого элемента, а также устанавливает префикс для имен процедур-обработчиков событий, расположенных в модуле формы.
СоздатьЭУ / CreateControl | Создает в месте, указанном при вызове процедуры УстановитьАтрибут элемент управления ActiveX с указанным ProgID.
УстановитьФокус / SetFocus | Устанавливает фокус ввода.
Уничтожить / Destroy | уничтожает элемент управления.


АктивИкс::Объект / Object

1C++ :: АктивИкс | Ранее: АктивИкс | Далее: ОбработкаСобытий / EventProcessing
АктивИкс :: Объект / Object

Доступ: только чтение.

Тип: OLE объект.

Описание: Обеспечивает доступ к свойствам и методам созданного элемента управления.


АктивИкс::ОбработкаСобытий / EventProcessing

1C++ :: АктивИкс | Ранее: Объект / Object | Далее: УстановитьАтрибут / AssignAttrib
АктивИкс :: ОбработкаСобытий / EventProcessing

Доступ: чтение и запись.

Тип: Число.

Описание: Управляет вызовом процедур - обработчиков событий.

Если 0, то при возникновении событий в элементе управления процедуры-обработчики не вызываются. При любых других значениях обработка событий производится.


АктивИкс::УстановитьАтрибут / AssignAttrib

1C++ :: АктивИкс | Ранее: ОбработкаСобытий / EventProcessing | Далее: СоздатьЭУ / CreateControl
АктивИкс :: УстановитьАтрибут / AssignAttrib

Синтаксис: УстановитьАтрибут(Форма, ИдентификаторЭлементаДиалога)

Параметры:
  • Форма - тип: Форма. Форма, на которой будет создан элемент ActiveX
  • ИдентификаторЭлементаДиалога - тип: Строка. Идентификатор элемента диалога, на месте которого будет создан элемент ActiveX.

Описание: Указывает размещение создаваемого элемента, а также устанавливает префикс для имен процедур-обработчиков событий, расположенных в модуле формы.

имена процедур-обработчиков событий, расположенных в модуле КОП-наследника АктивИкс совпадают с именами событий.

Важно

Метод работает после физического открытия окна формы (например - в предопределенной процедуре ПослеОткрытия). Метод работает только для реквизитов диалога типа "Текст".


АктивИкс::СоздатьЭУ / CreateControl

1C++ :: АктивИкс | Ранее: УстановитьАтрибут / AssignAttrib | Далее: УстановитьФокус / SetFocus
АктивИкс :: СоздатьЭУ / CreateControl

Синтаксис:

Параметры:
  • ProgID - тип: Строка. ProgID элемента управления как указано в реестре.

Возвращает: OLE объект созданного элемента управления.

Описание: Создает в месте, указанном при вызове процедуры УстановитьАтрибут элемент управления ActiveX с указанным ProgID.

Важно

Метод работает после указания расположения ЭУ вызовом УстановитьАтрибут класса АктивИкс или вызовом СоздатьЭУ(СоздатьТабличноеПоле) класса АтрибутФормы.

OLE-объект возвращаемый при выполнении метода может быть сохранен в переменной. В дальнейшем доступ к этому объекту может осуществляться через свойство Объект.


АктивИкс::УстановитьФокус / SetFocus

1C++ :: АктивИкс | Ранее: СоздатьЭУ / CreateControl | Далее: Уничтожить / Destroy
АктивИкс :: УстановитьФокус / SetFocus

Синтаксис: УстановитьФокус()

Описание: Устанавливает фокус ввода.


АктивИкс::Уничтожить / Destroy

1C++ :: АктивИкс | Ранее: УстановитьФокус / SetFocus | Далее:
АктивИкс :: Уничтожить / Destroy

Синтаксис: Уничтожить()

Описание: уничтожает элемент управления.