Изменения, влияющие на обеспечение обратной совместимости

Изменения, влияющие на обеспечение обратной совместимости

  • v.2.5.0.7


v.2.5.0.7

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: Изменения, влияющие на обеспечение обратной совместимости | Далее: Табличное поле
v.2.5.0.7
  • Табличное поле
  • Перехватчик
  • ООП - пользовательские классы


Табличное поле

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: v.2.5.0.7 | Далее: Drag-n-Drop
Табличное поле
  • Drag-n-Drop


Drag-n-Drop

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: Табличное поле | Далее: Перехватчик
Drag-n-Drop

Механизм Drag-n-Drop несовместим на уровне параметров c 1cpp v.2.5.0.6 до объединения с веткой TF_RC3 26.02.2008


Перехватчик

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: Drag-n-Drop | Далее: ООП - пользовательские классы
Перехватчик

Исправлен баг - нельзя было установить еще один перехват на уже перехваченную форму

[bug 3791]


ООП - пользовательские классы

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: Перехватчик | Далее: Параметры по значению - Знач
ООП - пользовательские классы
  • Параметры по значению - Знач
  • Динамические свойства
  • Прочее


Параметры по значению - Знач

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: ООП - пользовательские классы | Далее: Динамические свойства
Параметры по значению - Знач

  • Исправлен баг - Если хотя бы один параметр метода определен как Знач, то в ранних версиях все параметры передавались по значению

  • Исправлен баг - Для публичного метода класса, не описанного в prm-файле, а

    описанного только в модуле класса, не работает передача параметров по значению, а работает только по ссылке.

    [bug 3658]


Динамические свойства

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: Параметры по значению - Знач | Далее: Прочее
Динамические свойства

  • Исправление реализации динамических свойств для обеспечения нормального ООП

    [bug 3606] и [bug 3592]

    ВНИМАНИЕ (несовместимость): необходимо вручную исправление классов, реализующих динамические свойства !! Класс (или его клиент(не рекомендуется)) должен самостоятельно добавить динамическое свойство с помощью встроенного метода ДобавитьДинамическоеСвойство(стрИмяНовогоСвойства)


Прочее

1C++ :: Изменения, влияющие на обеспечение обратной совместимости | Ранее: Динамические свойства | Далее:
Прочее

Исправлен баг - при разном порядке объявления множественных базовых классов работа наследуемых методов класса-наследника отличается.

[bug 3589]