Поставщик данных - журнал регистрации

Поставщик данных - журнал регистрации

Служит для доступа к журналу регистрации 1С и может использоваться в двух режимах:

  • в качестве поставщика данных для табличного поля;
  • как самостоятельный объект для работы с журналом регистрации.

Свойство ТекущаяСтрока табличного поля имеет тип число и определяет:

  • при чтении смещение в байтах от начала файла до начала текущей записи журнала регистрации;
  • при записи производится установка на запись, содержащую указанное смещение, если отбор не установлен, или установка на первую запись со смещением большим указанного, удовлетворяющей отбору, если отбор установлен.
  • ПоставщикДанныхЖурналРегистрации / LogProvider
  • ТипыСобытийЖурналаРегистрации / LogEventTypes
  • ТипСобытияЖурналаРегистрации / LogEventType
  • СобытияЖурналаРегистрации / LogEvents
  • СобытиеЖурналаРегистрации / LogEvent
  • Отбор / Filter
  • ЭлементОтбора / FilterItem


ПоставщикДанныхЖурналРегистрации / LogProvider

1C++ :: Поставщик данных - журнал регистрации | Ранее: Поставщик данных - журнал регистрации | Далее: Позиция / Position
ПоставщикДанныхЖурналРегистрации / LogProvider

Свойства

Позиция / Position | Смещение в байтах от начала файла до начала текущей записи журнала регистрации. Если значение отрицательное, то запись находится во временном файле, полученном путем извлечения из архивов, если просмотр архивов установлен (см. свойство ПросмотрАрхивов).
Дата / Date | Дата записи журнала регистрации.
Время / Time | Время записи журнала регистрации.
Пользователь / User | Пользователь, вызвавший определенное событие.
Режим / Mode | Режим работы 1С: Предприятия, в котором произошло определенное событие.
ТипСобытия / EventType | Тип события. Тип значения этого свойства зависит от того, присутствует данный тип события в коллекции типов событий поставщика данных (см. свойство ТипыСобытий).
Событие / Event | Событие. Тип значения этого свойства зависит от того, присутствует данное событие в коллекции событий (см. свойство События) одного из типов событий поставщика данных (см. свойство ТипыСобытий).
Категория / Category | Категория события: 0 - сеанс, 1 - административное, 2 - изменение данных, 3 - информация, 4 - предупреждение, 5 - ошибка.
Комментарий / Comment | Комментарий к событию.
Объект / Object | Объект.
ПредставлениеОбъекта / ObjectPresent | Представление объекта.
НачалоПериода / BeginOfPeriod | Дата начала периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.
ВремяНачалаПериода / PeriodBeginingTime | Время начала периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.
КонецПериода / EndOfPeriod | Дата конца периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.
ВремяОкончанияПериода / PeriodEndingTime | Время окончания периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.
ГлубинаПросмотра / ScanDeep | Количество попыток поиска строки, удовлетворяющей отбору.
ПоследняяПросмотреннаяДата / LastScanDate | Дата последней записи журнала регистрации, после которой поиск строк был прекращен.
ИспользованиеБуфера / UsingBuffer | Определяет, используется или нет буфер при отборе записей.
ИмяФайла / FileName | Содержит полное имя файла журнала регистрации, который провайдер использует в качестве источника данных.
ПросмотрАрхивов / ArchivesView | Определяет, будет или нет осуществляться просмотр архивов при установке периода просмотра методами УстановитьПериод или УстановитьПериодРасш. Поиск архивов осуществляется в том же каталоге, где находится журнал регистрации. Архивы должны быть получены путем выполнения архивирования журнала регистрации из Монитора. Извлечение данных из архива зависит от того, установлен отбор с использованием буфера или нет. Если отбор с использованием буфера не установлен, то данные извлекаются по мере необходимости.
ТипыСобытий / EventTypes | Фиксированная коллекция типов событий в журнале регистрации. Содержит как системные типы событий, так и пользовательские, определенные в файле 1cv7evt.txt. Поиск данного файла осуществляется в том же каталоге, где находится журнал регистрации.
Отбор / Filter | Коллекция содержит элементы отбора, соответствующие установленному отбору методами ИзменитьФильтр и УстановитьФильтр.

Методы

УстановитьПериод / SetPeriod | Устанавливает период просмотра записей журнала регистрации.
УстановитьПериодРасш / SetPeriodEx | Устанавливает период просмотра записей журнала регистрации.
УстановитьГлубину / SetScanDeep | Устанавливает количество попыток поиска строки, удовлетворяющей отбору.
ИзменитьФильтр / ChangeFilter | Добавляет или удаляет элемент отбора для просмотра записей журнала регистрации.
УстановитьФильтр / SetFilter | Проверяет на корректность изменения отбора методом ИзменитьФильтр и начинает отбор записей. Если используется буфер, то при прерывании отбора клавишей <ESC> формируется исключение. Если провайдер является поставщиком данных табличного поля, то выполнение процесса отбора в процентах отображается в строке состояния.
ОткрытьФайл / OpenFile | Открывает файл журнала регистрации для последующей выборки записей методом ВыбратьСтроки.
ЗакрытьФайл / CloseFile | Закрывает открытый файл журнала регистрации.
ВыбратьСтроки / SelectLines | Метод определяет, на какую запись указывает переданное смещение, и устанавливает выборку с этой записи.
ПолучитьСтроку / GetLine | Выполняет позиционирование на очередную запись из выборки. Если перед получением строки установлен период и (или) отбор, то получение записи осуществляется с учетом периода и отбора. При прерывании данной операции клавишей <ESC> формируется исключение.


ПоставщикДанныхЖурналРегистрации / LogProvider::Позиция / Position

1C++ :: Поставщик данных - журнал регистрации | Ранее: ПоставщикДанныхЖурналРегистрации / LogProvider | Далее: Дата / Date
ПоставщикДанныхЖурналРегистрации / LogProvider :: Позиция / Position

Доступ: только чтение.

Тип: Число.

Описание: Смещение в байтах от начала файла до начала текущей записи журнала регистрации. Если значение отрицательное, то запись находится во временном файле, полученном путем извлечения из архивов, если просмотр архивов установлен (см. свойство ПросмотрАрхивов).


ПоставщикДанныхЖурналРегистрации / LogProvider::Дата / Date

1C++ :: Поставщик данных - журнал регистрации | Ранее: Позиция / Position | Далее: Время / Time
ПоставщикДанныхЖурналРегистрации / LogProvider :: Дата / Date

Доступ: только чтение.

Тип: Дата.

Описание: Дата записи журнала регистрации.


ПоставщикДанныхЖурналРегистрации / LogProvider::Время / Time

1C++ :: Поставщик данных - журнал регистрации | Ранее: Дата / Date | Далее: Пользователь / User
ПоставщикДанныхЖурналРегистрации / LogProvider :: Время / Time

Доступ: только чтение.

Тип: Строка в формате "ЧЧ:ММ:СС".

Описание: Время записи журнала регистрации.


ПоставщикДанныхЖурналРегистрации / LogProvider::Пользователь / User

1C++ :: Поставщик данных - журнал регистрации | Ранее: Время / Time | Далее: Режим / Mode
ПоставщикДанныхЖурналРегистрации / LogProvider :: Пользователь / User

Доступ: только чтение.

Тип: Строка или пустое значение.

Описание: Пользователь, вызвавший определенное событие.


ПоставщикДанныхЖурналРегистрации / LogProvider::Режим / Mode

1C++ :: Поставщик данных - журнал регистрации | Ранее: Пользователь / User | Далее: ТипСобытия / EventType
ПоставщикДанныхЖурналРегистрации / LogProvider :: Режим / Mode

Доступ: только чтение.

Тип: Строка "E", "C", "M", или "D".

Описание: Режим работы 1С: Предприятия, в котором произошло определенное событие.


ПоставщикДанныхЖурналРегистрации / LogProvider::ТипСобытия / EventType

1C++ :: Поставщик данных - журнал регистрации | Ранее: Режим / Mode | Далее: Событие / Event
ПоставщикДанныхЖурналРегистрации / LogProvider :: ТипСобытия / EventType

Доступ: только чтение.

Тип: Строка или ТипСобытияЖурналаРегистрации.

Описание: Тип события. Тип значения этого свойства зависит от того, присутствует данный тип события в коллекции типов событий поставщика данных (см. свойство ТипыСобытий).


ПоставщикДанныхЖурналРегистрации / LogProvider::Событие / Event

1C++ :: Поставщик данных - журнал регистрации | Ранее: ТипСобытия / EventType | Далее: Категория / Category
ПоставщикДанныхЖурналРегистрации / LogProvider :: Событие / Event

Доступ: только чтение.

Тип: Строка или СобытиеЖурналаРегистрации.

Описание: Событие. Тип значения этого свойства зависит от того, присутствует данное событие в коллекции событий (см. свойство События) одного из типов событий поставщика данных (см. свойство ТипыСобытий).


ПоставщикДанныхЖурналРегистрации / LogProvider::Категория / Category

1C++ :: Поставщик данных - журнал регистрации | Ранее: Событие / Event | Далее: Комментарий / Comment
ПоставщикДанныхЖурналРегистрации / LogProvider :: Категория / Category

Доступ: только чтение.

Тип: Число 0, 1, 2, 3, 4 или 5.

Описание: Категория события: 0 - сеанс, 1 - административное, 2 - изменение данных, 3 - информация, 4 - предупреждение, 5 - ошибка.


ПоставщикДанныхЖурналРегистрации / LogProvider::Комментарий / Comment

1C++ :: Поставщик данных - журнал регистрации | Ранее: Категория / Category | Далее: Объект / Object
ПоставщикДанныхЖурналРегистрации / LogProvider :: Комментарий / Comment

Доступ: только чтение.

Тип: Строка или пустое значение.

Описание: Комментарий к событию.


ПоставщикДанныхЖурналРегистрации / LogProvider::Объект / Object

1C++ :: Поставщик данных - журнал регистрации | Ранее: Комментарий / Comment | Далее: ПредставлениеОбъекта / ObjectPresent
ПоставщикДанныхЖурналРегистрации / LogProvider :: Объект / Object

Доступ: только чтение.

Тип: Агрегатный или пустое значение.

Описание: Объект.


ПоставщикДанныхЖурналРегистрации / LogProvider::ПредставлениеОбъекта / ObjectPresent

1C++ :: Поставщик данных - журнал регистрации | Ранее: Объект / Object | Далее: НачалоПериода / BeginOfPeriod
ПоставщикДанныхЖурналРегистрации / LogProvider :: ПредставлениеОбъекта / ObjectPresent

Доступ: только чтение.

Тип: Строка или пустое значение.

Описание: Представление объекта.


ПоставщикДанныхЖурналРегистрации / LogProvider::НачалоПериода / BeginOfPeriod

1C++ :: Поставщик данных - журнал регистрации | Ранее: ПредставлениеОбъекта / ObjectPresent | Далее: ВремяНачалаПериода / PeriodBeginingTime
ПоставщикДанныхЖурналРегистрации / LogProvider :: НачалоПериода / BeginOfPeriod

Доступ: только чтение.

Тип: Дата.

Описание: Дата начала периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.


ПоставщикДанныхЖурналРегистрации / LogProvider::ВремяНачалаПериода / PeriodBeginingTime

1C++ :: Поставщик данных - журнал регистрации | Ранее: НачалоПериода / BeginOfPeriod | Далее: КонецПериода / EndOfPeriod
ПоставщикДанныхЖурналРегистрации / LogProvider :: ВремяНачалаПериода / PeriodBeginingTime

Доступ: только чтение.

Тип: Строка в формате "ЧЧ:ММ:СС".

Описание: Время начала периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.


ПоставщикДанныхЖурналРегистрации / LogProvider::КонецПериода / EndOfPeriod

1C++ :: Поставщик данных - журнал регистрации | Ранее: ВремяНачалаПериода / PeriodBeginingTime | Далее: ВремяОкончанияПериода / PeriodEndingTime
ПоставщикДанныхЖурналРегистрации / LogProvider :: КонецПериода / EndOfPeriod

Доступ: только чтение.

Тип: Дата.

Описание: Дата конца периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.


ПоставщикДанныхЖурналРегистрации / LogProvider::ВремяОкончанияПериода / PeriodEndingTime

1C++ :: Поставщик данных - журнал регистрации | Ранее: КонецПериода / EndOfPeriod | Далее: ГлубинаПросмотра / ScanDeep
ПоставщикДанныхЖурналРегистрации / LogProvider :: ВремяОкончанияПериода / PeriodEndingTime

Доступ: только чтение.

Тип: Строка в формате "ЧЧ:ММ:СС".

Описание: Время окончания периода при установленном периоде просмотра методами УстановитьПериод или УстановитьПериодРасш.


ПоставщикДанныхЖурналРегистрации / LogProvider::ГлубинаПросмотра / ScanDeep

1C++ :: Поставщик данных - журнал регистрации | Ранее: ВремяОкончанияПериода / PeriodEndingTime | Далее: ПоследняяПросмотреннаяДата / LastScanDate
ПоставщикДанныхЖурналРегистрации / LogProvider :: ГлубинаПросмотра / ScanDeep

Доступ: только чтение.

Тип: Неотрицательное число.

Описание: Количество попыток поиска строки, удовлетворяющей отбору.

Имеет действие только при установленном отборе. Если 0, то количество попыток ограничено только размеров файла журнала регистрации, т.е. будет анализироваться весь файл.

Примечание: По умолчанию равно 0.


ПоставщикДанныхЖурналРегистрации / LogProvider::ПоследняяПросмотреннаяДата / LastScanDate

1C++ :: Поставщик данных - журнал регистрации | Ранее: ГлубинаПросмотра / ScanDeep | Далее: ИспользованиеБуфера / UsingBuffer
ПоставщикДанныхЖурналРегистрации / LogProvider :: ПоследняяПросмотреннаяДата / LastScanDate

Доступ: только чтение.

Тип: Дата.

Описание: Дата последней записи журнала регистрации, после которой поиск строк был прекращен.

Поиск мог быть прекращен из-за ограничения, наложенного свойством ГлубинаПросмотра, или при нажатии клавиши <ESC>. Имеет смысл только при установленном отборе.


ПоставщикДанныхЖурналРегистрации / LogProvider::ИспользованиеБуфера / UsingBuffer

1C++ :: Поставщик данных - журнал регистрации | Ранее: ПоследняяПросмотреннаяДата / LastScanDate | Далее: ИмяФайла / FileName
ПоставщикДанныхЖурналРегистрации / LogProvider :: ИспользованиеБуфера / UsingBuffer

Доступ: только чтение.

Тип: Число 0 или 1.

Описание: Определяет, используется или нет буфер при отборе записей.


ПоставщикДанныхЖурналРегистрации / LogProvider::ИмяФайла / FileName

1C++ :: Поставщик данных - журнал регистрации | Ранее: ИспользованиеБуфера / UsingBuffer | Далее: ПросмотрАрхивов / ArchivesView
ПоставщикДанныхЖурналРегистрации / LogProvider :: ИмяФайла / FileName

Доступ: чтение и запись.

Тип: строка.

Описание: Содержит полное имя файла журнала регистрации, который провайдер использует в качестве источника данных.

Примечание: По умолчанию используется журнал регистрации текущей информационной базы. В случае использования провайдера в качестве поставщика данных табличного поля при изменении данного свойства табличное поле сразу начинает отображать указанный журнал регистрации. Если провайдер используется как самостоятельный объект, то для доступа к указанному файлу журнала регистрации необходимо закрыть ранее используемый файл методом ЗакрытьФайл и открыть новый файл методом ОткрытьФайл. Если используется журнал регистрации не текущей информационной базы, то свойство Объект неопределено.


ПоставщикДанныхЖурналРегистрации / LogProvider::ПросмотрАрхивов / ArchivesView

1C++ :: Поставщик данных - журнал регистрации | Ранее: ИмяФайла / FileName | Далее: ТипыСобытий / EventTypes
ПоставщикДанныхЖурналРегистрации / LogProvider :: ПросмотрАрхивов / ArchivesView

Доступ: чтение и запись.

Тип: Число 0 или 1.

Описание: Определяет, будет или нет осуществляться просмотр архивов при установке периода просмотра методами УстановитьПериод или УстановитьПериодРасш. Поиск архивов осуществляется в том же каталоге, где находится журнал регистрации. Архивы должны быть получены путем выполнения архивирования журнала регистрации из Монитора. Извлечение данных из архива зависит от того, установлен отбор с использованием буфера или нет. Если отбор с использованием буфера не установлен, то данные извлекаются по мере необходимости.


ПоставщикДанныхЖурналРегистрации / LogProvider::ТипыСобытий / EventTypes

1C++ :: Поставщик данных - журнал регистрации | Ранее: ПросмотрАрхивов / ArchivesView | Далее: Отбор / Filter
ПоставщикДанныхЖурналРегистрации / LogProvider :: ТипыСобытий / EventTypes

Доступ: чтение.

Тип: ТипыСобытийЖурналаРегистрации.

Описание: Фиксированная коллекция типов событий в журнале регистрации. Содержит как системные типы событий, так и пользовательские, определенные в файле 1cv7evt.txt. Поиск данного файла осуществляется в том же каталоге, где находится журнал регистрации.


ПоставщикДанныхЖурналРегистрации / LogProvider::Отбор / Filter

1C++ :: Поставщик данных - журнал регистрации | Ранее: ТипыСобытий / EventTypes | Далее: УстановитьПериод / SetPeriod
ПоставщикДанныхЖурналРегистрации / LogProvider :: Отбор / Filter

Доступ: чтение.

Тип: Отбор.

Описание: Коллекция содержит элементы отбора, соответствующие установленному отбору методами ИзменитьФильтр и УстановитьФильтр.


ПоставщикДанныхЖурналРегистрации / LogProvider::УстановитьПериод / SetPeriod

1C++ :: Поставщик данных - журнал регистрации | Ранее: Отбор / Filter | Далее: УстановитьПериодРасш / SetPeriodEx
ПоставщикДанныхЖурналРегистрации / LogProvider :: УстановитьПериод / SetPeriod

Синтаксис: УстановитьПериод([ДатаНачала],[ДатаКонца])

Параметры:

  • ДатаНачала - тип: Дата. Определяет дату начала периода, с которой будут отображаться записи журнала регистрации. Необязателен, по умолчанию пустая дата. Если не указан, то началом периода считается начало журнала;
  • ДатаКонца - тип: Дата. Определяет дату конца периода, по которую будут отображаться записи журнала регистрации. Необязателен, по умолчанию пустая дата. Если не указан, то концом периода считается конец журнала журнала.

Возвращает: тип: Число. 1 - вызов метода закончился успешно, 0 - в противном случае.

Описание: Устанавливает период просмотра записей журнала регистрации.

Если оба параметра не указаны, то отображается весь журнал. Алгоритм поиска границ предполагает, что записи в журнале расположены в порядке возрастания дат. Если это условие не выполняется, то данный метод может работать некорректно.

Если до изменения периода были установлен отбор с сохранением позиций отобранных записей в буфере (см. метод УстановитьФильтр), то в случае увеличения периода происходит дополнительный отбор записей. При его прерывании клавишей <ESC> формируется исключение.


ПоставщикДанныхЖурналРегистрации / LogProvider::УстановитьПериодРасш / SetPeriodEx

1C++ :: Поставщик данных - журнал регистрации | Ранее: УстановитьПериод / SetPeriod | Далее: УстановитьГлубину / SetScanDeep
ПоставщикДанныхЖурналРегистрации / LogProvider :: УстановитьПериодРасш / SetPeriodEx

Синтаксис: УстановитьПериодРасш([ДатаНачала],[ВремяНачала],[ДатаКонца],[ВремяКонца])

Параметры:

  • ДатаНачала - тип: Дата. Определяет дату начала периода, с которой будут отображаться записи журнала регистрации. Необязателен, по умолчанию пустая дата. Если не указан, то началом периода считается начало журнала;
  • ВремяНачала - тип: Строка в формате "ЧЧ:ММ:СС". Определяет время начала периода, с которого будут отображаться записи журнала регистрации. Необязателен, по умолчанию "00:00:00".
  • ДатаКонца - тип: Дата. Определяет дату конца периода, по которую будут отображаться записи журнала регистрации. Необязателен, по умолчанию пустая дата. Если не указан, то концом периода считается конец журнала журнала.
  • ВремяКонца - тип: Строка в формате "ЧЧ:ММ:СС". Определяет время окончания периода, по которое будут отображаться записи журнала регистрации. Необязателен, по умолчанию "23:59:59".

Возвращает: тип: Число. 1 - вызов метода закончился успешно, 0 - в противном случае.

Описание: Устанавливает период просмотра записей журнала регистрации.

Метод служит для тех же целей, что и метод УстановитьПериод.


ПоставщикДанныхЖурналРегистрации / LogProvider::УстановитьГлубину / SetScanDeep

1C++ :: Поставщик данных - журнал регистрации | Ранее: УстановитьПериодРасш / SetPeriodEx | Далее: ИзменитьФильтр / ChangeFilter
ПоставщикДанныхЖурналРегистрации / LogProvider :: УстановитьГлубину / SetScanDeep

Синтаксис: УстановитьГлубину([Глубина],[ОбновитьТП])

Параметры:

  • Глубина - тип: Число. Количество попыток поиска строки, удовлетворяющей отбору. Необязателен, по умолчанию 0;
  • ОбновитьТП - тип: Число 0 или 1. Необходимость начать поиск строк сразу после изменения глубины просмотра. Необязателен, по умолчанию 1.

Возвращает: тип: Число. 1 - вызов метода закончился успешно, 0 - в противном случае.

Описание: Устанавливает количество попыток поиска строки, удовлетворяющей отбору.

Данный метод рекомендуется использовать совместно с установленным отбором в случае поиска заведомо редких событий.


ПоставщикДанныхЖурналРегистрации / LogProvider::ИзменитьФильтр / ChangeFilter

1C++ :: Поставщик данных - журнал регистрации | Ранее: УстановитьГлубину / SetScanDeep | Далее: Варианты отборов и возможные значения
ПоставщикДанныхЖурналРегистрации / LogProvider :: ИзменитьФильтр / ChangeFilter

Синтаксис: ИзменитьФильтр([ВариантОтбора],[ЗначениеОтбора])

Параметры:

  • ВариантОтбора - тип: Число согласно таблице Варианты отборов и возможные значения. При этом если число положительное, то данный вариант отбора устанавливается, если отрицательное, то сбрасывается. При значении параметра равным нулю отбор полностью сбрасывается. Необязателен, по умолчанию 0;
  • ЗначениеОтбора - тип: пустое значение, строка, объект агрегатного типа или список значений из них. Значение устанавливаемого отбора в зависимости от первого параметра. Необязателен, по умолчанию пустое значение.

Возвращает: тип: Число. 1 - вызов метода закончился успешно, 0 - в противном случае.

Описание: Добавляет или удаляет элемент отбора для просмотра записей журнала регистрации.

Все значения типа строка являются регистронезависимыми за исключением значений отбора по пользователю.

Типом объекта могут быть:

  • Перечисление;
  • Справочник;
  • Документ;
  • Календарь;
  • Вид расчета;
  • Счет;
  • Вид субконто;
  • План счетов.

Примеры использования метода:

ТабличноеПоле.ПоставщикДанных.ИзменитьФильтр(2, "ЕM"); // добавить фильтр по режиму "Предприятие" и "Монитор"
ТабличноеПоле.ПоставщикДанных.ИзменитьФильтр(22);      // добавить фильтр по событию "Документ записан"
ТабличноеПоле.ПоставщикДанных.ИзменитьФильтр(-62);     // удалить фильтр по событию "Изменена точка актуальности"
ТабличноеПоле.ПоставщикДанных.ИзменитьФильтр();        // сбросить все фильтры
  • Варианты отборов и возможные значения


Варианты отборов и возможные значения

1C++ :: Поставщик данных - журнал регистрации | Ранее: ИзменитьФильтр / ChangeFilter | Далее: УстановитьФильтр / SetFilter
Варианты отборов и возможные значения
Вариант отбора | Фильтруемое поле записи журнала | Значение поля | Режим | Категория | Описание | Возможное значение
 |  |  |  |  |  | Добавление | Удаление
1 | Пользователь |  | ECMD | 012345 |  | Строка с идентификатором пользователя или список значений из них. Для указания пустого пользователя использовать строку "<>". | Аналогично добавлению, или пустое значение, если полностью сбросить данный вариант отбора.
2 | Режим |  | ECMD | 012345 |  | Строка из символов 'E', 'C', 'M', 'D'. | Аналогично добавлению, или пустое значение, если полностью сбросить данный вариант отбора.
3 | Категория |  | ECMD | 012345 |  | Строка из символов '0', '1', '2', '3', '4', '5'. | Аналогично добавлению, или пустое значение, если полностью сбросить данный вариант отбора.
4 | Тип события | Sys | ECMD | 0 | Сеанс |  |
5 | Событие | OpenSession | ECMD | 0 | Подключение |  |
6 |  | CloseSession | ECMD | 0 | Отключение |  |
7 | Тип события | Consts | E | 2 | Константы |  |
8 | Событие | ConstWrite | E | 2 | Значение константы изменено |  |
9 |  | ConstDel | E | 2 | Значение константы удалено |  |
10 | Тип события | Refs | E | 2 | Справочники |  |
11 | Событие | RefNew | E | 2 | Записан новый элемент справочника |  |
12 |  | RefWrite | E | 2 | Элемент справочника записан |  |
13 |  | RefUnmarkDel | E | 2 | С элемента справочника снята пометка на удаление |  |
14 |  | RefDel | E | 2 | Элемент справочника удален |  |
15 |  | RefMarkDel | E | 2 | Элемент справочника помечен на удаление |  |
16 |  | RefGrpMove | E | 2 | Элемент справочника перенесен в другую группу |  |
17 |  | RefAttrWrite | E | 2 | Значение реквизита справочника изменено |  |
18 |  | RefAttrDel | E | 2 | Значение реквизита справочника удалено |  |
19 | Тип события | Docs | E | 23 | Документы |  |
20 | Событие | DocNew | E | 3 | Документ создан |  |
21 |  | DocOpen | E | 3 | Документ открыт |  |
22 |  | DocWrite | E | 2 | Документ записан |  |
23 |  | DocWriteNew | E | 2 | Записан новый документ |  |
24 |  | DocNotWrite | E | 3 | Документ не записан |  |
25 |  | DocPassed | E | 2 | Документ проведен |  |
26 |  | DocBackPassed | E | 2 | Документ проведен задним числом |  |
27 |  | DocNotPassed | E | 2 | Документ не проведен |  |
28 |  | DocMakeNotPassed | E | 2 | Документ сделан непроведенным |  |
29 |  | DocWriteAndRepassed | E | 2 | Документ записан и проведен |  |
30 |  | DocWriteAndPostBfAP | E | 2 | Документ записан и проведен задним числом |  |
31 |  | DocTimeChanged | E | 2 | Изменено время документа |  |
32 |  | DocOperWrite | E | 2 | Операция документа изменена |  |
33 |  | DocOperOn | E | 2 | Проводки включены |  |
34 |  | DocOperOff | E | 2 | Проводки выключены |  |
35 |  | DocMarkDel | E | 2 | Документ помечен на удаление |  |
36 |  | DocUnmarkDel | E | 2 | Пометка на удаление документа снята |  |
37 |  | DocDel | E | 2 | Документ удален |  |
38 | Тип события | CJ | E | 2 | Журнал расчетов |  |
39 | Событие | CJPerChng | E | 2 | Изменен текущий расчетный период в журнале расчетов |  |
40 |  | CJPerBackChng | E | 2 | Откат назад текущего расчетного периода в журнале расчетов |  |
41 |  | CJPerNotChng | E | 2 | Неудачная попытка изменения текущего расчетного периода в журнале расчетов |  |
42 |  | CJUneditRec | E | 2 | Отмена ручного редактирования результата расчета в журнале расчетов |  |
43 |  | CJEditRec | E | 2 | Отредактирован результат расчета в журнале расчетов |  |
44 | Тип события | Accs | E | 23 | Счета |  |
45 | Событие | AccNew | E | 3 | Записан новый счет |  |
46 |  | AccWrite | E | 2 | Счет записан |  |
47 |  | AccDel | E | 2 | Счет удален |  |
48 |  | AccMarkDel | E | 2 | Счет помечен на удаление |  |
49 |  | AccUnmarkDel | E | 2 | Со счета снята пометка на удаление |  |
50 |  | AccAttrWrite | E | 2 | Значение реквизита счета записано |  |
51 |  | AccAttrDel | E | 2 | Значение реквизита счета удалено |  |
52 | Тип события | CorrProvs | E | 2 | Корректные проводки |  |
53 | Событие | CorrProvNew | E | 2 | Записана новая корректная проводка |  |
54 |  | CorrProvEdit | E | 2 | Корректная проводка изменена |  |
55 |  | CorrProvDel | E | 2 | Корректная проводка удалена |  |
56 | Тип события | TmplOpers | E | 2 | Типовые операции |  |
57 | Событие | TmplOperNew | E | 2 | Записана новая типовая операция |  |
58 |  | TmplOperWrite | E | 2 | Типовая операция записана |  |
59 |  | TmplOperDel | E | 2 | Типовая операция удалена |  |
60 |  | TmplOperGrpMove | E | 2 | Типовая операция перенесена в другую группу |  |
61 | Тип события | Grbgs | EM | 125 | Общие события |  |
62 | Событие | GrbgTAChng | E | 2 | Изменена точка актуальности |  |
63 |  | GrbgSnapChng | E | 2 | Изменен период сохранения итогов |  |
64 |  | GrbgRclcDocs | E | 2 | Групповое проведение документов |  |
65 |  | GrbgNewPerBuhTot | E | 2 | Бухгалтерские итоги рассчитаны |  |
66 |  | GrbgRclcAllBuhTot | E | 2 | Полный пересчет бухгалтерских итогов |  |
67 |  | GrbgLogArch | M | 1 | Архивирование журнала регистрации |  |
68 |  | GrbgSyntaxErr | E | 5 | Синтаксическая ошибка |  |
69 |  | GrbgRuntimeErr | E | 5 | Ошибка времени выполнения |  |
70 | Тип события | Restruct | C | 1345 | Конфигурация |  |
71 | Событие | RestructSaveMD | C | 3 | Запись измененной конфигурации |  |
72 |  | RestructStart | C | 1 | Начало реструктуризации |  |
73 |  | RestructCopy | C | 1 | Начало копирования результатов реструктуризации |  |
74 |  | RestructAcptEnd | C | 1 | Реструктуризация завершена |  |
75 |  | RestructStatus | C | 3 | Статус реструктуризации |  |
76 |  | RestructAnalys | C | 3 | Анализ информации |  |
77 |  | RestructWarn | C | 4 | Предупреждение |  |
78 |  | RestructErr | C | 5 | Ошибка при реструктуризации |  |
79 |  | RestructCritErr | C | 5 | Критическая ошибка при реструктуризации |  |
80 | Тип события | Distr | C | 15 | Распределенная ИБ |  |
81 | Событие | DistBatchErr | C | 5 | Ошибка автообмена в пакетном режиме |  |
82 |  | DistDnldBeg | C | 1 | Начата выгрузка изменений данных |  |
83 |  | DistDnldSuc | C | 1 | Выгрузка изменений данных успешно завершена |  |
84 |  | DistDnldFail | C | 1 | Выгрузка изменений данных не выполнена |  |
85 |  | DistDnlErr | C | 5 | Ошибка выгрузки изменений данных |  |
86 |  | DistDnlStatus | C | 1 | Выгрузка изменений данных |  |
87 |  | DistUplBeg | C | 1 | Начата загрузка изменений данных |  |
88 |  | DistUplSuc | C | 1 | Загрузка изменений данных успешно завершена |  |
89 |  | DistUplFail | C | 1 | Загрузка изменений данных не выполнена |  |
90 |  | DistUplErr | C | 5 | Ошибка загрузки изменений данных |  |
91 |  | DistUplStatus | C | 1 | Загрузка изменений данных |  |
92 |  | DistDnldPrimBeg | C | 1 | Первичная выгрузка периферийной ИБ |  |
93 |  | DistDnldPrimSuc | C | 1 | Первичная выгрузка периферийной ИБ успешно завершена |  |
94 |  | DistDnldPrimFail | C | 1 | Первичная выгрузка периферийной ИБ не выполнена |  |
95 |  | DistDnldPrimErr | C | 5 | Ошибка первичной выгрузки периферийной ИБ |  |
96 |  | DistInit | C | 1 | Распределенная ИБ инициализирована |  |
97 |  | DistPIBCreat | C | 1 | Создана периферийная ИБ |  |
98 |  | DistPIBDel | C | 1 | Удалена периферийная ИБ |  |
99 |  | DistIBModi | C | 1 | Изменены параметры ИБ |  |
100 |  | DistAEParam | C | 1 | Изменены параметры автообмена |  |
101 | Тип события | UpDown | C | 15 | Выгрузка / загрузка данных |  |
103 | Событие | UpDownDnldToFile | C | 1 | Выгрузка ИБ |  |
104 |  | UpDownDnldSuc | C | 1 | Выгрузка ИБ успешно завершена |  |
105 |  | UpDownDnldFail | C | 1 | Выгрузка ИБ не выполнена |  |
106 |  | UpDownDnldErr | C | 5 | Ошибка выгрузки данных |  |
107 |  | UpDownUplFromFile | C | 1 | Загрузка ИБ |  |
108 |  | UpDownUplSuc | C | 1 | Загрузка ИБ успешно завершена |  |
109 |  | UpDownUplFail | C | 1 | Загрузка ИБ не выполнена |  |
110 |  | UpDownUplErr | C | 5 | Ошибка загрузки данных |  |
111 | Тип события | Archive | C | 15 | Сохранение / восстановление |  |
112 | Событие | ArchiveStart | C | 1 | Начало сохранения |  |
113 |  | ArchiveEnd | C | 1 | Завершение сохранения |  |
114 |  | DearchiveStart | C | 1 | Начало восстановления |  |
115 |  | DearchiveEnd | C | 1 | Завершение восстановления |  |
116 |  | ArchiveError | C | 5 | Ошибка при сохранении / восстановлении |  |
118 | Тип события | Batch | ECMD | 15 | Пакетный режим |  |
121 | Событие | BatchErr | ECMD | 5 | Ошибка при работе в пакетном режиме |  |
122 | Тип события | UsrDef | C | 1 | Пользователи |  |
123 | Тип события | Doctor | C | 15 | Тестирование и исправление ИБ |  |
124 | Событие | dctTRBeg | C | 1 | Начало тестирования и исправления |  |
125 |  | dctTBeg | C | 1 | Начало тестирования |  |
126 |  | dctPhInt | C | 1 | Контроль физической целостности |  |
127 |  | dctReind | C | 1 | Реиндексация таблиц ИБ |  |
128 |  | dctLgInt | C | 1 | Контроль логической целостности |  |
129 |  | dctRcST | C | 1 | Пересчет служебных данных |  |
130 |  | dctRcT | C | 1 | Пересчет итогов |  |
131 |  | dctTREnd | C | 1 | Окончание тестирования и исправления |  |
132 |  | dctTEnd | C | 1 | Окончание тестирования |  |
133 |  | dctErr | C | 5 | Ошибка ИБ |  |
134 |  | dctPck | C | 1 | Упаковка таблиц ИБ |  |
135 | Тип события | User | E | 012345 | Другие события |  |
136 | Событие | UserMsg | E | 012345 | Дополнительное событие |  |
137 |  |  | E | 012345 | Любое событие пользователя | Строка с идентификатором события или список значений из них. | Аналогично добавлению, или пустое значение, если полностью сбросить данный вариант отбора.
138 | Тип события |  | E | 012345 | Любой тип события пользователя | Строка с идентификатором типа события или список значений из них. | Аналогично добавлению, или пустое значение, если полностью сбросить данный вариант отбора.
139 | Комментарий |  | ECMD | 012345 |  | Подстрока для поиска в комментарии |
140 | Объект |  | E | 012345 | Вид объекта | Строка с идентификатором вида объекта или список значений из них. | Аналогично добавлению, или пустое значение, если полностью сбросить данный вариант отбора.
141 | Объект |  | E | 012345 | Объект | Объект агрегатного типа или список значений из них. | Аналогично добавлению, или пустое значение, если полностью сбросить данный вариант отбора.
142 | Представление |  | E | 012345 |  | Подстрока для поиска в представлении |


ПоставщикДанныхЖурналРегистрации / LogProvider::УстановитьФильтр / SetFilter

1C++ :: Поставщик данных - журнал регистрации | Ранее: Варианты отборов и возможные значения | Далее: ОткрытьФайл / OpenFile
ПоставщикДанныхЖурналРегистрации / LogProvider :: УстановитьФильтр / SetFilter

Синтаксис: УстановитьФильтр([ИспользоватьБуфер])

Параметры:

  • ИспользоватьБуфер - тип: Число. 0 - буфер не используется (осуществляется динамический отбор), 1 - позиции отобранных записей сохраняются в буфере. Необязателен, по умолчанию 0.

Возвращает: тип: Число. 1 - изменения отбора корректны и начат отбор записей, 0 - в противном случае.

Описание: Проверяет на корректность изменения отбора методом ИзменитьФильтр и начинает отбор записей. Если используется буфер, то при прерывании отбора клавишей <ESC> формируется исключение. Если провайдер является поставщиком данных табличного поля, то выполнение процесса отбора в процентах отображается в строке состояния.


ПоставщикДанныхЖурналРегистрации / LogProvider::ОткрытьФайл / OpenFile

1C++ :: Поставщик данных - журнал регистрации | Ранее: УстановитьФильтр / SetFilter | Далее: ЗакрытьФайл / CloseFile
ПоставщикДанныхЖурналРегистрации / LogProvider :: ОткрытьФайл / OpenFile

Синтаксис: ОткрытьФайл()

Возвращает: тип: Число. 1 - файл журнала регистрации открыт, 0 - в противном случае.

Описание: Открывает файл журнала регистрации для последующей выборки записей методом ВыбратьСтроки.


ПоставщикДанныхЖурналРегистрации / LogProvider::ЗакрытьФайл / CloseFile

1C++ :: Поставщик данных - журнал регистрации | Ранее: ОткрытьФайл / OpenFile | Далее: ВыбратьСтроки / SelectLines
ПоставщикДанныхЖурналРегистрации / LogProvider :: ЗакрытьФайл / CloseFile

Синтаксис: ЗакрытьФайл()

Описание: Закрывает открытый файл журнала регистрации.


ПоставщикДанныхЖурналРегистрации / LogProvider::ВыбратьСтроки / SelectLines

1C++ :: Поставщик данных - журнал регистрации | Ранее: ЗакрытьФайл / CloseFile | Далее: ПолучитьСтроку / GetLine
ПоставщикДанныхЖурналРегистрации / LogProvider :: ВыбратьСтроки / SelectLines

Синтаксис: ВыбратьСтроки([Смещение])

Параметры:

  • Смещение - тип: Число. Определяет, с какого смещения в байтах от начала журнала регистрации производить выборку записей журнала регистрации. Необязателен, по умолчанию 0. Для выборки записей с начала временного файла параметр должен быть равен -1.

Возвращает: тип: Число. 1 - выборка начата, 0 - в противном случае.

Описание: Метод определяет, на какую запись указывает переданное смещение, и устанавливает выборку с этой записи.


ПоставщикДанныхЖурналРегистрации / LogProvider::ПолучитьСтроку / GetLine

1C++ :: Поставщик данных - журнал регистрации | Ранее: ВыбратьСтроки / SelectLines | Далее: ТипыСобытийЖурналаРегистрации / LogEventTypes
ПоставщикДанныхЖурналРегистрации / LogProvider :: ПолучитьСтроку / GetLine

Синтаксис: ПолучитьСтроку()

Возвращает: тип: Число. 1 - строка получена, 0 - в противном случае.

Описание: Выполняет позиционирование на очередную запись из выборки. Если перед получением строки установлен период и (или) отбор, то получение записи осуществляется с учетом периода и отбора. При прерывании данной операции клавишей <ESC> формируется исключение.


ТипыСобытийЖурналаРегистрации / LogEventTypes

1C++ :: Поставщик данных - журнал регистрации | Ранее: ПолучитьСтроку / GetLine | Далее: <ТипСобытия>
ТипыСобытийЖурналаРегистрации / LogEventTypes

Фиксированная коллекция типов событий в журнале регистрации. Элементы коллекции - объекты типа ТипСобытияЖурналаРегистрации. Индексы типов событий - от нуля до количества типов событий минус один.

Свойства

<ТипСобытия> Набор свойств содержит идентификаторы типов событий журнала регистрации. Доступ к значению осуществляется по идентификатору типа события.

Методы

Количество / Count | Получить количество типов событий.
Получить / Get | Получить тип события журнала регистрации.
Индекс / IndexOf | Получить индекс типа события.


ТипыСобытийЖурналаРегистрации / LogEventTypes::<ТипСобытия>

1C++ :: Поставщик данных - журнал регистрации | Ранее: ТипыСобытийЖурналаРегистрации / LogEventTypes | Далее: Количество / Count
ТипыСобытийЖурналаРегистрации / LogEventTypes :: <ТипСобытия>

Доступ: только чтение.

Тип: ТипСобытияЖурналаРегистрации.

Описание: Набор свойств содержит идентификаторы типов событий журнала регистрации. Доступ к значению осуществляется по идентификатору типа события.


ТипыСобытийЖурналаРегистрации / LogEventTypes::Количество / Count

1C++ :: Поставщик данных - журнал регистрации | Ранее: <ТипСобытия> | Далее: Получить / Get
ТипыСобытийЖурналаРегистрации / LogEventTypes :: Количество / Count

Синтаксис: Количество()

Возвращает: тип: Число, количество типов событий.

Описание: Получить количество типов событий.


ТипыСобытийЖурналаРегистрации / LogEventTypes::Получить / Get

1C++ :: Поставщик данных - журнал регистрации | Ранее: Количество / Count | Далее: Индекс / IndexOf
ТипыСобытийЖурналаРегистрации / LogEventTypes :: Получить / Get

Синтаксис: Получить(ТипСобытия)

Параметры:

  • ТипСобытия - тип: Число, Строка. Индекс или идентификатор типа события.

Возвращает: тип: ТипСобытияЖурналаРегистрации.

Описание: Получить тип события журнала регистрации.


ТипыСобытийЖурналаРегистрации / LogEventTypes::Индекс / IndexOf

1C++ :: Поставщик данных - журнал регистрации | Ранее: Получить / Get | Далее: ТипСобытияЖурналаРегистрации / LogEventType
ТипыСобытийЖурналаРегистрации / LogEventTypes :: Индекс / IndexOf

Синтаксис: Индекс(ТипСобытия)

Параметры:

  • ТипСобытия - тип: ТипСобытияЖурналаРегистрации. Тип события, индекс которого требуется получить.

Возвращает: тип: Число - индекс типа события, или -1, если тип события не принадлежит коллекции.

Описание: Получить индекс типа события.


ТипСобытияЖурналаРегистрации / LogEventType

1C++ :: Поставщик данных - журнал регистрации | Ранее: Индекс / IndexOf | Далее: Индекс / Index
ТипСобытияЖурналаРегистрации / LogEventType

Объект для получения информации о типе события журнала регистрации.

Свойства

Индекс / Index | Значение данного свойства соответствует варианту отбора, используемому в методе ИзменитьФильтр (см. Варианты отборов и возможные значения).
Идентификатор / Identifier | Идентификатор типа события.
Описание / Description | Описание типа события.
Системный / IsSystem | Является данный тип события системным или пользовательским.
События / Events | Содержит события, принадлежащие данному типу.


ТипСобытияЖурналаРегистрации / LogEventType::Индекс / Index

1C++ :: Поставщик данных - журнал регистрации | Ранее: ТипСобытияЖурналаРегистрации / LogEventType | Далее: Идентификатор / Identifier
ТипСобытияЖурналаРегистрации / LogEventType :: Индекс / Index

Доступ: только чтение.

Тип: Число.

Описание: Значение данного свойства соответствует варианту отбора, используемому в методе ИзменитьФильтр (см. Варианты отборов и возможные значения).


ТипСобытияЖурналаРегистрации / LogEventType::Идентификатор / Identifier

1C++ :: Поставщик данных - журнал регистрации | Ранее: Индекс / Index | Далее: Описание / Description
ТипСобытияЖурналаРегистрации / LogEventType :: Идентификатор / Identifier

Доступ: только чтение.

Тип: Строка.

Описание: Идентификатор типа события.


ТипСобытияЖурналаРегистрации / LogEventType::Описание / Description

1C++ :: Поставщик данных - журнал регистрации | Ранее: Идентификатор / Identifier | Далее: Системный / IsSystem
ТипСобытияЖурналаРегистрации / LogEventType :: Описание / Description

Доступ: только чтение.

Тип: Строка.

Описание: Описание типа события.


ТипСобытияЖурналаРегистрации / LogEventType::Системный / IsSystem

1C++ :: Поставщик данных - журнал регистрации | Ранее: Описание / Description | Далее: События / Events
ТипСобытияЖурналаРегистрации / LogEventType :: Системный / IsSystem

Доступ: только чтение.

Тип: Число: 0 или 1.

Описание: Является данный тип события системным или пользовательским.


ТипСобытияЖурналаРегистрации / LogEventType::События / Events

1C++ :: Поставщик данных - журнал регистрации | Ранее: Системный / IsSystem | Далее: СобытияЖурналаРегистрации / LogEvents
ТипСобытияЖурналаРегистрации / LogEventType :: События / Events

Доступ: только чтение.

Тип: Фиксированная коллекция СобытияЖурналаРегистрации.

Описание: Содержит события, принадлежащие данному типу.


СобытияЖурналаРегистрации / LogEvents

1C++ :: Поставщик данных - журнал регистрации | Ранее: События / Events | Далее: <Событие>
СобытияЖурналаРегистрации / LogEvents

Фиксированная коллекция событий в журнале регистрации, принадлежащих определенному типу. Элементы коллекции - объекты типа СобытиеЖурналаРегистрации. Индексы событий - от нуля до количества событий минус один.

Свойства

<Событие> Набор свойств содержит идентификаторы событий журнала регистрации. Доступ к значению осуществляется по идентификатору события.

Методы

Количество / Count | Получить количество событий.
Получить / Get | Получить событие журнала регистрации.
Индекс / IndexOf | Получить индекс события.


СобытияЖурналаРегистрации / LogEvents::<Событие>

1C++ :: Поставщик данных - журнал регистрации | Ранее: СобытияЖурналаРегистрации / LogEvents | Далее: Количество / Count
СобытияЖурналаРегистрации / LogEvents :: <Событие>

Доступ: только чтение.

Тип: СобытиеЖурналаРегистрации.

Описание: Набор свойств содержит идентификаторы событий журнала регистрации. Доступ к значению осуществляется по идентификатору события.


СобытияЖурналаРегистрации / LogEvents::Количество / Count

1C++ :: Поставщик данных - журнал регистрации | Ранее: <Событие> | Далее: Получить / Get
СобытияЖурналаРегистрации / LogEvents :: Количество / Count

Синтаксис: Количество()

Возвращает: тип: Число, количество событий.

Описание: Получить количество событий.


СобытияЖурналаРегистрации / LogEvents::Получить / Get

1C++ :: Поставщик данных - журнал регистрации | Ранее: Количество / Count | Далее: Индекс / IndexOf
СобытияЖурналаРегистрации / LogEvents :: Получить / Get

Синтаксис: Получить(Событие)

Параметры:

  • Событие - тип: Число, Строка. Индекс или идентификатор события.

Возвращает: тип: СобытиеЖурналаРегистрации.

Описание: Получить событие журнала регистрации.


СобытияЖурналаРегистрации / LogEvents::Индекс / IndexOf

1C++ :: Поставщик данных - журнал регистрации | Ранее: Получить / Get | Далее: СобытиеЖурналаРегистрации / LogEvent
СобытияЖурналаРегистрации / LogEvents :: Индекс / IndexOf

Синтаксис: Индекс(Событие)

Параметры:

  • Событие - тип: СобытиеЖурналаРегистрации. Событие, индекс которого требуется получить.

Возвращает: тип: Число - индекс события, или -1, если событие не принадлежит коллекции.

Описание: Получить индекс события.


СобытиеЖурналаРегистрации / LogEvent

1C++ :: Поставщик данных - журнал регистрации | Ранее: Индекс / IndexOf | Далее: Индекс / Index
СобытиеЖурналаРегистрации / LogEvent

Объект для получения информации о событии журнала регистрации.

Свойства

Индекс / Index | Значение данного свойства соответствует варианту отбора, используемому в методе ИзменитьФильтр (см. Варианты отборов и возможные значения).
Идентификатор / Identifier | Идентификатор события.
Описание / Description | Описание события.
Системное / IsSystem | Является данное событие системным или пользовательским.


СобытиеЖурналаРегистрации / LogEvent::Индекс / Index

1C++ :: Поставщик данных - журнал регистрации | Ранее: СобытиеЖурналаРегистрации / LogEvent | Далее: Идентификатор / Identifier
СобытиеЖурналаРегистрации / LogEvent :: Индекс / Index

Доступ: только чтение.

Тип: Число.

Описание: Значение данного свойства соответствует варианту отбора, используемому в методе ИзменитьФильтр (см. Варианты отборов и возможные значения).


СобытиеЖурналаРегистрации / LogEvent::Идентификатор / Identifier

1C++ :: Поставщик данных - журнал регистрации | Ранее: Индекс / Index | Далее: Описание / Description
СобытиеЖурналаРегистрации / LogEvent :: Идентификатор / Identifier

Доступ: только чтение.

Тип: Строка.

Описание: Идентификатор события.


СобытиеЖурналаРегистрации / LogEvent::Описание / Description

1C++ :: Поставщик данных - журнал регистрации | Ранее: Идентификатор / Identifier | Далее: Системное / IsSystem
СобытиеЖурналаРегистрации / LogEvent :: Описание / Description

Доступ: только чтение.

Тип: Строка.

Описание: Описание события.


СобытиеЖурналаРегистрации / LogEvent::Системное / IsSystem

1C++ :: Поставщик данных - журнал регистрации | Ранее: Описание / Description | Далее: Отбор / Filter
СобытиеЖурналаРегистрации / LogEvent :: Системное / IsSystem

Доступ: только чтение.

Тип: Число: 0 или 1.

Описание: Является данное событие системным или пользовательским.


Отбор / Filter

1C++ :: Поставщик данных - журнал регистрации | Ранее: Системное / IsSystem | Далее: <ЭлементОтбора>
Отбор / Filter

Коллекция содержит элементы отбора, соответствующие установленному отбору методами ИзменитьФильтр и УстановитьФильтр.

Свойства

<ЭлементОтбора> Набор свойств содержит элементы отбора. Доступ к значению осуществляется по имени элемента.

Методы

Количество / Count | Получить количество элементов отбора.
Получить / Get | Получить элемента отбора.
Индекс / IndexOf | Получить индекс элемента отбора.
Добавить / Add | Добавляет новый элемент отбора в журнале регистрации, если элемента отбора с данным именем не существует, или возвращает существующий элемент отбора по имени.
Удалить / Remove | Удаляет элемент отбора в журнале регистрации.
Очистить / Clear | Удаляет все элементы отбора в журнале регистрации.
Установить / Set | Выполняются действия аналогичные действиями при использовании метода УстановитьФильтр. Состав отбора определяется элементами коллекции.


Отбор / Filter::<ЭлементОтбора>

1C++ :: Поставщик данных - журнал регистрации | Ранее: Отбор / Filter | Далее: Количество / Count
Отбор / Filter :: <ЭлементОтбора>

Доступ: только чтение.

Тип: ЭлементОтбора.

Описание: Набор свойств содержит элементы отбора. Доступ к значению осуществляется по имени элемента.


Отбор / Filter::Количество / Count

1C++ :: Поставщик данных - журнал регистрации | Ранее: <ЭлементОтбора> | Далее: Получить / Get
Отбор / Filter :: Количество / Count

Синтаксис: Количество()

Возвращает: тип: Число, количество элементов отбора.

Описание: Получить количество элементов отбора.


Отбор / Filter::Получить / Get

1C++ :: Поставщик данных - журнал регистрации | Ранее: Количество / Count | Далее: Индекс / IndexOf
Отбор / Filter :: Получить / Get

Синтаксис: Получить(ЭлементОтбора)

Параметры:

  • ЭлементОтбора - тип: Число, Строка. Индекс или имя элемента отбора.

Возвращает: тип: ЭлементОтбора.

Описание: Получить элемента отбора.


Отбор / Filter::Индекс / IndexOf

1C++ :: Поставщик данных - журнал регистрации | Ранее: Получить / Get | Далее: Добавить / Add
Отбор / Filter :: Индекс / IndexOf

Синтаксис: Индекс(ЭлементОтбора)

Параметры:

  • ЭлементОтбора - тип: ЭлементОтбора. Элемент отбора, индекс которого требуется получить.

Возвращает: тип: Число - индекс элемента отбора, или -1, если элемент отбора не принадлежит коллекции.

Описание: Получить индекс элемента отбора.


Отбор / Filter::Добавить / Add

1C++ :: Поставщик данных - журнал регистрации | Ранее: Индекс / IndexOf | Далее: Удалить / Remove
Отбор / Filter :: Добавить / Add

Синтаксис: Добавить(Имя)

Параметры:

  • Имя - тип: Строка. Имя добавляемого элемента отбора.

Возвращает: тип: ЭлементОтбора - созданный элемента отбора.

Описание: Добавляет новый элемент отбора в журнале регистрации, если элемента отбора с данным именем не существует, или возвращает существующий элемент отбора по имени.


Отбор / Filter::Удалить / Remove

1C++ :: Поставщик данных - журнал регистрации | Ранее: Добавить / Add | Далее: Очистить / Clear
Отбор / Filter :: Удалить / Remove

Синтаксис: Удалить(Индекс)

Параметры:

  • Индекс - тип: Число. Индекс элемента отбора.

Описание: Удаляет элемент отбора в журнале регистрации.


Отбор / Filter::Очистить / Clear

1C++ :: Поставщик данных - журнал регистрации | Ранее: Удалить / Remove | Далее: Установить / Set
Отбор / Filter :: Очистить / Clear

Синтаксис: Очистить()

Описание: Удаляет все элементы отбора в журнале регистрации.


Отбор / Filter::Установить / Set

1C++ :: Поставщик данных - журнал регистрации | Ранее: Очистить / Clear | Далее: ЭлементОтбора / FilterItem
Отбор / Filter :: Установить / Set

Синтаксис: Установить([ИспользоватьБуфер])

Параметры:

  • ИспользоватьБуфер - тип: Число. 0 - буфер не используется (осуществляется динамический отбор), 1 - позиции отобранных записей сохраняются в буфере. Необязателен, по умолчанию 0.

Возвращает: тип: Число. 1 - изменения отбора корректны и начат отбор записей, 0 - в противном случае.

Описание: Выполняются действия аналогичные действиями при использовании метода УстановитьФильтр. Состав отбора определяется элементами коллекции.


ЭлементОтбора / FilterItem

1C++ :: Поставщик данных - журнал регистрации | Ранее: Установить / Set | Далее: Тип / Type
ЭлементОтбора / FilterItem

Объект для управления отбором в журнале регистрации.

Свойства

Тип / Type | Тип элемента отбора.
Значение / Value | Значение элемента отбора.
Имя / Name | Имя элемента отбора. Может быть произвольным.

Методы

УстановитьТипИЗначение / SetTypeAndValue Установить тип и значение для элемента отбора.


ЭлементОтбора / FilterItem::Тип / Type

1C++ :: Поставщик данных - журнал регистрации | Ранее: ЭлементОтбора / FilterItem | Далее: Значение / Value
ЭлементОтбора / FilterItem :: Тип / Type

Доступ: только чтение.

Тип: Число.

Описание: Тип элемента отбора.

Типом элемента отбора могут быть:

  • 0 - не определен;
  • 3 - пользователь;
  • 4 - режим;
  • 5 - тип события;
  • 6 - событие;
  • 7 - категория;
  • 8 - комментарий;
  • 9 - объект;
  • 10 - представление;
  • 11 - вид объекта.


ЭлементОтбора / FilterItem::Значение / Value

1C++ :: Поставщик данных - журнал регистрации | Ранее: Тип / Type | Далее: Тип элемента отбора и возможное значение элемента отбора
ЭлементОтбора / FilterItem :: Значение / Value

Доступ: только чтение.

Тип: Зависит от типа отбора.

Описание: Значение элемента отбора.

  • Тип элемента отбора и возможное значение элемента отбора


Тип элемента отбора и возможное значение элемента отбора

1C++ :: Поставщик данных - журнал регистрации | Ранее: Значение / Value | Далее: Имя / Name
Тип элемента отбора и возможное значение элемента отбора
Тип элемента отбора | Тип значения отбора
3 | Строка
4 | Символ 'C', 'D', 'M' или 'E'.
5 | ТипСобытияЖурналаРегистрации или строка с идентификатором типа события.
6 | СобытиеЖурналаРегистрации или строка с идентификатором события.
7 | Число 0, 1, 2, 3, 4, или 5.
8 | Строка.
9 | Объект агрегатного типа.
10 | Строка.
11 | Строка.


ЭлементОтбора / FilterItem::Имя / Name

1C++ :: Поставщик данных - журнал регистрации | Ранее: Тип элемента отбора и возможное значение элемента отбора | Далее: УстановитьТипИЗначение / SetTypeAndValue
ЭлементОтбора / FilterItem :: Имя / Name

Доступ: только чтение.

Тип: Строка.

Описание: Имя элемента отбора. Может быть произвольным.


ЭлементОтбора / FilterItem::УстановитьТипИЗначение / SetTypeAndValue

1C++ :: Поставщик данных - журнал регистрации | Ранее: Имя / Name | Далее:
ЭлементОтбора / FilterItem :: УстановитьТипИЗначение / SetTypeAndValue

Синтаксис: УстановитьТипИЗначение([ТипОтбора],[ЗначениеОтбора])

Параметры:

  • ТипОтбора - тип: Число. См. описание свойства ТипОтбора. Необязателен, по умолчанию 0.
  • ЗначениеОтбора - тип: зависит от типа отбора (см. Тип и значение элемента отбора) Необязателен, по умолчанию пустое значение.

Возвращает: тип: Число: 1 - тип и значение установлены, 0 - в противном случае.

Описание: Установить тип и значение для элемента отбора.