Math

Math

Класс Математика / Math

Класс элементарной математики. Включает битовые операции и методы конверсии строк в числа.

Методы

Число / Long
Double
ABS
ACOS
ASIN
ATAN
ATAN2
CEIL
COPYSIGN
COS
COSH
EXP
FLOOR
FMOD
FREXP
HYPOT
LDEXP
LDIV
LOG
LOG10
MODF
PI
POW
RAND
RAND1
ROTL
ROTR
SHL
SHR
SIN
SINH
SQRT
SRAND
TAN
TANH
BITAND
BITOR
COMPL
XOR


Math::Число / Long

1C++ :: Math | Ранее: Math | Далее: Double
Math :: Число / Long
Синтаксис:

Long(Параметр, чБаза =0)
Параметры:
  • Параметр: Число или Строка

    Число или Строка, которые нужно перевести в тип Long

  • чБаза:

    База числа
Возвращает:

Число
Описание:
Переводит переданный параметр в тип Long.
При этом строка должна иметь следующий формат:

[whitespace] [{+ | -}] [0 [{ x | X }]] [digits]

A whitespace may consist of space and tab characters, which are ignored; digits are one or more decimal digits. The first character that does not fit this form stops the scan. If base is between 2 and 36, then it is used as the base of the number. If base is 0, the initial characters of the string are used to determine the base. If the first character is 0 and the second character is not 'x' or 'X', the string is interpreted as an octal integer; otherwise, it is interpreted as a decimal number. If the first character is '0' and the second character is 'x' or 'X', the string is interpreted as a hexadecimal integer. If the first character is '1' through '9', the string is interpreted as a decimal integer. The letters 'a' through 'z' (or 'A' through 'Z') are assigned the values 10 through 35; only letters whose assigned values are less than base are permitted.

Т.е. стандарным образом можно задавать десятичные, шестнадцатеричные и восьмеричные числа.
Если второй параметр равен нулю, база определяется автоматически,
иначе используется переданная база. База не может быть больше 36.
Примеры:
Long("0x100") == 256
Long("100", 2) == 4


Math::Double

1C++ :: Math | Ранее: Число / Long | Далее: ABS
Math :: Double
Синтаксис:

Double(Параметр)
Параметры:
  • Параметр: Число или Строка

    Число или Строка, которые нужно перевести в тип Double
Возвращает:

Число
Описание:
Переводит переданную строку в тип Double.
При этом строка должна иметь следующий формат:

[whitespace] [sign] [digits] [.digits] [ {d | D | e | E}[sign]digits]

A whitespace may consist of space and tab characters, which are ignored; sign is either plus (+) or minus (-); and digits are one or more decimal digits. If no digits appear before the radix character, at least one must appear after the radix character. The decimal digits can be followed by an exponent, which consists of an introductory letter (d, D, e, or E) and an optionally signed integer. If neither an exponent part nor a radix character appears, a radix character is assumed to follow the last digit in the string. The first character that does not fit this form stops the scan.

Таким образом можно легко задавать числа с плавающей точкой.
Примеры:
Double("-1.5e+3") == -1500


Math::ABS

1C++ :: Math | Ранее: Double | Далее: ACOS
Math :: ABS
Синтаксис:

ABS(Параметр)
Параметры:
  • Параметр: Число или Строка
Возвращает:
Число
Абсолютное значение x
Описание:

Возвращает abs(x)


Math::ACOS

1C++ :: Math | Ранее: ABS | Далее: ASIN
Math :: ACOS
Синтаксис:

ACOS(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Арккосинус x
Описание:

Возвращает acos(x)


Math::ASIN

1C++ :: Math | Ранее: ACOS | Далее: ATAN
Math :: ASIN
Синтаксис:

ASIN(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Арксинус x
Описание:

Возвращает asin(x)


Math::ATAN

1C++ :: Math | Ранее: ASIN | Далее: ATAN2
Math :: ATAN
Синтаксис:

ATAN(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Арктангенс x
Описание:

Возвращает atan(x)


Math::ATAN2

1C++ :: Math | Ранее: ATAN | Далее: CEIL
Math :: ATAN2
Синтаксис:

ATAN2(y, x)
Параметры:
  • y: Число или Строка
  • x: Число или Строка
Возвращает:
Число
Арктангенс y/x
Описание:

Возвращает atan(y/x)


Math::CEIL

1C++ :: Math | Ранее: ATAN2 | Далее: COPYSIGN
Math :: CEIL
Синтаксис:

CEIL(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Описание:

Возвращает наименьшее целое, большее x


Math::COPYSIGN

1C++ :: Math | Ранее: CEIL | Далее: COS
Math :: COPYSIGN
Синтаксис:

COPYSIGN(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:

Возвращает число x со знаком числа y


Math::COS

1C++ :: Math | Ранее: COPYSIGN | Далее: COSH
Math :: COS
Синтаксис:

COS(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Косинус x
Описание:

Возвращает cos(x)


Math::COSH

1C++ :: Math | Ранее: COS | Далее: EXP
Math :: COSH
Синтаксис:

COSH(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Косинус гиперболический x
Описание:

Возвращает cosh(x)


Math::EXP

1C++ :: Math | Ранее: COSH | Далее: FLOOR
Math :: EXP
Синтаксис:

EXP(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Экспонента x
Описание:

Возвращает e^x


Math::FLOOR

1C++ :: Math | Ранее: EXP | Далее: FMOD
Math :: FLOOR
Синтаксис:

FLOOR(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Описание:

Возвращает наибольшее целое, меньшее x


Math::FMOD

1C++ :: Math | Ранее: FLOOR | Далее: FREXP
Math :: FMOD
Синтаксис:

FMOD(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
остаток от деления x/y
Описание:

The function calculates the floating-point remainder f of x / y such that x = i * y + f, where i is an integer, f has the same sign as x, and the absolute value of f is less than the absolute value of y.

Функция возвращает такое значение остатка f, что x = i * y + f, где i - целое, f - одного знака с x, и абсолютное значение f меньше абсолютного значения y.


Math::FREXP

1C++ :: Math | Ранее: FMOD | Далее: HYPOT
Math :: FREXP
Синтаксис:

FREXP(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Мантисса x
Описание:

The function breaks down the floating-point value (x) into a mantissa (m) and an exponent (n), such that the absolute value of m is greater than or equal to 0.5 and less than 1.0, and x = m * 2^n.

Функция разбирает число x на мантиссу (m) и степень (n) таким образом, что 0.5 <= abs(m) < 1.0, и x = m * 2^n.


Math::HYPOT

1C++ :: Math | Ранее: FREXP | Далее: LDEXP
Math :: HYPOT
Синтаксис:

HYPOT(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
значение гипотенузы
Описание:

Функция возвращает SQRT(X^2 + y^2)


Math::LDEXP

1C++ :: Math | Ранее: HYPOT | Далее: LDIV
Math :: LDEXP
Синтаксис:

LDEXP(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:

Возвращает x * 2^y


Math::LDIV

1C++ :: Math | Ранее: LDEXP | Далее: LOG
Math :: LDIV
Синтаксис:

LDIV(x, y, rem)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
  • rem: Число (возврат)
Возвращает:
Число
Частное от целочисленного деления x/y
Описание:
Функция вычисляет частное и остаток от целочисленного деления x на y,
остаток возвращается в параметре rem


Math::LOG

1C++ :: Math | Ранее: LDIV | Далее: LOG10
Math :: LOG
Синтаксис:

LOG(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Логарифм x
Описание:
Функция вычисляет натуральный логарифм log(x)


Math::LOG10

1C++ :: Math | Ранее: LOG | Далее: MODF
Math :: LOG10
Синтаксис:

LOG10(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Десятичный логарифм x
Описание:
Функция вычисляет десятичный логарифм log10(x)


Math::MODF

1C++ :: Math | Ранее: LOG10 | Далее: PI
Math :: MODF
Синтаксис:

MODF(x, fract)
Параметры:
  • x: Число или Строка
  • fract: Число (возврат)
Возвращает:
Число
Целая часть x
Описание:
Функция разбирает x на целую и дробную часть того же знака, что и x,
дробная часть возвращается в переменной fract


Math::PI

1C++ :: Math | Ранее: MODF | Далее: POW
Math :: PI
Синтаксис:

PI()
Параметры:

нет
Возвращает:
Число
Описание:

Возвращает число PI


Math::POW

1C++ :: Math | Ранее: PI | Далее: RAND
Math :: POW
Синтаксис:

POW(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
x ^ y


Math::RAND

1C++ :: Math | Ранее: POW | Далее: RAND1
Math :: RAND
Синтаксис:

RAND()
Параметры:

нет
Возвращает:
Число
Случайное число
Описание:
Возвращает случайное число в диапазоне от 0 до RAND_MAX (определен как 0x7fff)
Для возврата случайного числа в диапазоне от 0 до 1 предназначена функция RAND1
Для инициализации генератора предназначена функция SRAND


Math::RAND1

1C++ :: Math | Ранее: RAND | Далее: ROTL
Math :: RAND1
Синтаксис:

RAND1()
Параметры:

нет
Возвращает:
Число
Случайное число
Описание:
Возвращает случайное число в диапазоне от 0 до 1
Для инициализации генератора предназначена функция SRAND


Math::ROTL

1C++ :: Math | Ранее: RAND1 | Далее: ROTR
Math :: ROTL
Синтаксис:

ROTL(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:
Функция выполняет кольцевой сдвиг числа x на y разрядов влево


Math::ROTR

1C++ :: Math | Ранее: ROTL | Далее: SHL
Math :: ROTR
Синтаксис:

ROTR(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:
Функция выполняет кольцевой сдвиг числа x на y разрядов вправо


Math::SHL

1C++ :: Math | Ранее: ROTR | Далее: SHR
Math :: SHL
Синтаксис:

SHL(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:
Функция выполняет сдвиг числа x на y разрядов влево


Math::SHR

1C++ :: Math | Ранее: SHL | Далее: SIN
Math :: SHR
Синтаксис:

SHR(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:
Функция выполняет сдвиг числа x на y разрядов вправо


Math::SIN

1C++ :: Math | Ранее: SHR | Далее: SINH
Math :: SIN
Синтаксис:

SIN(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Синус x
Описание:
Возвращает sin(x)


Math::SINH

1C++ :: Math | Ранее: SIN | Далее: SQRT
Math :: SINH
Синтаксис:

SINH(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Синус гиперболический x
Описание:
Возвращает sinh(x)


Math::SQRT

1C++ :: Math | Ранее: SINH | Далее: SRAND
Math :: SQRT
Синтаксис:

SQRT(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Корень квадратный х
Описание:
Возвращает x ^ 0.5


Math::SRAND

1C++ :: Math | Ранее: SQRT | Далее: TAN
Math :: SRAND
Синтаксис:

SRAND(x)
Параметры:
  • x: Число или Строка

    seed генератора
Возвращает:

нет
Описание:

Инициализирует генератор псевдослучайных чисел


Math::TAN

1C++ :: Math | Ранее: SRAND | Далее: TANH
Math :: TAN
Синтаксис:

TAN(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Тангенс x
Описание:

Возвращает tan(x)


Math::TANH

1C++ :: Math | Ранее: TAN | Далее: BITAND
Math :: TANH
Синтаксис:

TANH(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Тангенс гиперболический x
Описание:

Возвращает tanh(x)


Math::BITAND

1C++ :: Math | Ранее: TANH | Далее: BITOR
Math :: BITAND
Синтаксис:

BITAND(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:

Возвращает x & y


Math::BITOR

1C++ :: Math | Ранее: BITAND | Далее: COMPL
Math :: BITOR
Синтаксис:

BITOR(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:

Возвращает x | y


Math::COMPL

1C++ :: Math | Ранее: BITOR | Далее: XOR
Math :: COMPL
Синтаксис:

COMPL(x)
Параметры:
  • x: Число или Строка
Возвращает:
Число
Инверсия x
Описание:

Возвращает ~x


Math::XOR

1C++ :: Math | Ранее: COMPL | Далее:
Math :: XOR
Синтаксис:

XOR(x, y)
Параметры:
  • x: Число или Строка
  • y: Число или Строка
Возвращает:
Число
Описание:

Возвращает x ^ y