Работа с Табличным Полем

Работа с Табличным Полем

Эта часть документации описывает работу с ЭУ "ТабличноеПоле".

  • Табличное поле
  • Типы данных
  • Поставщики данных табличного поля
  • Объекты общего назначения


Табличное поле

1C++ :: Работа с Табличным Полем | Ранее: Работа с Табличным Полем | Далее: ТабличноеПоле
Табличное поле

Элемент управления, представляющий данные в виде таблицы. Работает со специальными объектами - источниками данных, называемыми поставщиками данных табличного поля. Поставщики данных обеспечивают специальный интерфейс, через который табличное поле получает данные. Само табличное поле не работает с источниками данных (базой данных, файлом, таблицами в памяти и т.п.), оно пользуется только тем, что предоставляет ему поставщик данных.

Табличное поле может генерировать события в виде вызова процедур модуля формы, на которой оно расположено, имена которых должны быть составлены из имени реквизита формы и имени события. Каждое событие, кроме описанных параметров, всегда имеет первый параметр, имеющий значение объекта - источника событий (само табличное поле).

Подержка полиморфного поведения при обработке событий

События табличного поля может обрабатывать КОП-наследник от ТабличногоПоля. Процедуры-обработчики событий должны быть объявлены с ключевым словом Экспорт (protected или public) и должны иметь имя, совпадающее с именем обрабатываемого события.

События могут быть заданы в КОПе и в модуле формы одновременно, в этом случае сначала происходит вызов события в КОПе, затем в модуле формы.

  • ТабличноеПоле
  • КолонкиТабличногоПоля
  • КолонкаТабличногоПоля
  • ДанныеСтроки
  • ОформлениеСтроки
  • ОформлениеЯчейки
  • ВыделенныеСтроки
  • ФиксированныеСтроки


ТабличноеПоле

1C++ :: Работа с Табличным Полем | Ранее: Табличное поле | Далее: Колонки / Columns
ТабличноеПоле

Во всех объектах табличного поля и в нем самом, свойства, определяющие цвет различных элементов задаются стандартным числом RGB. Кроме того, свойства могут принимать специальное значение цвета, равное -1. Это означает авто-цвет - значение цвета будет определяться из настроек операционной системы.

Создание табличного поля.

Для создания объекта нужно разместить на форме кнопку - она будет реквизитом формы. После того, как окно формы создано (например в процедуре ПослеОткрытия()), необходимо получить объект АтрибутФормы, соответствующий этой кнопке и вызвать его метод АтрибутФормы::СоздатьЭлементУправления(), передав в него:

  • строку "ТабличноеПоле": в этом случае будет создан объект типа ТабличноеПоле;
  • объект типа ТабличноеПоле: для создания ЭУ будет использован переданный объект.
  • объект КОПа наследника от объекта ТабличноеПоле (причем не обязательно непосредственный наследник): для создания ЭУ будет использован объект базового класса.

Метод возвращает объект типа ТабличноеПоле или переданный параметром объект.

Свойства

Колонки / Columns | Содержит коллекцию колонок табличного поля.
ПоставщикДанных / DataProvider | Поставщик данных табличного поля.
ВертСкроллер / VScroller | Наличие вертикальной полосы прокрутки.
НачальноеПредставление / StartView | Используется для определения начального заполнения табличного поля, когда в него установлен поставщик данных.
РежимВыделенияСтроки / RowSelectMode | Определяет стиль выделения текущей строки.
РежимВыделения / SelectMode | Определяет режим выделения строк табличного поля.
ВертикальныеЛинии / VerticalLines | Определяет наличие вертикальных разделительных линий между ячейками. 0 - линии не отображаются, 1 - линии отображаются.
ГоризонтальныеЛинии / HorizontalLines | Определяет наличие горизонтальных разделительных линий между ячейками. 0 - линии не отображаются, 1 - линии отображаются.
СтильЗаголовков / HeadersStyle | Определяет стиль отрисовки заголовков колонок.
СтильАктивногоЗаголовка / ActiveHeaderStyle | Определяет стиль отрисовки заголовка активной колонки.
ТекущаяКолонка / CurrentColumn | Определяет текущую колонку табличного поля.
ТекущиеДанные / CurrentData | Коллекция значений полей данных источника данных табличного поля. Данные текущей строки.
ВыделенныеСтроки / SelectedRows | Коллекция выделенных строк табличного поля
Шрифт / Font | Шрифт по умолчанию для колонок, строк, заголовков и ячеек табличного поля.
ТаймаутОбновления / RefreshTimeout | Интервал времени (в секундах), через который выполняется автоматическое обновление данных табличного поля. 0 - не обновлять автоматически.
ТаймаутБыстрогоПоиска / QuickSearchTimeout | Интервал времени (в миллисекундах), через который выполняется попытка найти строку по введенным данным. табличного поля. 0 - автоматически не пытаться.
ИзменятьПозициюКолонок / ChangePositionOfColumns | Разрешает или запрещает изменение позиции колонок. 0 - запрещает, 1 - разрешает.
ЦветЛиний / LinesColor | Определяет цвет разделительных линий между ячейками табличного поля.
ЦветТекста / TextColor | Определяет цвет текста табличного поля по умолчанию.
ЦветФона / BackColor | Определяет цвет фона табличного поля по умолчанию. Имеет влияние на цвет ячеек и на пространство окна, не занятое данными табличного поля.
ЦветТекстаВыделения / SelectionTextColor | Определяет цвет текста выделенной ячейки.
ЦветФонаВыделения / SelectionBackColor | Определяет цвет фона выделенной ячейки.
ЦветТекстаВыделения2 / SelectionTextColor2 | Определяет цвет текста выделенной строки когда РежимВыделенияСтроки == 2.
ЦветФонаВыделения2 / SelectionBackColor2 | Определяет цвет фона выделенной ячейки когда РежимВыделенияСтроки == 2.
ЦветФонаЧередованияСтрок / AlternationRowBackColor | Определяет альтернативный цвет фона строки таблицы в режиме чередования цветов фона строк.
ЧередованиеЦветовСтрок / UseAlternationRowColor | Определяет режим чередования цвета фона строки. 0 - не чередовать, 1- чередовать.
ТекущаяСтрока / CurrentRow | Определяет текущую строку табличного поля. Cвойство обслуживается установленным поставщиком данных. При записи в это свойство, произойдет активизация соответствующей строки табличного поля.
РазрешитьНачалоПеретаскивания / EnableStartDrag | Определяет поведение ЭУ для режима Drag&Drop. 1 - разрешает ЭУ выступать источником в операциях перетаскивания, 0 - запрещает.
РазрешитьПеретаскивание / EnableDrag | Определяет поведение ЭУ для режима Drag&Drop. 1 - разрешает ЭУ выступать приемником в операциях перетаскивания, 0 - запрещает.
ОтображатьЗаголовки / ShowHeaders |
ФиксацияСлева / FixedLeft |
ФиксацияСправа / FixedRight |
Шапка / Header |
Подвал / Footer |

Методы

ОбновитьСтроки / RefreshRows | перечитать строки, отображаемые в данный момент в табличном поле. Табличное поле будет стараться сохранить текущую строку.
ПерерисоватьСтроки / RedrawRows |
УстановитьОтступы / SetTextMargins |
ПолучитьГраницыТекущейЯчейки / GetCurrentCellBounds |
АвтоШирина / AutoWidth |

События

ПриВыводеСтроки / RowOut | Возникает при выводе (отображении) строки табличного поля.
Выбор / Selection | Возникает при двойном клике на строке табличного поля, или нажатии клавиши Enter.
ПриАктивизацииСтроки / ActivateRow | Возникает, когда любая строка становится текущей.
ПриАктивизацииКолонки / ActivateColumn | Возникает, когда любая колонка становится текущей.
ПриАктивизацииЯчейки / ActivateCell | Возникает, когда ячейка становится текущей. Порядок прохождения событий: ПриАктивизацииСтроки, ПриАктивизацииКолонки, ПриАктивизацииЯчейки.
ПриВыбореЗаголовка / HeaderSelection | Возникает, когда пользователь выбирает мышью заголовок колонки.
ПриКонтекстномМеню / ContextMenu | Возникает, когда необходимо отобразить контекстное меню.
ПриВыбореФлажка / ClickCheckBox | Возникает, когда пользователь изменяет значение флажка.
НачалоПеретаскивания / DragStart | Возникает в ЭУ источнике данных, когда пользователь начинает перетаскивание (Drag&Drop).
ОкончаниеПеретаскивания / DragEnd | Возникает в ЭУ источнике данных, когда завершается операция перетаскивания (Drag&Drop).
ПроверкаПеретаскивания / DragCheck | Возникает в ЭУ назначения перетаскивания для определения действия, которое произойдет при совершении операции перетаскивания. (Drag&Drop)
Перетаскивание / Drag | Возникает в ЭУ назначения, когда совершается операция перетаскивания (Drag&Drop).
ПриУничтожении / OnDestroy |
ПриНачалеБыстрогоПоиска / OnQuickSearchStart |
ПриБыстромПоиске / OnQuickSearch |
ПриОкончанииБыстрогоПоиска / OnQuickSearchEnd |
ПриПеремещенииКолонки / OnColumnMove |
ПриИзмененииВидимостиКолонки / OnColumnVisibilityChange |
ПриИзмененииШириныКолонки / OnColumnWidthChange |


ТабличноеПоле::Колонки / Columns

1C++ :: Работа с Табличным Полем | Ранее: ТабличноеПоле | Далее: ПоставщикДанных / DataProvider
ТабличноеПоле :: Колонки / Columns

Доступ: только чтение.

Тип: КолонкиТабличногоПоля.

Описание: Содержит коллекцию колонок табличного поля.


ТабличноеПоле::ПоставщикДанных / DataProvider

1C++ :: Работа с Табличным Полем | Ранее: Колонки / Columns | Далее: ВертСкроллер / VScroller
ТабличноеПоле :: ПоставщикДанных / DataProvider

Доступ: чтение и запись.

Тип: объект.

Описание: Поставщик данных табличного поля.

См. также: Поставщики данных табличного поля


ТабличноеПоле::ВертСкроллер / VScroller

1C++ :: Работа с Табличным Полем | Ранее: ПоставщикДанных / DataProvider | Далее: НачальноеПредставление / StartView
ТабличноеПоле :: ВертСкроллер / VScroller

Доступ: чтение и запись.

Тип: Число.

Описание: Наличие вертикальной полосы прокрутки.

  • 0 - Автоматически скрывать, если все строки помещаются в табличном поле;
  • 1 - Всегда присутствует;
  • 2 - Всегда отсутствует.


ТабличноеПоле::НачальноеПредставление / StartView

1C++ :: Работа с Табличным Полем | Ранее: ВертСкроллер / VScroller | Далее: РежимВыделенияСтроки / RowSelectMode
ТабличноеПоле :: НачальноеПредставление / StartView

Доступ: чтение и запись.

Тип: Число.

Описание: Используется для определения начального заполнения табличного поля, когда в него установлен поставщик данных.

  • 0 - с начала;
  • 1 - с конца.


ТабличноеПоле::РежимВыделенияСтроки / RowSelectMode

1C++ :: Работа с Табличным Полем | Ранее: НачальноеПредставление / StartView | Далее: РежимВыделения / SelectMode
ТабличноеПоле :: РежимВыделенияСтроки / RowSelectMode

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет стиль выделения текущей строки.

  • 0 - выделяется ячейка
  • 1 - выделяется вся строка
  • 2 - текущая ячейка и текущая строка выделяется по-разному (для строки используются ЦветТекстаВыделения2 и ЦветФонаВыделения2)


ТабличноеПоле::РежимВыделения / SelectMode

1C++ :: Работа с Табличным Полем | Ранее: РежимВыделенияСтроки / RowSelectMode | Далее: ВертикальныеЛинии / VerticalLines
ТабличноеПоле :: РежимВыделения / SelectMode

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет режим выделения строк табличного поля.

  • 0 - одиночный (разрешено выделение одной строки)
  • 1 - множественный (разрешено выделение нескольких строк)


ТабличноеПоле::ВертикальныеЛинии / VerticalLines

1C++ :: Работа с Табличным Полем | Ранее: РежимВыделения / SelectMode | Далее: ГоризонтальныеЛинии / HorizontalLines
ТабличноеПоле :: ВертикальныеЛинии / VerticalLines

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет наличие вертикальных разделительных линий между ячейками. 0 - линии не отображаются, 1 - линии отображаются.


ТабличноеПоле::ГоризонтальныеЛинии / HorizontalLines

1C++ :: Работа с Табличным Полем | Ранее: ВертикальныеЛинии / VerticalLines | Далее: СтильЗаголовков / HeadersStyle
ТабличноеПоле :: ГоризонтальныеЛинии / HorizontalLines

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет наличие горизонтальных разделительных линий между ячейками. 0 - линии не отображаются, 1 - линии отображаются.


ТабличноеПоле::СтильЗаголовков / HeadersStyle

1C++ :: Работа с Табличным Полем | Ранее: ГоризонтальныеЛинии / HorizontalLines | Далее: СтильАктивногоЗаголовка / ActiveHeaderStyle
ТабличноеПоле :: СтильЗаголовков / HeadersStyle

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет стиль отрисовки заголовков колонок.

  • 0 - стиль 3D;
  • 1 - плоский стиль.


ТабличноеПоле::СтильАктивногоЗаголовка / ActiveHeaderStyle

1C++ :: Работа с Табличным Полем | Ранее: СтильЗаголовков / HeadersStyle | Далее: ТекущаяКолонка / CurrentColumn
ТабличноеПоле :: СтильАктивногоЗаголовка / ActiveHeaderStyle

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет стиль отрисовки заголовка активной колонки.

  • 0 - активная колонка не выделяется;
  • 1 - активная колонка выделяется в стиле, соответствующем значению свойства 'СтильЗаголовков'.


ТабличноеПоле::ТекущаяКолонка / CurrentColumn

1C++ :: Работа с Табличным Полем | Ранее: СтильАктивногоЗаголовка / ActiveHeaderStyle | Далее: ТекущиеДанные / CurrentData
ТабличноеПоле :: ТекущаяКолонка / CurrentColumn

Доступ: чтение и запись.

Тип: КолонкаТабличногоПоля.

Описание: Определяет текущую колонку табличного поля.


ТабличноеПоле::ТекущиеДанные / CurrentData

1C++ :: Работа с Табличным Полем | Ранее: ТекущаяКолонка / CurrentColumn | Далее: ВыделенныеСтроки / SelectedRows
ТабличноеПоле :: ТекущиеДанные / CurrentData

Доступ: только чтение.

Тип: ДанныеСтроки.

Описание: Коллекция значений полей данных источника данных табличного поля. Данные текущей строки.


ТабличноеПоле::ВыделенныеСтроки / SelectedRows

1C++ :: Работа с Табличным Полем | Ранее: ТекущиеДанные / CurrentData | Далее: Шрифт / Font
ТабличноеПоле :: ВыделенныеСтроки / SelectedRows

Доступ: только чтение

Тип: ВыделенныеСтроки

Описание: Коллекция выделенных строк табличного поля


ТабличноеПоле::Шрифт / Font

1C++ :: Работа с Табличным Полем | Ранее: ВыделенныеСтроки / SelectedRows | Далее: ТаймаутОбновления / RefreshTimeout
ТабличноеПоле :: Шрифт / Font

Доступ: чтение и запись.

Тип: Шрифт.

Описание: Шрифт по умолчанию для колонок, строк, заголовков и ячеек табличного поля.

Определяет также высоту строки табличного поля. Высота строки будет определяться по высоте строки текста этого шрифта. Значение Авто означает, что будет использоваться шрифт формы. По отношению ко всем остальным дочерним объектам табличного поля (колонка, строка, ячейка), этот шрифт будет шрифтом с самым низким приоритетом.

Примечание: значение Авто в свойствах типа Шрифт дочерних объектов означает, что будет выбран шрифт с меньшим приоритетом.


ТабличноеПоле::ТаймаутОбновления / RefreshTimeout

1C++ :: Работа с Табличным Полем | Ранее: Шрифт / Font | Далее: ТаймаутБыстрогоПоиска / QuickSearchTimeout
ТабличноеПоле :: ТаймаутОбновления / RefreshTimeout

Доступ: чтение и запись.

Тип: Число.

Описание: Интервал времени (в секундах), через который выполняется автоматическое обновление данных табличного поля. 0 - не обновлять автоматически.


ТабличноеПоле::ТаймаутБыстрогоПоиска / QuickSearchTimeout

1C++ :: Работа с Табличным Полем | Ранее: ТаймаутОбновления / RefreshTimeout | Далее: ИзменятьПозициюКолонок / ChangePositionOfColumns
ТабличноеПоле :: ТаймаутБыстрогоПоиска / QuickSearchTimeout

Доступ: чтение и запись.

Тип: Число.

Описание: Интервал времени (в миллисекундах), через который выполняется попытка найти строку по введенным данным. табличного поля. 0 - автоматически не пытаться.


ТабличноеПоле::ИзменятьПозициюКолонок / ChangePositionOfColumns

1C++ :: Работа с Табличным Полем | Ранее: ТаймаутБыстрогоПоиска / QuickSearchTimeout | Далее: ЦветЛиний / LinesColor
ТабличноеПоле :: ИзменятьПозициюКолонок / ChangePositionOfColumns

Доступ: чтение и запись.

Тип: Число.

Описание: Разрешает или запрещает изменение позиции колонок. 0 - запрещает, 1 - разрешает.


ТабличноеПоле::ЦветЛиний / LinesColor

1C++ :: Работа с Табличным Полем | Ранее: ИзменятьПозициюКолонок / ChangePositionOfColumns | Далее: ЦветТекста / TextColor
ТабличноеПоле :: ЦветЛиний / LinesColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет разделительных линий между ячейками табличного поля.


ТабличноеПоле::ЦветТекста / TextColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветЛиний / LinesColor | Далее: ЦветФона / BackColor
ТабличноеПоле :: ЦветТекста / TextColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет текста табличного поля по умолчанию.


ТабличноеПоле::ЦветФона / BackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекста / TextColor | Далее: ЦветТекстаВыделения / SelectionTextColor
ТабличноеПоле :: ЦветФона / BackColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет фона табличного поля по умолчанию. Имеет влияние на цвет ячеек и на пространство окна, не занятое данными табличного поля.


ТабличноеПоле::ЦветТекстаВыделения / SelectionTextColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветФона / BackColor | Далее: ЦветФонаВыделения / SelectionBackColor
ТабличноеПоле :: ЦветТекстаВыделения / SelectionTextColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет текста выделенной ячейки.


ТабличноеПоле::ЦветФонаВыделения / SelectionBackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекстаВыделения / SelectionTextColor | Далее: ЦветТекстаВыделения2 / SelectionTextColor2
ТабличноеПоле :: ЦветФонаВыделения / SelectionBackColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет фона выделенной ячейки.


ТабличноеПоле::ЦветТекстаВыделения2 / SelectionTextColor2

1C++ :: Работа с Табличным Полем | Ранее: ЦветФонаВыделения / SelectionBackColor | Далее: ЦветФонаВыделения2 / SelectionBackColor2
ТабличноеПоле :: ЦветТекстаВыделения2 / SelectionTextColor2

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет текста выделенной строки когда РежимВыделенияСтроки == 2.


ТабличноеПоле::ЦветФонаВыделения2 / SelectionBackColor2

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекстаВыделения2 / SelectionTextColor2 | Далее: ЦветФонаЧередованияСтрок / AlternationRowBackColor
ТабличноеПоле :: ЦветФонаВыделения2 / SelectionBackColor2

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет фона выделенной ячейки когда РежимВыделенияСтроки == 2.


ТабличноеПоле::ЦветФонаЧередованияСтрок / AlternationRowBackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветФонаВыделения2 / SelectionBackColor2 | Далее: ЧередованиеЦветовСтрок / UseAlternationRowColor
ТабличноеПоле :: ЦветФонаЧередованияСтрок / AlternationRowBackColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет альтернативный цвет фона строки таблицы в режиме чередования цветов фона строк.


ТабличноеПоле::ЧередованиеЦветовСтрок / UseAlternationRowColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветФонаЧередованияСтрок / AlternationRowBackColor | Далее: ТекущаяСтрока / CurrentRow
ТабличноеПоле :: ЧередованиеЦветовСтрок / UseAlternationRowColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет режим чередования цвета фона строки. 0 - не чередовать, 1- чередовать.


ТабличноеПоле::ТекущаяСтрока / CurrentRow

1C++ :: Работа с Табличным Полем | Ранее: ЧередованиеЦветовСтрок / UseAlternationRowColor | Далее: РазрешитьНачалоПеретаскивания / EnableStartDrag
ТабличноеПоле :: ТекущаяСтрока / CurrentRow

Доступ: чтение и запись.

Тип: определяется поставщиком данных. Указывается в описании конкретного поставщика данных.

Описание: Определяет текущую строку табличного поля. Cвойство обслуживается установленным поставщиком данных. При записи в это свойство, произойдет активизация соответствующей строки табличного поля.

См. также: Поставщики данных табличного поля


ТабличноеПоле::РазрешитьНачалоПеретаскивания / EnableStartDrag

1C++ :: Работа с Табличным Полем | Ранее: ТекущаяСтрока / CurrentRow | Далее: РазрешитьПеретаскивание / EnableDrag
ТабличноеПоле :: РазрешитьНачалоПеретаскивания / EnableStartDrag

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет поведение ЭУ для режима Drag&Drop. 1 - разрешает ЭУ выступать источником в операциях перетаскивания, 0 - запрещает.

Когда начало перетаскивания разрешено, работают события НачалоПеретаскивания / DragStart и ОкончаниеПеретаскивания / DragEnd.


ТабличноеПоле::РазрешитьПеретаскивание / EnableDrag

1C++ :: Работа с Табличным Полем | Ранее: РазрешитьНачалоПеретаскивания / EnableStartDrag | Далее: ОтображатьЗаголовки / ShowHeaders
ТабличноеПоле :: РазрешитьПеретаскивание / EnableDrag

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет поведение ЭУ для режима Drag&Drop. 1 - разрешает ЭУ выступать приемником в операциях перетаскивания, 0 - запрещает.

Когда перетаскивание разрешено, работают события ПроверкаПеретаскивания / DragCheck и Перетаскивание / Drag.


ТабличноеПоле::ОтображатьЗаголовки / ShowHeaders

1C++ :: Работа с Табличным Полем | Ранее: РазрешитьПеретаскивание / EnableDrag | Далее: ФиксацияСлева / FixedLeft
ТабличноеПоле :: ОтображатьЗаголовки / ShowHeaders
Доступ:

Чтение и запись
Тип:
Число
  • 1: отобразить заголовки
  • 0: скрыть заголовки
Описание:

Управляет отображением заголовков колонок ТП


ТабличноеПоле::ФиксацияСлева / FixedLeft

1C++ :: Работа с Табличным Полем | Ранее: ОтображатьЗаголовки / ShowHeaders | Далее: ФиксацияСправа / FixedRight
ТабличноеПоле :: ФиксацияСлева / FixedLeft
Доступ: Чтение и запись
Тип: Число
Описание: Содержит количество зафиксированных слева колонок. Зафиксированные колонки остаются на месте при горизонтальной прокрутке табличного поля.


ТабличноеПоле::ФиксацияСправа / FixedRight

1C++ :: Работа с Табличным Полем | Ранее: ФиксацияСлева / FixedLeft | Далее: Шапка / Header
ТабличноеПоле :: ФиксацияСправа / FixedRight
Доступ: Чтение и запись
Тип: Число
Описание: Содержит количество зафиксированных справа колонок. Зафиксированные колонки остаются на месте при горизонтальной прокрутке табличного поля.


ТабличноеПоле::Шапка / Header

1C++ :: Работа с Табличным Полем | Ранее: ФиксацияСправа / FixedRight | Далее: Подвал / Footer
ТабличноеПоле :: Шапка / Header
Доступ: Чтение
Тип: ФиксированныеСтроки
Описание: Объект, предназначенный для управления шапкой табличного поля


ТабличноеПоле::Подвал / Footer

1C++ :: Работа с Табличным Полем | Ранее: Шапка / Header | Далее: ОбновитьСтроки / RefreshRows
ТабличноеПоле :: Подвал / Footer
Доступ: Чтение
Тип: ФиксированныеСтроки
Описание: Объект, предназначенный для управления подвалом табличного поля


ТабличноеПоле::ОбновитьСтроки / RefreshRows

1C++ :: Работа с Табличным Полем | Ранее: Подвал / Footer | Далее: ПерерисоватьСтроки / RedrawRows
ТабличноеПоле :: ОбновитьСтроки / RefreshRows

Синтаксис: ОбновитьСтроки()

Описание: перечитать строки, отображаемые в данный момент в табличном поле. Табличное поле будет стараться сохранить текущую строку.


ТабличноеПоле::ПерерисоватьСтроки / RedrawRows

1C++ :: Работа с Табличным Полем | Ранее: ОбновитьСтроки / RefreshRows | Далее: УстановитьОтступы / SetTextMargins
ТабличноеПоле :: ПерерисоватьСтроки / RedrawRows
Синтаксис: ПерерисоватьСтроки()
Возвращает: нет
Описание: Обновить строки, отображаемые в данный момент в табличном поле, без обращения к провайдеру.


ТабличноеПоле::УстановитьОтступы / SetTextMargins

1C++ :: Работа с Табличным Полем | Ранее: ПерерисоватьСтроки / RedrawRows | Далее: ПолучитьГраницыТекущейЯчейки / GetCurrentCellBounds
ТабличноеПоле :: УстановитьОтступы / SetTextMargins
Синтаксис:

УстановитьОтступы(чЛево, чВерх, чПраво, чНиз)
Параметры:
  • чЛево, тип: Число
  • чВерх, тип: Число
  • чПраво, тип: Число
  • чНиз, тип: Число
Возвращает:

нет
Описание:
Устанавливает отступы текста в пределах ячейки в соответствии с переданными параметрами.
Отрицательные значения параметров игнорируются.


ТабличноеПоле::ПолучитьГраницыТекущейЯчейки / GetCurrentCellBounds

1C++ :: Работа с Табличным Полем | Ранее: УстановитьОтступы / SetTextMargins | Далее: АвтоШирина / AutoWidth
ТабличноеПоле :: ПолучитьГраницыТекущейЯчейки / GetCurrentCellBounds
Синтаксис:

ПолучитьГраницыТекущейЯчейки(чЛево, чВерх, чПраво, чНиз, флПривязка = 0)
Параметры:
  • чЛево, тип: Число
  • чВерх, тип: Число
  • чПраво, тип: Число
  • чНиз, тип: Число
  • флПривязка, тип: Число
    • 0: экранные координаты
    • 1: клиентские координаты
Возвращает:
  • 0: границы получить невозможно
  • 1: границы успешно получены
Описание:

Возвращет координаты текущей ячейки ТП


ТабличноеПоле::АвтоШирина / AutoWidth

1C++ :: Работа с Табличным Полем | Ранее: ПолучитьГраницыТекущейЯчейки / GetCurrentCellBounds | Далее: ПриВыводеСтроки / RowOut
ТабличноеПоле :: АвтоШирина / AutoWidth
Синтаксис:

AutoWidth()
Параметры:

нет
Возвращает:

нет
Описание:
Устанавливает минимальную достаточную ширину для всех колонок ТП по видимой части ТП
Действие равнозначно двойному щелчку левой кнопкой мыши на разделителе колонок в заголовке ТП при нажатой клавише SHIFT


ТабличноеПоле::ПриВыводеСтроки / RowOut

1C++ :: Работа с Табличным Полем | Ранее: АвтоШирина / AutoWidth | Далее: Выбор / Selection
ТабличноеПоле :: ПриВыводеСтроки / RowOut

Синтаксис: ПриВыводеСтроки(ОформлениеСтроки, ДанныеСтроки, ТипРегиона)

Параметры:

  • ОформлениеСтроки - тип: ОформлениеСтроки. Объект для управления оформлением выводимой строки табличного поля.
  • ДанныеСтроки - тип: ДанныеСтроки. Данные (коллекция значений полей) выводимой строки табличного поля.
  • ТипРегиона - тип: ТипыРегионовТП

Описание: Возникает при выводе (отображении) строки табличного поля.


ТабличноеПоле::Выбор / Selection

1C++ :: Работа с Табличным Полем | Ранее: ПриВыводеСтроки / RowOut | Далее: ПриАктивизацииСтроки / ActivateRow
ТабличноеПоле :: Выбор / Selection

Синтаксис: Выбор(Строка, Колонка, ТипРегиона)

Параметры:

  • Строка - тип: определяется поставищком данных. Значение, идентифицирующее строку ТП.
  • Колонка - тип: КолонкаТабличногоПоля
  • ТипРегиона - тип: ТипыРегионовТП

Описание: Возникает при двойном клике на строке табличного поля, или нажатии клавиши Enter.


ТабличноеПоле::ПриАктивизацииСтроки / ActivateRow

1C++ :: Работа с Табличным Полем | Ранее: Выбор / Selection | Далее: ПриАктивизацииКолонки / ActivateColumn
ТабличноеПоле :: ПриАктивизацииСтроки / ActivateRow

Синтаксис: ПриАктивизацииСтроки()

Описание: Возникает, когда любая строка становится текущей.


ТабличноеПоле::ПриАктивизацииКолонки / ActivateColumn

1C++ :: Работа с Табличным Полем | Ранее: ПриАктивизацииСтроки / ActivateRow | Далее: ПриАктивизацииЯчейки / ActivateCell
ТабличноеПоле :: ПриАктивизацииКолонки / ActivateColumn

Синтаксис: ПриАктивизацииКолонки()

Описание: Возникает, когда любая колонка становится текущей.


ТабличноеПоле::ПриАктивизацииЯчейки / ActivateCell

1C++ :: Работа с Табличным Полем | Ранее: ПриАктивизацииКолонки / ActivateColumn | Далее: ПриВыбореЗаголовка / HeaderSelection
ТабличноеПоле :: ПриАктивизацииЯчейки / ActivateCell

Синтаксис: ПриАктивизацииЯчейки()

Описание: Возникает, когда ячейка становится текущей. Порядок прохождения событий: ПриАктивизацииСтроки, ПриАктивизацииКолонки, ПриАктивизацииЯчейки.


ТабличноеПоле::ПриВыбореЗаголовка / HeaderSelection

1C++ :: Работа с Табличным Полем | Ранее: ПриАктивизацииЯчейки / ActivateCell | Далее: ПриКонтекстномМеню / ContextMenu
ТабличноеПоле :: ПриВыбореЗаголовка / HeaderSelection

Синтаксис: ПриВыбореЗаголовка(Колонка)

Параметры:

  • Колонка - тип: КолонкаТабличногоПоля. Колонка, заголовок которой выбран.

Описание: Возникает, когда пользователь выбирает мышью заголовок колонки.


ТабличноеПоле::ПриКонтекстномМеню / ContextMenu

1C++ :: Работа с Табличным Полем | Ранее: ПриВыбореЗаголовка / HeaderSelection | Далее: ПриВыбореФлажка / ClickCheckBox
ТабличноеПоле :: ПриКонтекстномМеню / ContextMenu

Синтаксис: ПриКонтекстномМеню(ТипРегиона, Колонка, Строка)

Параметры:

  • ТипРегиона - тип: ТипыРегионовТП
  • Колонка - тип: КолонкаТабличногоПоля. Колонка табличного поля, на которой было вызвано контекстное меню.
  • Строка - тип: определяется поставищком данных. Значение, идентифицирующее строку ТП.

Описание: Возникает, когда необходимо отобразить контекстное меню.


ТабличноеПоле::ПриВыбореФлажка / ClickCheckBox

1C++ :: Работа с Табличным Полем | Ранее: ПриКонтекстномМеню / ContextMenu | Далее: НачалоПеретаскивания / DragStart
ТабличноеПоле :: ПриВыбореФлажка / ClickCheckBox

Синтаксис: ПриВыбореФлажка(Строка, Колонка, ТипРегиона)

Параметры:

  • Строка - тип: определяется поставищком данных. Значение, идентифицирующее строку ТП.
  • Колонка - тип: КолонкаТабличногоПоля
  • ТипРегиона - тип: ТипыРегионовТП

Описание: Возникает, когда пользователь изменяет значение флажка.


ТабличноеПоле::НачалоПеретаскивания / DragStart

1C++ :: Работа с Табличным Полем | Ранее: ПриВыбореФлажка / ClickCheckBox | Далее: ОкончаниеПеретаскивания / DragEnd
ТабличноеПоле :: НачалоПеретаскивания / DragStart

Синтаксис: НачалоПеретаскивания(ДопустимыеДействия, Значение, Колонка, ТипРегиона, ТипЦели)

Параметры:

  • ДопустимыеДействия - тип: Число. (Выход) Список допустимых действий перетаскивания. Список задается как сумма следующих значений:

    • 1 - копирование (Copy)
    • 2 - перетаскивание (Move)
    • 4 - связывание (Link)

    Значение по-умолчанию 1. Если необходимо разрешить другие действия, нужно изменить значение этого параметра на выходе из обработчика события. Если передать 0, т.е. не определить ни одного действия, Перетаскивание не начнется.

  • Значение - тип: определяется поставщиком данных. (Вход) Значение, идентифицирующее строку табличного поля. (Выход) Значение, которое будет представлять перетаскиваемые данные.

  • Колонка - тип: КолонкаТабличногоПоля

  • ТипРегиона - тип: ТипыРегионовТП

  • ТипЦели - тип: Число. (Выход) Определяет логическую область отображения перетаскиваемых данных в ТП.

    • 0 - не задано
    • 1 - ячейка
    • 2 - строка
    • 3 - колонка

Это значение используется для определения области ТП, в которой не нужно формировать события проверки перетаскивания, в том случае когда ЭУ-приемником является то же ТП, что и источник.

Описание: Возникает в ЭУ источнике данных, когда пользователь начинает перетаскивание (Drag&Drop).


ТабличноеПоле::ОкончаниеПеретаскивания / DragEnd

1C++ :: Работа с Табличным Полем | Ранее: НачалоПеретаскивания / DragStart | Далее: ПроверкаПеретаскивания / DragCheck
ТабличноеПоле :: ОкончаниеПеретаскивания / DragEnd

Синтаксис: ОкончаниеПеретаскивания(Действие, Значение, Колонка, ТипРегиона)

Параметры:

  • Действие - тип: Число. Действие - результат операции перетаскивания. Допустимые действия:

    • 0 - нет действия
    • 1 - копирование (Copy)
    • 2 - перетаскивание (Move)
    • 4 - связывание (Link)
    • Значение - тип: Любой. Значение, представляющее перетаскиваемые данные. Это значение было задано в событии НачалоПеретаскивания.
    • Колонка - тип: КолонкаТабличногоПоля
    • ТипРегиона - тип: ТипыРегионовТП

Описание: Возникает в ЭУ источнике данных, когда завершается операция перетаскивания (Drag&Drop).

Обычная обработка: в случае операции 2 (перетаскивания или Move) нужно удалить перетаскиваемые данные. В параметре Действие ЭУ источник данных всегда получит одно из тех действий, которое он определил для себя в событии НачалоПеретаскивания / DragStart.

Порядок прохождения событий:
  • НачалоПеретаскивания - в источнике,
  • ПроверкаПеретаскивания - в назначении,
  • Перетаскивание - в назначении,
  • ОкончаниеПеретаскивания - в источнике.


ТабличноеПоле::ПроверкаПеретаскивания / DragCheck

1C++ :: Работа с Табличным Полем | Ранее: ОкончаниеПеретаскивания / DragEnd | Далее: Перетаскивание / Drag
ТабличноеПоле :: ПроверкаПеретаскивания / DragCheck

Синтаксис: ПроверкаПеретаскивания(Действие, Значение, СтрокаТП, КолонкаТП, ТипРегионаТП, ТипЦели)

Параметры:

  • Действие - тип: Число. (Выход) Действие которое произойдет при совершении перетаскивания. По-умолчанию 0. Допустимые действия:

    • 0 - нет действия
    • 1 - копирование (Copy)
    • 2 - перетаскивание (Move)
    • 4 - связывание (Link)

  • Значение - тип: Любой. Значение, представляющее перетаскиваемые данные. Это значение было задано в обработчике события НачалоПеретаскивания.

  • СтрокаТП - тип: Любой. Значение представляющее строку табличного поля, в которую идет перетаскивание (находится под курсором). Обеспечивается поставщиком данных.

  • КолонкаТП - тип: КолонкаТабличногоПоля. Колонка табличного поля, в которую идет перетаскивание (находится под курсором).
    • ТипРегионаТП - тип: ТипыРегионовТП. Тип региона, в который идет перетаскивание.

  • ТипЦели - тип: Число. (Выход) Определяет логическую область приемника перетаскиваемых данных, которая подсвечивается рамкой. Значение по-умолчанию: если ЭУ источник данных - табличное поле, то значение, заданное в обработчике события НачалоПеретаскивания; если источник данных - некий другой ЭУ, то значение равно 0.

    • 0 - не задано
    • 1 - ячейка
    • 2 - строка
    • 3 - колонка

Описание: Возникает в ЭУ назначения перетаскивания для определения действия, которое произойдет при совершении операции перетаскивания. (Drag&Drop)

Главное назначение события - проверить возможность совершения операции перетаскивания и определить Действие. Событие возникает всякий раз, когда изменяется строка или колонка ТП. Если строка или колонка не определяются под курсором мыши, то значения соответствующих параметров будут равны пустому значению.


ТабличноеПоле::Перетаскивание / Drag

1C++ :: Работа с Табличным Полем | Ранее: ПроверкаПеретаскивания / DragCheck | Далее: ПриУничтожении / OnDestroy
ТабличноеПоле :: Перетаскивание / Drag

Синтаксис: Перетаскивание(Действие, Значение, СтрокаТП, КолонкаТП, ТипРегионаТП)

Параметры:

  • Действие - тип: Число. Действие, которое нужно выполнить для совершения перетаскивания. Равно значению параметра Действие на выходе из события ПроверкаПеретаскивания / DragCheck. Допустимые действия:

    • 1 - копирование (Copy)
    • 2 - перетаскивание (Move)
    • 4 - связывание (Link)

  • Значение - тип: Любой. Значение, представляющее перетаскиваемые данные. Это значение было задано в обработчике события НачалоПеретаскивания.

  • СтрокаТП - тип: Любой. Значение представляющее строку табличного поля, в которую идет перетаскивание (находится под курсором). Обеспечивается поставщиком данных.

  • КолонкаТП - тип: КолонкаТабличногоПоля. Колонка табличного поля, в которую идет перетаскивание (находится под курсором).
    • ТипРегионаТП - тип: ТипыРегионовТП. Тип региона, в который идет перетаскивание.

Описание: Возникает в ЭУ назначения, когда совершается операция перетаскивания (Drag&Drop).

Если строка или колонка не определяются под курсором мыши, то значения соответствующих параметров будут равны пустому значению.


ТабличноеПоле::ПриУничтожении / OnDestroy

1C++ :: Работа с Табличным Полем | Ранее: Перетаскивание / Drag | Далее: ПриНачалеБыстрогоПоиска / OnQuickSearchStart
ТабличноеПоле :: ПриУничтожении / OnDestroy
Синтаксис: ПриУничтожении()
Параметры: нет
Описание: Событие вызывается при уничтожении контрола, с которым связано ТП, до уничтожения самого ТП.


ТабличноеПоле::ПриНачалеБыстрогоПоиска / OnQuickSearchStart

1C++ :: Работа с Табличным Полем | Ранее: ПриУничтожении / OnDestroy | Далее: ПриБыстромПоиске / OnQuickSearch
ТабличноеПоле :: ПриНачалеБыстрогоПоиска / OnQuickSearchStart
Синтаксис:

ПриНачалеБыстрогоПоиска(чТипБыстрогоПоиска, чФСО)
Параметры:
  • чТипБыстрогоПоиска, тип: Число
    Тип быстрого поиска:
    • 1 - текстовый быстрый поиск
  • чФСО, тип: Число

    Доступ: чтение и запись

    Флаг стандартной обработки. Возможные значения для установки:
    • 1 - быстрый поиск разрешен
    • 0 - быстрый поиск запрещен

    Значение по умолчанию: 1
Описание:

Событие вызывается до инициализации окна быстрого поиска и позволяет управлять разрешением на его создание.


ТабличноеПоле::ПриБыстромПоиске / OnQuickSearch

1C++ :: Работа с Табличным Полем | Ранее: ПриНачалеБыстрогоПоиска / OnQuickSearchStart | Далее: ПриОкончанииБыстрогоПоиска / OnQuickSearchEnd
ТабличноеПоле :: ПриБыстромПоиске / OnQuickSearch
Синтаксис:

ПриБыстромПоиске(чТипБыстрогоПоиска, нДанные, чФСО)
Параметры:
  • чТипБыстрогоПоиска, тип: Число
    Тип быстрого поиска:
    • 1 - текстовый быстрый поиск
  • нДанные, тип: для текстового быстрого поиска - Строка

    Доступ: чтение и запись

    Данные, введенные в окне быстрого поиска

  • чФСО, тип: Число
    Флаг стандартной обработки. Возможные значения для установки:
    • 1 - быстрый поиск разрешен
    • 0 - быстрый поиск запрещен

    Значение по умолчанию: 1
Описание:
Событие вызывается до выполнения системной процедуры быстрого поиска и позволяет организовать специальные алгоритмы поиска.
Возможна трансформация данных с последующей системной обработкой, а также полная замена системной обработки на собственную.


ТабличноеПоле::ПриОкончанииБыстрогоПоиска / OnQuickSearchEnd

1C++ :: Работа с Табличным Полем | Ранее: ПриБыстромПоиске / OnQuickSearch | Далее: ПриПеремещенииКолонки / OnColumnMove
ТабличноеПоле :: ПриОкончанииБыстрогоПоиска / OnQuickSearchEnd
Синтаксис:

ПриОкончанииБыстрогоПоиска(флРезультат, флПерепозиционировано)
Параметры:
  • флРезультат, тип: Число
    Причина закрытия окна быстрого поиска.
    • 1 - закрытие клавишей ENTER
    • 0 - отмена быстрого поиска (любым способом)
  • флПерепозиционировано, тип: Число
    Флаг, отражающий факт перепозиционирования непосредственно перед закрытием окна БП
    • 1 - ТП было перепозиционировано
    • 0 - ТП не было перепозиционировано
Описание:

Событие вызывается после закрытия окна быстрого поиска.


ТабличноеПоле::ПриПеремещенииКолонки / OnColumnMove

1C++ :: Работа с Табличным Полем | Ранее: ПриОкончанииБыстрогоПоиска / OnQuickSearchEnd | Далее: ПриИзмененииВидимостиКолонки / OnColumnVisibilityChange
ТабличноеПоле :: ПриПеремещенииКолонки / OnColumnMove
Синтаксис:

ПриПеремещенииКолонки(Колонка, чСдвиг, чФСО)
Параметры:

  • Колонка, тип: КолонкаТабличногоПоля

  • чСдвиг, тип: Число

    Предлагаемый сдвиг колонки

  • чФСО, тип: Число
    Флаг стандартной обработки. Возможные значения для установки:
    • 1 - перемещение колонки разрешено
    • 0 - перемещение колонки запрещено

    Значение по умолчанию: 1
Описание:
Событие вызывается при интерактивном перемещении колонки ТП непосредственно перед выполнением перемещения.


ТабличноеПоле::ПриИзмененииВидимостиКолонки / OnColumnVisibilityChange

1C++ :: Работа с Табличным Полем | Ранее: ПриПеремещенииКолонки / OnColumnMove | Далее: ПриИзмененииШириныКолонки / OnColumnWidthChange
ТабличноеПоле :: ПриИзмененииВидимостиКолонки / OnColumnVisibilityChange
Синтаксис:

ПриИзмененииВидимостиКолонки(Колонка, флВидимость, чФСО)
Параметры:

  • Колонка, тип: КолонкаТабличногоПоля

  • флВидимость, тип: Число

    Предлагаемое значение флага видимости колонки

  • чФСО, тип: Число
    Флаг стандартной обработки. Возможные значения для установки:
    • 1 - изменение видимости колонки разрешено
    • 0 - изменение видимости колонки запрещено

    Значение по умолчанию: 1
Описание:
Событие вызывается при интерактивном изменении видимости колонки ТП непосредственно перед выполнением изменения видимости.


ТабличноеПоле::ПриИзмененииШириныКолонки / OnColumnWidthChange

1C++ :: Работа с Табличным Полем | Ранее: ПриИзмененииВидимостиКолонки / OnColumnVisibilityChange | Далее: КолонкиТабличногоПоля
ТабличноеПоле :: ПриИзмененииШириныКолонки / OnColumnWidthChange
Синтаксис:

ПриИзмененииШириныКолонки()
Параметры:

нет
Описание:
Событие вызывается при интерактивном изменении ширины одной или нескольких колонок.


КолонкиТабличногоПоля

1C++ :: Работа с Табличным Полем | Ранее: ПриИзмененииШириныКолонки / OnColumnWidthChange | Далее: <ИмяКолонки>
КолонкиТабличногоПоля

Коллекция колонок табличного поля. Элементы коллекции - объекты типа КолонкаТабличногоПоля. Индексы колонок - от нуля до количества колонок минус один.

Свойства

<ИмяКолонки> Набор свойств содержит значения полей колонок табличного поля. Доступ к значению осуществляется по имени колонки. Имена свойств совпадают с именами колонок табличного поля.

Методы

Количество / Count | Получить количество колонок.
Получить / Get | Получить колонку табличного поля.
Индекс / IndexOf | Получить индекс колонки.
Добавить / Add | Добавляет колонку в табличное поле.
Вставить / Insert | Вставляет колонку в табличное поле.
Удалить / Remove | Удаляет колонку из табличного поля.
Очистить / Clear | Удаляет все колонки в табличном поле.
Сдвинуть / Move | Сдвигает позицию колоки на указанное смещение.


КолонкиТабличногоПоля::<ИмяКолонки>

1C++ :: Работа с Табличным Полем | Ранее: КолонкиТабличногоПоля | Далее: Количество / Count
КолонкиТабличногоПоля :: <ИмяКолонки>

Доступ: только чтение.

Тип: КолонкаТабличногоПоля.

Описание: Набор свойств содержит значения полей колонок табличного поля. Доступ к значению осуществляется по имени колонки. Имена свойств совпадают с именами колонок табличного поля.


КолонкиТабличногоПоля::Количество / Count

1C++ :: Работа с Табличным Полем | Ранее: <ИмяКолонки> | Далее: Получить / Get
КолонкиТабличногоПоля :: Количество / Count

Синтаксис: Количество()

Возвращает: тип: Число, количество колонок.

Описание: Получить количество колонок.


КолонкиТабличногоПоля::Получить / Get

1C++ :: Работа с Табличным Полем | Ранее: Количество / Count | Далее: Индекс / IndexOf
КолонкиТабличногоПоля :: Получить / Get

Синтаксис: Получить(Колонка)

Параметры:

  • Колонка - тип: Число, Строка. Индекс или имя колонки.

Возвращает: тип: КолонкаТабличногоПоля.

Описание: Получить колонку табличного поля.


КолонкиТабличногоПоля::Индекс / IndexOf

1C++ :: Работа с Табличным Полем | Ранее: Получить / Get | Далее: Добавить / Add
КолонкиТабличногоПоля :: Индекс / IndexOf

Синтаксис: Индекс(Колонка)

Параметры:

  • Колонка - тип: КолонкаТабличногоПоля. Колонка, индекс которой требуется получить.

Возвращает: тип: Число - индекс колонки, или -1, если колонка не принадлежит табличному полю.

Описание: Получить индекс колонки.


КолонкиТабличногоПоля::Добавить / Add

1C++ :: Работа с Табличным Полем | Ранее: Индекс / IndexOf | Далее: Вставить / Insert
КолонкиТабличногоПоля :: Добавить / Add

Синтаксис: Добавить(Имя)

Параметры:

  • Имя - тип: Строка. Имя добавляемой колонки.

Возвращает: тип: КолонкаТабличногоПоля - созданная колонка.

Описание: Добавляет колонку в табличное поле.


КолонкиТабличногоПоля::Вставить / Insert

1C++ :: Работа с Табличным Полем | Ранее: Добавить / Add | Далее: Удалить / Remove
КолонкиТабличногоПоля :: Вставить / Insert

Синтаксис: Вставить(Имя,Индкс)

Параметры:

  • Имя - тип: Строка. Имя вставляемой колонки.
  • Индекс - тип: Число. Индекс вставляемой колонки.

Возвращает: тип: КолонкаТабличногоПоля - созданная колонка.

Описание: Вставляет колонку в табличное поле.


КолонкиТабличногоПоля::Удалить / Remove

1C++ :: Работа с Табличным Полем | Ранее: Вставить / Insert | Далее: Очистить / Clear
КолонкиТабличногоПоля :: Удалить / Remove

Синтаксис: Удалить(Индекс)

Параметры:

  • Индекс - тип: Число. Индекс удаляемой колонки.

Описание: Удаляет колонку из табличного поля.


КолонкиТабличногоПоля::Очистить / Clear

1C++ :: Работа с Табличным Полем | Ранее: Удалить / Remove | Далее: Сдвинуть / Move
КолонкиТабличногоПоля :: Очистить / Clear

Синтаксис: Очистить()

Описание: Удаляет все колонки в табличном поле.


КолонкиТабличногоПоля::Сдвинуть / Move

1C++ :: Работа с Табличным Полем | Ранее: Очистить / Clear | Далее: КолонкаТабличногоПоля
КолонкиТабличногоПоля :: Сдвинуть / Move

Синтаксис: Сдвинуть(Индекс, Смещение)

Параметры:

  • Индекс - тип: Число, индекс колонки, которую необходимо сдвинуть;
  • Смещение - тип: Число, если положительное, колонка сдвигается влево (ее индекс увеличивается), если отрицательное, сдвигается.

Возвращает: тип: КолонкаТабличногоПоля - созданная колонка.

Описание: Сдвигает позицию колоки на указанное смещение.


КолонкаТабличногоПоля

1C++ :: Работа с Табличным Полем | Ранее: Сдвинуть / Move | Далее: Имя / Name
КолонкаТабличногоПоля

Объект для управления колонкой табличного поля.

Свойства

Имя / Name | Имя колонки.
Заголовок / Caption | Текст заголовка колонки.
Видимость / Visible | Видимость колонки. 0 - невидима, 1 - видима.
Ширина / Width | Ширина колонки в пикселях.
АвтоШирина / AutoWidth | Минимальная достаточная ширина колонки в пикселях, рассчитанная по видимой части ТП
ГоризонтальноеВыравнивание / HorizontalAlignment | Определяет правило выравнивания текста в ячейках колонки по горизонтали.
ИзменениеРазмера / SizeChange | Определяет возможность интерактивного изменения ширины колонки. 0 - запрещено, 1 - разрешено.
ЦветТекста / TextColor | Цвет текста строк. Приоритет выше, чем у свойства ЦветТекста табличного поля.
ЦветФона / BackColor | Цвет фона строк. Приоритет выше, чем у свойства ЦветФона табличного поля.
Шрифт / Font | Шрифт строк. Приоритет выше, чем у свойства Шрифт табличного поля.
ШрифтЗаголовка / HeaderFont | Шрифт заголовка. Приоритет выше, чем у свойства Шрифт табличного поля.
ЦветТекстаЗаголовка / HeaderTextColor | текста заголовка.
ЦветФонаЗаголовка / HeaderBackColor | Цвет фона заголовка.
Данные / DataField | Имя поля данных в поставщике данных. Если не указано, или указано неверно - это не является ошибкой, в этом случае никакие данные поставщика данных в этой колонке не отображаются.
ЗнакУпорядочивания / OrderMarker | Определяет вывод значка упорядочивания в заголовке колонки.
ИзменятьВидимость / ChangeVisible | Разрешает или запрещает изменять видимость колонки. 0 - запрещает, 1- разрешает.

Методы

УстановитьКартинкиСтрок / SetRowsPictures Устанавливает набор картинок для отображения в ячейках этой колонки. Картинками считаются части общей переданной первым параметром картинки, полученные по следующим правилам: от левого верхнего угла слева направо, ширина равна высоте. Выбирается только первый ряд. Прозрачным является цвет RGB(0x00, 0x80, 0x80). Картинки будут доступны по индексу (от нуля).


КолонкаТабличногоПоля::Имя / Name

1C++ :: Работа с Табличным Полем | Ранее: КолонкаТабличногоПоля | Далее: Заголовок / Caption
КолонкаТабличногоПоля :: Имя / Name

Доступ: чтение и запись.

Тип: Строка.

Описание: Имя колонки.


КолонкаТабличногоПоля::Заголовок / Caption

1C++ :: Работа с Табличным Полем | Ранее: Имя / Name | Далее: Видимость / Visible
КолонкаТабличногоПоля :: Заголовок / Caption

Доступ: чтение и запись.

Тип: Строка.

Описание: Текст заголовка колонки.


КолонкаТабличногоПоля::Видимость / Visible

1C++ :: Работа с Табличным Полем | Ранее: Заголовок / Caption | Далее: Ширина / Width
КолонкаТабличногоПоля :: Видимость / Visible

Доступ: чтение и запись.

Тип: Число.

Описание: Видимость колонки. 0 - невидима, 1 - видима.


КолонкаТабличногоПоля::Ширина / Width

1C++ :: Работа с Табличным Полем | Ранее: Видимость / Visible | Далее: АвтоШирина / AutoWidth
КолонкаТабличногоПоля :: Ширина / Width

Доступ: чтение и запись.

Тип: Число.

Описание: Ширина колонки в пикселях.


КолонкаТабличногоПоля::АвтоШирина / AutoWidth

1C++ :: Работа с Табличным Полем | Ранее: Ширина / Width | Далее: ГоризонтальноеВыравнивание / HorizontalAlignment
КолонкаТабличногоПоля :: АвтоШирина / AutoWidth

Доступ: Чтение

Тип: Число

Описание: Минимальная достаточная ширина колонки в пикселях, рассчитанная по видимой части ТП


КолонкаТабличногоПоля::ГоризонтальноеВыравнивание / HorizontalAlignment

1C++ :: Работа с Табличным Полем | Ранее: АвтоШирина / AutoWidth | Далее: ИзменениеРазмера / SizeChange
КолонкаТабличногоПоля :: ГоризонтальноеВыравнивание / HorizontalAlignment

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет правило выравнивания текста в ячейках колонки по горизонтали.

  • 0 - автоматически, в зависимости от типа поля данных, отображаемого в колонке;
  • 1 - прижать влево;
  • 2 - прижать вправо;
  • 3 - центрировать.


КолонкаТабличногоПоля::ИзменениеРазмера / SizeChange

1C++ :: Работа с Табличным Полем | Ранее: ГоризонтальноеВыравнивание / HorizontalAlignment | Далее: ЦветТекста / TextColor
КолонкаТабличногоПоля :: ИзменениеРазмера / SizeChange

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет возможность интерактивного изменения ширины колонки. 0 - запрещено, 1 - разрешено.


КолонкаТабличногоПоля::ЦветТекста / TextColor

1C++ :: Работа с Табличным Полем | Ранее: ИзменениеРазмера / SizeChange | Далее: ЦветФона / BackColor
КолонкаТабличногоПоля :: ЦветТекста / TextColor

Доступ: чтение и запись.

Тип: Число.

Описание: Цвет текста строк. Приоритет выше, чем у свойства ЦветТекста табличного поля.


КолонкаТабличногоПоля::ЦветФона / BackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекста / TextColor | Далее: Шрифт / Font
КолонкаТабличногоПоля :: ЦветФона / BackColor

Доступ: чтение и запись.

Тип: Число.

Описание: Цвет фона строк. Приоритет выше, чем у свойства ЦветФона табличного поля.


КолонкаТабличногоПоля::Шрифт / Font

1C++ :: Работа с Табличным Полем | Ранее: ЦветФона / BackColor | Далее: ШрифтЗаголовка / HeaderFont
КолонкаТабличногоПоля :: Шрифт / Font

Доступ: чтение и запись.

Тип: Шрифт.

Описание: Шрифт строк. Приоритет выше, чем у свойства Шрифт табличного поля.


КолонкаТабличногоПоля::ШрифтЗаголовка / HeaderFont

1C++ :: Работа с Табличным Полем | Ранее: Шрифт / Font | Далее: ЦветТекстаЗаголовка / HeaderTextColor
КолонкаТабличногоПоля :: ШрифтЗаголовка / HeaderFont

Доступ: чтение и запись.

Тип: Шрифт.

Описание: Шрифт заголовка. Приоритет выше, чем у свойства Шрифт табличного поля.


КолонкаТабличногоПоля::ЦветТекстаЗаголовка / HeaderTextColor

1C++ :: Работа с Табличным Полем | Ранее: ШрифтЗаголовка / HeaderFont | Далее: ЦветФонаЗаголовка / HeaderBackColor
КолонкаТабличногоПоля :: ЦветТекстаЗаголовка / HeaderTextColor

Доступ: чтение и запись.

Тип: Число.

Описание: текста заголовка.


КолонкаТабличногоПоля::ЦветФонаЗаголовка / HeaderBackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекстаЗаголовка / HeaderTextColor | Далее: Данные / DataField
КолонкаТабличногоПоля :: ЦветФонаЗаголовка / HeaderBackColor

Доступ: чтение и запись.

Тип: Число.

Описание: Цвет фона заголовка.


КолонкаТабличногоПоля::Данные / DataField

1C++ :: Работа с Табличным Полем | Ранее: ЦветФонаЗаголовка / HeaderBackColor | Далее: ЗнакУпорядочивания / OrderMarker
КолонкаТабличногоПоля :: Данные / DataField

Доступ: чтение и запись.

Тип: Строка.

Описание: Имя поля данных в поставщике данных. Если не указано, или указано неверно - это не является ошибкой, в этом случае никакие данные поставщика данных в этой колонке не отображаются.

См. также: Поставщики данных табличного поля


КолонкаТабличногоПоля::ЗнакУпорядочивания / OrderMarker

1C++ :: Работа с Табличным Полем | Ранее: Данные / DataField | Далее: ИзменятьВидимость / ChangeVisible
КолонкаТабличногоПоля :: ЗнакУпорядочивания / OrderMarker

Доступ: чтение и запись.

Тип: Число

Описание: Определяет вывод значка упорядочивания в заголовке колонки.

  • 0 - не отображается;
  • 1 - по возрастанию;
  • 2 - по убыванию;
  • 3 - по возрастанию второе поле;
  • 4 - по убыванию второе поле;
  • 5 - по возрастанию третье поле;
  • 6 - по убыванию третье поле;


КолонкаТабличногоПоля::ИзменятьВидимость / ChangeVisible

1C++ :: Работа с Табличным Полем | Ранее: ЗнакУпорядочивания / OrderMarker | Далее: УстановитьКартинкиСтрок / SetRowsPictures
КолонкаТабличногоПоля :: ИзменятьВидимость / ChangeVisible

Доступ: чтение и запись.

Тип: Число

Описание: Разрешает или запрещает изменять видимость колонки. 0 - запрещает, 1- разрешает.


КолонкаТабличногоПоля::УстановитьКартинкиСтрок / SetRowsPictures

1C++ :: Работа с Табличным Полем | Ранее: ИзменятьВидимость / ChangeVisible | Далее: ДанныеСтроки
КолонкаТабличногоПоля :: УстановитьКартинкиСтрок / SetRowsPictures

Синтаксис: УстановитьКартинкиСтрок(Картинки, Ширина)

Параметры:

  • Картинки - тип: Картинка. Картинка - из которой будут получены отдельные пиктограммы для отображения в ячейках.
  • Ширина - тип: Число. Необязателен, по умолчанию 0. Ширина отдельной пиктограммы для отображения. Если равна нулю, ширина определяется высотой переданной картинки.

Описание: Устанавливает набор картинок для отображения в ячейках этой колонки. Картинками считаются части общей переданной первым параметром картинки, полученные по следующим правилам: от левого верхнего угла слева направо, ширина равна высоте. Выбирается только первый ряд. Прозрачным является цвет RGB(0x00, 0x80, 0x80). Картинки будут доступны по индексу (от нуля).


ДанныеСтроки

1C++ :: Работа с Табличным Полем | Ранее: УстановитьКартинкиСтрок / SetRowsPictures | Далее: <ИмяПоляДанных>
ДанныеСтроки

Фиксированная коллекция значений полей данных, полученных табличным полем от поставщика данных. Элементы коллекции - значения полей поставщика.

Свойства

<ИмяПоляДанных> Набор свойств содержит значения значения полей данных. Доступ к значению осуществляется по имени поля данных. Набор полей данных обеспечивается поставщиком данных.

Методы

Количество / Count | Получить количество полей данных.
Получить / Get | Получить значение поля.
Индекс / IndexOf | Получить индекс поля.


ДанныеСтроки::<ИмяПоляДанных>

1C++ :: Работа с Табличным Полем | Ранее: ДанныеСтроки | Далее: Количество / Count
ДанныеСтроки :: <ИмяПоляДанных>

Доступ: только чтение.

Тип: любой. Тип определяется поставщиком данных.

Описание: Набор свойств содержит значения значения полей данных. Доступ к значению осуществляется по имени поля данных. Набор полей данных обеспечивается поставщиком данных.

См. также: Поставщики данных табличного поля


ДанныеСтроки::Количество / Count

1C++ :: Работа с Табличным Полем | Ранее: <ИмяПоляДанных> | Далее: Получить / Get
ДанныеСтроки :: Количество / Count

Синтаксис: Количество()

Возвращает: тип: Число, количество полей.

Описание: Получить количество полей данных.


ДанныеСтроки::Получить / Get

1C++ :: Работа с Табличным Полем | Ранее: Количество / Count | Далее: Индекс / IndexOf
ДанныеСтроки :: Получить / Get

Синтаксис: Получить(Поле)

Параметры:

  • Поле - тип: Число, Строка. Имя или индекс поля данных.

Возвращает: тип: Любой. Значение поля данных

Описание: Получить значение поля.


ДанныеСтроки::Индекс / IndexOf

1C++ :: Работа с Табличным Полем | Ранее: Получить / Get | Далее: ОформлениеСтроки
ДанныеСтроки :: Индекс / IndexOf

Синтаксис: Индекс(Поле)

Параметры:

  • Поле - тип: Строка. Имя поля, индекс которого требуется получить.

Возвращает: тип: Число - индекс поля, или -1, если поля с таким именем не существует.

Описание: Получить индекс поля.


ОформлениеСтроки

1C++ :: Работа с Табличным Полем | Ранее: Индекс / IndexOf | Далее: ДанныеСтроки / RowData
ОформлениеСтроки

Объект для управления оформлением строки табличного поля.

Свойства

ДанныеСтроки / RowData | Данные строки. Коллекция значений полей для строки табличного поля.
Ячейки / Cells | Коллекция ячеек строки табличного поля. Элементы коллекции - объекты типа ОформлениеЯчейки.
ЦветТекста / TextColor | Определяет цвет текста всех ячеек строки. Приоритет выше, чем у свойства ЦветТекста колонки табличного поля.
ЦветФона / BackColor | Определяет цвет текста всех ячеек строки. Приоритет выше, чем у свойства ЦветТекста колонки табличного поля.
Шрифт / Font | Определяет Шрифт всех ячеек строки. Приоритет выше, чем у свойства Шрифт колонки табличного поля.


ОформлениеСтроки::ДанныеСтроки / RowData

1C++ :: Работа с Табличным Полем | Ранее: ОформлениеСтроки | Далее: Ячейки / Cells
ОформлениеСтроки :: ДанныеСтроки / RowData

Доступ: только чтение.

Тип: ДанныеСтроки.

Описание: Данные строки. Коллекция значений полей для строки табличного поля.


ОформлениеСтроки::Ячейки / Cells

1C++ :: Работа с Табличным Полем | Ранее: ДанныеСтроки / RowData | Далее: ЦветТекста / TextColor
ОформлениеСтроки :: Ячейки / Cells

Доступ: только чтение.

Тип: ФиксированнаяКоллекция.

Описание: Коллекция ячеек строки табличного поля. Элементы коллекции - объекты типа ОформлениеЯчейки.


ОформлениеСтроки::ЦветТекста / TextColor

1C++ :: Работа с Табличным Полем | Ранее: Ячейки / Cells | Далее: ЦветФона / BackColor
ОформлениеСтроки :: ЦветТекста / TextColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет текста всех ячеек строки. Приоритет выше, чем у свойства ЦветТекста колонки табличного поля.


ОформлениеСтроки::ЦветФона / BackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекста / TextColor | Далее: Шрифт / Font
ОформлениеСтроки :: ЦветФона / BackColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет текста всех ячеек строки. Приоритет выше, чем у свойства ЦветТекста колонки табличного поля.


ОформлениеСтроки::Шрифт / Font

1C++ :: Работа с Табличным Полем | Ранее: ЦветФона / BackColor | Далее: ОформлениеЯчейки
ОформлениеСтроки :: Шрифт / Font

Доступ: чтение и запись.

Тип: Шрифт.

Описание: Определяет Шрифт всех ячеек строки. Приоритет выше, чем у свойства Шрифт колонки табличного поля.


ОформлениеЯчейки

1C++ :: Работа с Табличным Полем | Ранее: Шрифт / Font | Далее: Имя / Name
ОформлениеЯчейки

Объект для управления оформлением ячейки табличного поля.

Свойства

Имя / Name | Имя ячейки. Соответствует имени колонки, которой принадлежит ячейка.
ОтображатьТекст / ShowText | Признак отображения текста в ячейке. 0 - не отображать, 1 - отображать.
ОтображатьКартинку / ShowPicture | Признак отображения картинки в ячейке. 0 - не отображать, 1 - отображать.
ОтображатьФлажок / ShowCheck | Признак отображения флажка в ячейке. 0 - не отображать, 1 - отображать.
ГоризонтальноеВыравнивание / HorizontalAlignment | Определяет правило выравнивания текста в ячейке по горизонтали.
ИндексКартинки / PictureIndex | Определяет индекс картинки для отображения в ячейке. Картинки должны быть предварительно установлены в соответствующей колонке.
ЗначениеФлажка / CheckValue | Определяет значение флажка ячейки табличного поля. Значение флажка отображаемого в ячейке.
Текст / Text | Определяет текст ячейки табличного поля.
ЦветТекста / TextColor | Определяет цвет текста ячейки табличного поля. Приоритет выше, чем у свойства ЦветТекста строки табличного поля.
ЦветФона / BackColor | Определяет цвет фона ячейки табличного поля. Приоритет выше, чем у свойства ЦветФона строки табличного поля.
Шрифт / Font | Определяет шрифт текста ячейки табличного поля. Приоритет выше, чем у свойства Шрифт строки табличного поля.

Методы

УстановитьТекст / SetText
УстановитьКартинку / SetPicture
УстановитьФлажок / SetCheck


ОформлениеЯчейки::Имя / Name

1C++ :: Работа с Табличным Полем | Ранее: ОформлениеЯчейки | Далее: ОтображатьТекст / ShowText
ОформлениеЯчейки :: Имя / Name

Доступ: только чтение.

Тип: Строка.

Описание: Имя ячейки. Соответствует имени колонки, которой принадлежит ячейка.


ОформлениеЯчейки::ОтображатьТекст / ShowText

1C++ :: Работа с Табличным Полем | Ранее: Имя / Name | Далее: ОтображатьКартинку / ShowPicture
ОформлениеЯчейки :: ОтображатьТекст / ShowText

Доступ: чтение и запись.

Тип: Число.

Описание: Признак отображения текста в ячейке. 0 - не отображать, 1 - отображать.


ОформлениеЯчейки::ОтображатьКартинку / ShowPicture

1C++ :: Работа с Табличным Полем | Ранее: ОтображатьТекст / ShowText | Далее: ОтображатьФлажок / ShowCheck
ОформлениеЯчейки :: ОтображатьКартинку / ShowPicture

Доступ: чтение и запись.

Тип: Число.

Описание: Признак отображения картинки в ячейке. 0 - не отображать, 1 - отображать.


ОформлениеЯчейки::ОтображатьФлажок / ShowCheck

1C++ :: Работа с Табличным Полем | Ранее: ОтображатьКартинку / ShowPicture | Далее: ГоризонтальноеВыравнивание / HorizontalAlignment
ОформлениеЯчейки :: ОтображатьФлажок / ShowCheck

Доступ: чтение и запись.

Тип: Число.

Описание: Признак отображения флажка в ячейке. 0 - не отображать, 1 - отображать.


ОформлениеЯчейки::ГоризонтальноеВыравнивание / HorizontalAlignment

1C++ :: Работа с Табличным Полем | Ранее: ОтображатьФлажок / ShowCheck | Далее: ИндексКартинки / PictureIndex
ОформлениеЯчейки :: ГоризонтальноеВыравнивание / HorizontalAlignment

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет правило выравнивания текста в ячейке по горизонтали.

  • 0 - автоматически, в зависимости от типа поля данных, отображаемого в колонке;
  • 1 - прижать влево;
  • 2 - прижать вправо;
  • 3 - центрировать.


ОформлениеЯчейки::ИндексКартинки / PictureIndex

1C++ :: Работа с Табличным Полем | Ранее: ГоризонтальноеВыравнивание / HorizontalAlignment | Далее: ЗначениеФлажка / CheckValue
ОформлениеЯчейки :: ИндексКартинки / PictureIndex

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет индекс картинки для отображения в ячейке. Картинки должны быть предварительно установлены в соответствующей колонке.

См. также: свойство УстановитьКартинкиСтрок / SetRowsPictures, объекта КолонкаТабличногоПоля.


ОформлениеЯчейки::ЗначениеФлажка / CheckValue

1C++ :: Работа с Табличным Полем | Ранее: ИндексКартинки / PictureIndex | Далее: Текст / Text
ОформлениеЯчейки :: ЗначениеФлажка / CheckValue

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет значение флажка ячейки табличного поля. Значение флажка отображаемого в ячейке.

  • 0 - не установлен;
  • 1 - установлен;
  • 2 - неопределенное состояние.


ОформлениеЯчейки::Текст / Text

1C++ :: Работа с Табличным Полем | Ранее: ЗначениеФлажка / CheckValue | Далее: ЦветТекста / TextColor
ОформлениеЯчейки :: Текст / Text

Доступ: чтение и запись.

Тип: Строка.

Описание: Определяет текст ячейки табличного поля.


ОформлениеЯчейки::ЦветТекста / TextColor

1C++ :: Работа с Табличным Полем | Ранее: Текст / Text | Далее: ЦветФона / BackColor
ОформлениеЯчейки :: ЦветТекста / TextColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет текста ячейки табличного поля. Приоритет выше, чем у свойства ЦветТекста строки табличного поля.


ОформлениеЯчейки::ЦветФона / BackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекста / TextColor | Далее: Шрифт / Font
ОформлениеЯчейки :: ЦветФона / BackColor

Доступ: чтение и запись.

Тип: Число.

Описание: Определяет цвет фона ячейки табличного поля. Приоритет выше, чем у свойства ЦветФона строки табличного поля.


ОформлениеЯчейки::Шрифт / Font

1C++ :: Работа с Табличным Полем | Ранее: ЦветФона / BackColor | Далее: УстановитьТекст / SetText
ОформлениеЯчейки :: Шрифт / Font

Доступ: чтение и запись.

Тип: Шрифт.

Описание: Определяет шрифт текста ячейки табличного поля. Приоритет выше, чем у свойства Шрифт строки табличного поля.


ОформлениеЯчейки::УстановитьТекст / SetText

1C++ :: Работа с Табличным Полем | Ранее: Шрифт / Font | Далее: УстановитьКартинку / SetPicture
ОформлениеЯчейки :: УстановитьТекст / SetText
Синтаксис:

УстановитьТекст(стрТекст)
Параметры:
  • стрТекст, тип: Строка.

    Текст, отображаемый в ячейке.
Возвращает:

нет
Описание:

Устанавливает текст ячейки табличного поля для отображения и свойство ОтображатьТекст в 1.


ОформлениеЯчейки::УстановитьКартинку / SetPicture

1C++ :: Работа с Табличным Полем | Ранее: УстановитьТекст / SetText | Далее: УстановитьФлажок / SetCheck
ОформлениеЯчейки :: УстановитьКартинку / SetPicture
Синтаксис:

УстановитьКартинку(Картинка)
Параметры:
  • Картинка, тип: Картинка, Число

    Картинка или индекс картинки
Возвращает:

нет
Описание:
Устанавливает картинку ячейки табличного поля и свойство ОтображатьКартинку в 1.
Если передано Число, это должен быть индекс пиктограммы в картинке переданной в метод КолонкаТабличногоПоля::УстановитьКартинкиСтрок;
Если передан объект Картинка, то отображается сама переданная картинка. Картинка отображается без использования цвета прозрачности. Правила масштабирования картинки задаются в объекте Картинка.
Масштабирование вывода картинки идет всегда с сохранением пропорций её оригинальных размеров и зависит от режима рисования (Картинка::РежимРисования()):
  • 1 - картинка отображается по оригинальным размерам или если они больше ячейки, то по размерам ячейки;
  • 2 - картинка отображается по оригинальным размерам (если они больше размеров ячейки - мы увидим не всю картинку, а только левый верхний угол картинки);
  • 3 - картинка отображается по размерам ячейки;


ОформлениеЯчейки::УстановитьФлажок / SetCheck

1C++ :: Работа с Табличным Полем | Ранее: УстановитьКартинку / SetPicture | Далее: ВыделенныеСтроки
ОформлениеЯчейки :: УстановитьФлажок / SetCheck
Синтаксис:

УстановитьФлажок(ЗначениеФлажка)
Параметры:
  • ЗначениеФлажка, тип: Число

    Значение флажка, отображаемого в ячейке

    • 0 – не установлен;
    • 1 – установлен;
    • 2 – неопределенное состояние.
Возвращает:

нет
Описание:

Устанавливает значение флажка ячейки табличного поля и свойство ОтображатьФлажок в 1.


ВыделенныеСтроки

1C++ :: Работа с Табличным Полем | Ранее: УстановитьФлажок / SetCheck | Далее: Методы
ВыделенныеСтроки

Коллекция выделенных строк табличного поля

Коллекцией можно управлять как интерактивно, так и программно.

Возможно выделение несвязанных строк с помощью мыши или клавиатуры при нажатой клавише CTRL, а также выделение диапазонов строк с помощью мыши при нажатой клавише SHIFT.

Для корректной работы механизма выделения строк необходимо, чтобы поставщик реализовал интерфейс CV7DataProvider (преобразование строки в значение, идентифицирующее строку). Например, для поставщика данных ODBC необходима установка поля ИД методом УстИДПоле.

  • Методы


Методы

1C++ :: Работа с Табличным Полем | Ранее: ВыделенныеСтроки | Далее: Количество / Count
Методы
  • Количество / Count
  • Очистить / Clear
  • Получить / Get
  • Добавить / Add
  • Удалить / Delete
  • Содержит / Contains


Количество / Count

1C++ :: Работа с Табличным Полем | Ранее: Методы | Далее: Очистить / Clear
Количество / Count
Синтаксис: Количество()
Параметры: нет
Возвращает: Количество выделенных строк ТП; тип: Число
Описание:


Очистить / Clear

1C++ :: Работа с Табличным Полем | Ранее: Количество / Count | Далее: Получить / Get
Очистить / Clear
Синтаксис: Очистить()
Параметры: нет
Возвращает: нет
Описание: Снимает выделение со всех строк ТП


Получить / Get

1C++ :: Работа с Табличным Полем | Ранее: Очистить / Clear | Далее: Добавить / Add
Получить / Get
Синтаксис:

Получить(Индекс)
Параметры:
  • Индекс, тип: Число

    Индекс строки; может принимать значения от 0 до Количество() - 1
Возвращает:

Значение строки; тип задается поставщиком данных
Описание:

Получает значение выделенной строки ТП по ее индексу в коллекции


Добавить / Add

1C++ :: Работа с Табличным Полем | Ранее: Получить / Get | Далее: Удалить / Delete
Добавить / Add
Синтаксис:

Добавить(Значение)
Параметры:
  • Значение, тип задается поставщиком данных

    Значение строки ТП
Возвращает:

нет
Описание:

Устанавливает выделение указанной строки ТП


Удалить / Delete

1C++ :: Работа с Табличным Полем | Ранее: Добавить / Add | Далее: Содержит / Contains
Удалить / Delete
Синтаксис:

Удалить(Значение)
Параметры:
  • Значение, тип задается поставщиком данных

    Значение строки ТП
Возвращает:

нет
Описание:

Снимает выделение указанной строки ТП


Содержит / Contains

1C++ :: Работа с Табличным Полем | Ранее: Удалить / Delete | Далее: ФиксированныеСтроки
Содержит / Contains
Синтаксис:

Содержит(Значение)
Параметры:
  • Значение, тип задается поставщиком данных

    Значение строки ТП
Возвращает:
  • 0 - не содержит
  • 1 - содержит
Описание:

Определяет, содержит ли в данная коллекция выделенных строк указанную строку ТП


ФиксированныеСтроки

1C++ :: Работа с Табличным Полем | Ранее: Содержит / Contains | Далее: Свойства
ФиксированныеСтроки

Объект, предназначенный для управления регионами фиксированных строк ТП (Шапка и Подвал)

  • Свойства
  • Методы


Свойства

1C++ :: Работа с Табличным Полем | Ранее: ФиксированныеСтроки | Далее: ПоставщикДанных / DataProvider
Свойства
  • ПоставщикДанных / DataProvider
  • ЦветТекста / TextColor
  • ЦветФона / BackColor


ПоставщикДанных / DataProvider

1C++ :: Работа с Табличным Полем | Ранее: Свойства | Далее: ЦветТекста / TextColor
ПоставщикДанных / DataProvider
Доступ: Чтение и запись
Тип: Поставщики данных табличного поля
Описание: Поставщик данных соответствующего региона ТП


ЦветТекста / TextColor

1C++ :: Работа с Табличным Полем | Ранее: ПоставщикДанных / DataProvider | Далее: ЦветФона / BackColor
ЦветТекста / TextColor
Доступ: Чтение и запись
Тип: Число
Описание: Цвет текста соответствующего региона ТП


ЦветФона / BackColor

1C++ :: Работа с Табличным Полем | Ранее: ЦветТекста / TextColor | Далее: Методы
ЦветФона / BackColor
Доступ: Чтение и запись
Тип: Число
Описание: Цвет фона соответствующего региона ТП


Методы

1C++ :: Работа с Табличным Полем | Ранее: ЦветФона / BackColor | Далее: ОбновитьСтроки / RefreshRows
Методы
  • ОбновитьСтроки / RefreshRows


ОбновитьСтроки / RefreshRows

1C++ :: Работа с Табличным Полем | Ранее: Методы | Далее: Типы данных
ОбновитьСтроки / RefreshRows
Синтаксис: ОбновитьСтроки()
Параметры: нет
Возвращает: нет
Описание: Обновляет данные поставщика и заново отрисовывает табличное поле


Типы данных

1C++ :: Работа с Табличным Полем | Ранее: ОбновитьСтроки / RefreshRows | Далее: Общие
Типы данных
  • Общие


Общие

1C++ :: Работа с Табличным Полем | Ранее: Типы данных | Далее: Перечисления
Общие
  • Перечисления


Перечисления

1C++ :: Работа с Табличным Полем | Ранее: Общие | Далее: ТипыРегионовТП
Перечисления
  • ТипыРегионовТП


ТипыРегионовТП

1C++ :: Работа с Табличным Полем | Ранее: Перечисления | Далее: Поставщики данных табличного поля
ТипыРегионовТП
Тип:

Перечисление
Значения:
  • 0 - регион не задан
  • 1 - заголовок
  • 2 - шапка
  • 3 - строки (основная часть)
  • 4 - подвал


Поставщики данных табличного поля

1C++ :: Работа с Табличным Полем | Ранее: ТипыРегионовТП | Далее: ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider
Поставщики данных табличного поля

См. также

  • ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider
  • ПоляДанныхODBC
  • ПолеДанныхODBC
  • ПараметрыЗапроса
  • ПоставщикДанныхТЗ / VTProvider


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider

1C++ :: Работа с Табличным Полем | Ранее: Поставщики данных табличного поля | Далее: Поля / Fields
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider

Используется для отображения в табличном поле таблиц баз данных. Для получения данных используется драйвер ODBC. Подключение задается объектом ODBCDataBase.

Получаемые данные определяются SQL запросом. Формат SQL запроса определяется строже, чем общий формат SQL запроса источника данных или драйвера ODBC.

Возможно использование метаимен и типизации полей, как определено для объекта ODBCRecordset в Приложении А. Данные получаются частями по несколько записей, как это необходимо для отображения.

Этот поставщик данных поддерживает функционал исключения полей из текста запроса, если данные не нужны для отображения (по причине удаления или невидимости колонки табличного поля).

Формат запроса:

<Запрос> ::=
SELECT
<ОпределениеПоля> [, …n]
FROM <ИсточникДанных>
[WHERE <Условие>]

<ОпределениеПоля> ::= <ВыражениеПоля> AS <ИмяПоля>
<ВыражениеПоля> ::= <определяется правилами источника данных>
<ИмяПоля> ::= <определяется правилами источника данных>
<ИсточникДанных> ::= <определяется правилами источника данных>
<Условие> ::= <определяется правилами источника данных>

Кроме текста запроса, для работы также необходимо задать ключ порядка. Ключ порядка - это набор полей с указанием упорядочивания (порядка следования записей). Значения этих полей должны однозначно идентифицировать каждую запись.

Формат ключа порядка:

<КлючПорядка> ::= <ЭлементКлючаПорядка> [, …n]
<ЭлементКлючаПорядка> ::= <ИмяПоля> {[ASC] | DESC}

В ключе порядка имя поля необходимо указывать без типизации. (Обратите внимание, что поля из ключа порядка должны быть обязательно определены в запросе.)

В тексте запроса допустимо использование текстовых параметров. Формат определения текстового параметра в тексте запроса:

:<ИмяПараметра> [<Модификатор>]

Возможно использование модификаторов, как определено для объекта ODBCRecordset. Текстовые параметры должны быть установлены до установки текста запроса.

В тексте запроса допустимо использование SQL параметров. Формат определения SQL параметра в тексте запроса:

?<ИмяПараметра>(Тип[, Длина[, Точность]])

После установки текста запроса, доступ значениям параметров обеспечивается коллекцией параметров поставщика данных.

Свойство ТекущаяСтрока табличного поля:

  • принимает значение идентифицирующего поля в случае, когда идентифицирующее поле было определено методом УстИДПоле.
  • в случае если идентифицирующее поле не было определено - то свойство ТекущаяСтрока при чтении будет возвращать значение неопределенного типа. При записи в это свойство допустимо передавать объект, в свойствах которого будут значения для ключа порядка текущей строки.

<ТипИсточника>

Определяет тип источника данных. От типа источника зависит стиль конечных запросов к серверу. От типа источника также могут зависеть способы и возможности оптимизации. Определены следующие типы источников данных:

MSSQL: Источником данных должен быть Microsoft SQL Server 7.0 или Microsoft SQL Server 2000. Рекомендуется драйвер: {SQL Server}.
VFP: Источником данных должны быть dbf файлы. Рекомендуется драйвер: {Microsoft Visual FoxPro Driver}.
MySQL: Источником должен быть MySQL Server. Рекомендуется драйвер: {MySQL ODBC 3.51 Driver}.
Oracle: Источником должен быть Oracle8i Database. Рекомендуется драйвер: {Microsoft ODBC для Oracle} или {Oracle ODBC Driver}.

Свойства

Поля / Fields | Коллекция полей поставщика данных.
БазаДанных / Database | Определяет подключение, через которое поставщик данных будет работать.
Параметры / Params | Коллекция параметров запроса.

Методы

УстТекстЗапроса / SetQueryText | Устанавливает текст запроса. При этом происходит сброс ключа порядка, сброс установки идентификационного поля. Происходит полная инициализация состояния поставщика данных. При установке текста запроса происходит также парсинг текста запроса парсером метаимен, как определено для объекта ODBCRecordset.
УстКлючПорядка / SetOrderKey | Установка возможна только после установки текста запроса.
УстановитьТекстовыйПараметр / SetTextParam | Устанавливает значение параметра.
УстИДПоле / SetIDField | Устанавливает поле, которое будет принято поставщиком данных как поле, идентифицирующее строку данных. Значение этого поля будет обеспечиваться поставщиком данных, как значение для свойства ТекущаяСтрока табличного поля.
Обновить / Refresh | Если параметр не указан, то происходит начальное заполнение табличного поля, учитывая значение свойства табличного поля НачальноеПредставление. Если указан параметр, то начальное заполнение табличного поля произойдет с активизацией переданной текущей строки.
Отладка / Debug | включает / отключает отладочный режим.
ПолучитьТекстЗапроса / GetQueryText | возвращает текст запроса


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::Поля / Fields

1C++ :: Работа с Табличным Полем | Ранее: ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider | Далее: БазаДанных / Database
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: Поля / Fields

Доступ: только чтение.

Тип: ПоляДанныхODBC.

Описание: Коллекция полей поставщика данных.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::БазаДанных / Database

1C++ :: Работа с Табличным Полем | Ранее: Поля / Fields | Далее: Параметры / Params
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: БазаДанных / Database

Доступ: чтение и запись.

Тип: ODBCDataBase.

Описание: Определяет подключение, через которое поставщик данных будет работать.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::Параметры / Params

1C++ :: Работа с Табличным Полем | Ранее: БазаДанных / Database | Далее: УстТекстЗапроса / SetQueryText
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: Параметры / Params

Доступ: только чтение.

Тип: ПараметрыЗапроса.

Описание: Коллекция параметров запроса.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::УстТекстЗапроса / SetQueryText

1C++ :: Работа с Табличным Полем | Ранее: Параметры / Params | Далее: УстКлючПорядка / SetOrderKey
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: УстТекстЗапроса / SetQueryText

Синтаксис: УстТекстЗапроса(ТекстЗапроса)

Параметры:

  • ТекстЗапроса - тип: Строка. Текст запроса, определяющий данные, которые будет выдавать поставщик данных.

Описание: Устанавливает текст запроса. При этом происходит сброс ключа порядка, сброс установки идентификационного поля. Происходит полная инициализация состояния поставщика данных. При установке текста запроса происходит также парсинг текста запроса парсером метаимен, как определено для объекта ODBCRecordset.

Примечание: Сразу после установки текста запроса поставщик данных находится в неработоспособном состоянии, т.к. происходит сброс, без ключа порядка он работать не может.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::УстКлючПорядка / SetOrderKey

1C++ :: Работа с Табличным Полем | Ранее: УстТекстЗапроса / SetQueryText | Далее: УстановитьТекстовыйПараметр / SetTextParam
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: УстКлючПорядка / SetOrderKey

Синтаксис: УстКлючПорядка(КлючПорядка)

Параметры:

  • КлючПорядка - тип: Строка. Текст ключа порядка.

Описание: Установка возможна только после установки текста запроса.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::УстановитьТекстовыйПараметр / SetTextParam

1C++ :: Работа с Табличным Полем | Ранее: УстКлючПорядка / SetOrderKey | Далее: УстИДПоле / SetIDField
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: УстановитьТекстовыйПараметр / SetTextParam

Синтаксис: УстановитьТекстовыйПараметр(ИмяПараметра, ЗначениеПараметра)

Параметры:

  • ИмяПараметра - тип: Строка. Имя параметра.
  • ЗначениеПараметра - тип: Строка. Значение параметра.

Описание: Устанавливает значение параметра.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::УстИДПоле / SetIDField

1C++ :: Работа с Табличным Полем | Ранее: УстановитьТекстовыйПараметр / SetTextParam | Далее: Обновить / Refresh
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: УстИДПоле / SetIDField

Синтаксис: УстИДПоле(ИмяПоля)

Параметры:

  • ИмяПоля - тип: Строка. Имя поля.

Описание: Устанавливает поле, которое будет принято поставщиком данных как поле, идентифицирующее строку данных. Значение этого поля будет обеспечиваться поставщиком данных, как значение для свойства ТекущаяСтрока табличного поля.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::Обновить / Refresh

1C++ :: Работа с Табличным Полем | Ранее: УстИДПоле / SetIDField | Далее: Отладка / Debug
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: Обновить / Refresh

Синтаксис: Обновить(ТекущаяСтрока)

Параметры:

  • ТекущаяСтрока - тип: любой. Необязателен. Зависит от установки идентифицирующего поля.

Описание: Если параметр не указан, то происходит начальное заполнение табличного поля, учитывая значение свойства табличного поля НачальноеПредставление. Если указан параметр, то начальное заполнение табличного поля произойдет с активизацией переданной текущей строки.

Текущую строку можно задавать двумя способами:

  • Если установлено идентифицирующее поле, то можно передать значение идентифицирующего поля.
  • Можно передать любой объект, имеющий свойства с именами полей ключа порядка, и соответствующими значениями этих свойств, как значения полей ключа порядка необходимой текущей строки. Например - объект типа Структрура.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::Отладка / Debug

1C++ :: Работа с Табличным Полем | Ранее: Обновить / Refresh | Далее: ПолучитьТекстЗапроса / GetQueryText
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: Отладка / Debug

Синтаксис: Отладка(флРежим = 1)

Параметры:

  • флРежим - тип: Число.
    • 1 - вкл. отладку
    • 0 - откл. отладку

Описание: включает / отключает отладочный режим.


ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider::ПолучитьТекстЗапроса / GetQueryText

1C++ :: Работа с Табличным Полем | Ранее: Отладка / Debug | Далее: ПоляДанныхODBC
ПоставщикДанныхODBC.<ТипИсточника> / ODBCDataProvider :: ПолучитьТекстЗапроса / GetQueryText

Синтаксис: ПолучитьТекстЗапроса()

Параметры:

  • нет

Описание: возвращает текст запроса


ПоляДанныхODBC

1C++ :: Работа с Табличным Полем | Ранее: ПолучитьТекстЗапроса / GetQueryText | Далее: <ИмяПоля>
ПоляДанныхODBC

Коллекция полей поставщика данных. Элементы коллекции - объекты типа ПолеДанныхODBC. Состав коллекции определяет набор полей запроса, который будет запрашиваться с сервера через драйвер ODBC.

Свойства

<ИмяПоля> Набор свойств содержит значения объекты для управления полями данных. Доступ осуществляется по имени поля данных.

Методы

Количество / Count | Получить количество элементов.
Получить / Get | Получить поле поставщика данных по индексу или номеру.
Добавить / Add | Добавляет поле в список получаемых от источника данных. Поле с таким именем должно быть определено в запросе. Если поле с таким именем уже присутствует с коллекции - добавления не происходит.
Удалить / Remove | Удаляет поле из списка получаемых от источника данных. Поля, входящие в состав ключа порядка, и идентифицирующее поле - удалить невозможно.
Очистить / Clear | Удаляет все поля из списка, кроме полей, входящих в состав ключа порядка. Поля, входящие в состав ключа порядка, и идентифицирующее поле - удалить невозможно.


ПоляДанныхODBC::<ИмяПоля>

1C++ :: Работа с Табличным Полем | Ранее: ПоляДанныхODBC | Далее: Количество / Count
ПоляДанныхODBC :: <ИмяПоля>

Доступ: только чтение.

Тип: ПолеДанныхODBC.

Описание: Набор свойств содержит значения объекты для управления полями данных. Доступ осуществляется по имени поля данных.


ПоляДанныхODBC::Количество / Count

1C++ :: Работа с Табличным Полем | Ранее: <ИмяПоля> | Далее: Получить / Get
ПоляДанныхODBC :: Количество / Count

Синтаксис: Количество()

Возвращает: тип: Число. Количество элементов.

Описание: Получить количество элементов.


ПоляДанныхODBC::Получить / Get

1C++ :: Работа с Табличным Полем | Ранее: Количество / Count | Далее: Добавить / Add
ПоляДанныхODBC :: Получить / Get

Синтаксис: Получить(Поле)

Параметры:

  • Поле - тип: Число, Строка. Индекс или имя поля.

Возвращает: тип: ПолеДанныхODBC.

Описание: Получить поле поставщика данных по индексу или номеру.


ПоляДанныхODBC::Добавить / Add

1C++ :: Работа с Табличным Полем | Ранее: Получить / Get | Далее: Удалить / Remove
ПоляДанныхODBC :: Добавить / Add

Синтаксис: Добавить(Имя)

Параметры:

  • Имя - тип: Строка. Имя добавляемого поля запроса.

Возвращает: тип: ПолеДанныхODBC. Добавленное поле.

Описание: Добавляет поле в список получаемых от источника данных. Поле с таким именем должно быть определено в запросе. Если поле с таким именем уже присутствует с коллекции - добавления не происходит.


ПоляДанныхODBC::Удалить / Remove

1C++ :: Работа с Табличным Полем | Ранее: Добавить / Add | Далее: Очистить / Clear
ПоляДанныхODBC :: Удалить / Remove

Синтаксис: Удалить(Индекс)

Параметры:

  • Индекс - тип: Число. Индекс удаляемого поля.

Описание: Удаляет поле из списка получаемых от источника данных. Поля, входящие в состав ключа порядка, и идентифицирующее поле - удалить невозможно.


ПоляДанныхODBC::Очистить / Clear

1C++ :: Работа с Табличным Полем | Ранее: Удалить / Remove | Далее: ПолеДанныхODBC
ПоляДанныхODBC :: Очистить / Clear

Синтаксис: Очистить()

Описание: Удаляет все поля из списка, кроме полей, входящих в состав ключа порядка. Поля, входящие в состав ключа порядка, и идентифицирующее поле - удалить невозможно.


ПолеДанныхODBC

1C++ :: Работа с Табличным Полем | Ранее: Очистить / Clear | Далее: Имя / Name
ПолеДанныхODBC

Объект для управления полем поставщика данных.

Свойства

Имя / Name | Имя поля.
АвтоУдаление / AutoDelete | Признак разрешения автоматического удаления поля из состава получаемых данных от источника. 0 - запрещено, 1 - разрешено.
ТипБыстрогоПоиска / QuickSearchType | Тип быстрого поиска определенного для этого поля. Быстрый поиск может проводиться интерактивно в табличном поле. Быстрый поиск ведется поставщиком данных только по первому полю ключа порядка, поэтому тип быстрого поиска должен определять тип данных этого поля.
УсловиеБыстрогоПоиска / QuickSearchCondition | Определяет дополнительное условие, которое будет включено по "И" в SQL запрос для быстрого поиска.
Типизация / Typification |


ПолеДанныхODBC::Имя / Name

1C++ :: Работа с Табличным Полем | Ранее: ПолеДанныхODBC | Далее: АвтоУдаление / AutoDelete
ПолеДанныхODBC :: Имя / Name

Доступ: только чтение.

Тип: Строка.

Описание: Имя поля.


ПолеДанныхODBC::АвтоУдаление / AutoDelete

1C++ :: Работа с Табличным Полем | Ранее: Имя / Name | Далее: ТипБыстрогоПоиска / QuickSearchType
ПолеДанныхODBC :: АвтоУдаление / AutoDelete

Доступ: чтение и запись.

Тип: Число.

Описание: Признак разрешения автоматического удаления поля из состава получаемых данных от источника. 0 - запрещено, 1 - разрешено.


ПолеДанныхODBC::ТипБыстрогоПоиска / QuickSearchType

1C++ :: Работа с Табличным Полем | Ранее: АвтоУдаление / AutoDelete | Далее: УсловиеБыстрогоПоиска / QuickSearchCondition
ПолеДанныхODBC :: ТипБыстрогоПоиска / QuickSearchType

Доступ: чтение и запись.

Тип: Число.

Описание: Тип быстрого поиска определенного для этого поля. Быстрый поиск может проводиться интерактивно в табличном поле. Быстрый поиск ведется поставщиком данных только по первому полю ключа порядка, поэтому тип быстрого поиска должен определять тип данных этого поля.

  • 0 - нет быстрого поиска;
  • 1 - текстовый быстрый поиск.


ПолеДанныхODBC::УсловиеБыстрогоПоиска / QuickSearchCondition

1C++ :: Работа с Табличным Полем | Ранее: ТипБыстрогоПоиска / QuickSearchType | Далее: Типизация / Typification
ПолеДанныхODBC :: УсловиеБыстрогоПоиска / QuickSearchCondition

Доступ: чтение и запись.

Тип: Строка.

Описание: Определяет дополнительное условие, которое будет включено по "И" в SQL запрос для быстрого поиска.

Примечание: ВНИМАНИЕ! Эта часть запроса не обрабатывается парсером метаимен.


ПолеДанныхODBC::Типизация / Typification

1C++ :: Работа с Табличным Полем | Ранее: УсловиеБыстрогоПоиска / QuickSearchCondition | Далее: ПараметрыЗапроса
ПолеДанныхODBC :: Типизация / Typification
Доступ: чтение и записаь
Тип: Строка вида "Справочник.*", "Документ.*" и т.д., без имени поля и знака "$"
Описание: Предоставляет возможность альтернативной спецификации типизирующих полей запроса.


ПараметрыЗапроса

1C++ :: Работа с Табличным Полем | Ранее: Типизация / Typification | Далее: <ИмяПараметра>
ПараметрыЗапроса

Коллекция значений SQL параметров запроса. Состав коллекции определяется при установке текста запроса.

Свойства

<ИмяПараметра> Набор свойств содержит значения SQL параметров определенных в тексте запроса. Доступ осуществляется по имени параметра.

Методы

Количество / Count | Получить количество параметров в запросе.
Получить / Get | Получить значение параметра по индексу или имени.
Индекс / IndexOf | Получить индекс параметра по имени, если параметр с таким именем не определен, то возвращается -1.
Установить / Set | Устанавливает значение параметра.


ПараметрыЗапроса::<ИмяПараметра>

1C++ :: Работа с Табличным Полем | Ранее: ПараметрыЗапроса | Далее: Количество / Count
ПараметрыЗапроса :: <ИмяПараметра>

Доступ: чтение и запись.

Тип: любой.

Описание: Набор свойств содержит значения SQL параметров определенных в тексте запроса. Доступ осуществляется по имени параметра.


ПараметрыЗапроса::Количество / Count

1C++ :: Работа с Табличным Полем | Ранее: <ИмяПараметра> | Далее: Получить / Get
ПараметрыЗапроса :: Количество / Count

Синтаксис: Количество()

Возвращает: тип: Число. Количество параметров.

Описание: Получить количество параметров в запросе.


ПараметрыЗапроса::Получить / Get

1C++ :: Работа с Табличным Полем | Ранее: Количество / Count | Далее: Индекс / IndexOf
ПараметрыЗапроса :: Получить / Get

Синтаксис: Получить(Параметр)

Параметры:

  • Параметр - тип: Число, Строка. Индекс или имя параметра.

Возвращает: тип: любой. Значение параметра.

Описание: Получить значение параметра по индексу или имени.


ПараметрыЗапроса::Индекс / IndexOf

1C++ :: Работа с Табличным Полем | Ранее: Получить / Get | Далее: Установить / Set
ПараметрыЗапроса :: Индекс / IndexOf

Синтаксис: Индекс(Имя)

Параметры:

  • Имя - тип: Строка. Имя параметра.

Возвращает: тип: Число. Индекс параметра.

Описание: Получить индекс параметра по имени, если параметр с таким именем не определен, то возвращается -1.


ПараметрыЗапроса::Установить / Set

1C++ :: Работа с Табличным Полем | Ранее: Индекс / IndexOf | Далее: ПоставщикДанныхТЗ / VTProvider
ПараметрыЗапроса :: Установить / Set

Синтаксис: Установить(Имя, Значение)

Параметры:

  • Имя - тип: Число, Строка. Индекс или имя параметра.
  • Значение - тип: любой. Значение параметра.

Описание: Устанавливает значение параметра.


ПоставщикДанныхТЗ / VTProvider

1C++ :: Работа с Табличным Полем | Ранее: Установить / Set | Далее: УстТаблицуЗначений / SetValueTable
ПоставщикДанныхТЗ / VTProvider

Поставщик данных для табличного поля. Позволяет отобразить данные таблицы значений в табличном поле.

Свойство ТекущаяСтрока табличного поля имеет тип Число - номер строки таблицы значенией начиная с 1.

Методы

УстТаблицуЗначений / SetValueTable Устанавливает таблицу значений. Она будет использоваться, как источник данных для отображения в табличном поле.


ПоставщикДанныхТЗ / VTProvider::УстТаблицуЗначений / SetValueTable

1C++ :: Работа с Табличным Полем | Ранее: ПоставщикДанныхТЗ / VTProvider | Далее: Объекты общего назначения
ПоставщикДанныхТЗ / VTProvider :: УстТаблицуЗначений / SetValueTable

Синтаксис: УстТаблицуЗначений(ТаблицаЗначений)

Параметры:

  • ТаблицаЗначений - тип: ТаблицаЗначений. Объект таблицы значений для отображения.

Описание: Устанавливает таблицу значений. Она будет использоваться, как источник данных для отображения в табличном поле.


Объекты общего назначения

1C++ :: Работа с Табличным Полем | Ранее: УстТаблицуЗначений / SetValueTable | Далее: Шрифт
Объекты общего назначения
  • Шрифт
  • ФабрикаОбъектов


Шрифт

1C++ :: Работа с Табличным Полем | Ранее: Объекты общего назначения | Далее: Вид / Type
Шрифт

Объект для определения шрифта текста.

Свойства

Вид / Type | Вид шпифта.
Имя / Name | Имя шрифта. (Имя гарнитуры)
Размер / Size | Размер шрифта в пунктах.
Жирный / Bold | Признак жирности шрифта. 0 - нормальный; 1 - жирный.
Наклонный / Italic | Признак наклона шрифта. 0 - нормальный; 1 - наклонный.
Подчеркивание / Underline | Признак подчеркивания шрифта. 0 - нормальный; 1 - подчеркнутый.
Зачеркивание / StrikeOut | Признак зачеркивания шрифта. 0 - нормальный; 1 - зачеркнутый.

Конструкторы (Создание через фабрику объектов)

Основной | Создается абсолютный шрифт.
Системный | Создается системный шрифт.
На основании другого шрифта | Создается шрифт на основании другого шрифта. Все параметры кроме первого - необязательны, и если не указано, то этот показатель шрифта не изменяется.


Шрифт::Вид / Type

1C++ :: Работа с Табличным Полем | Ранее: Шрифт | Далее: Имя / Name
Шрифт :: Вид / Type

Доступ: только чтение.

Тип: Число.

Описание: Вид шпифта.

  • 0 - специальное значение объекта типа шрифт, которое означает, что шрифт выбирается автоматически;
  • 1 - абсолютный, шрифт задан именем шрифта, размером и прочими признаками;
  • 2 - OEMFixedFont;
  • 3 - ANSIFixedFont;
  • 4 - ANSIVariableFont;
  • 5 - SystemFont;
  • 6 - DefaultGUIFont.


Шрифт::Имя / Name

1C++ :: Работа с Табличным Полем | Ранее: Вид / Type | Далее: Размер / Size
Шрифт :: Имя / Name

Доступ: только чтение.

Тип: Строка.

Описание: Имя шрифта. (Имя гарнитуры)


Шрифт::Размер / Size

1C++ :: Работа с Табличным Полем | Ранее: Имя / Name | Далее: Жирный / Bold
Шрифт :: Размер / Size

Доступ: только чтение.

Тип: Число.

Описание: Размер шрифта в пунктах.


Шрифт::Жирный / Bold

1C++ :: Работа с Табличным Полем | Ранее: Размер / Size | Далее: Наклонный / Italic
Шрифт :: Жирный / Bold

Доступ: только чтение.

Тип: Число.

Описание: Признак жирности шрифта. 0 - нормальный; 1 - жирный.


Шрифт::Наклонный / Italic

1C++ :: Работа с Табличным Полем | Ранее: Жирный / Bold | Далее: Подчеркивание / Underline
Шрифт :: Наклонный / Italic

Доступ: только чтение.

Тип: Число.

Описание: Признак наклона шрифта. 0 - нормальный; 1 - наклонный.


Шрифт::Подчеркивание / Underline

1C++ :: Работа с Табличным Полем | Ранее: Наклонный / Italic | Далее: Зачеркивание / StrikeOut
Шрифт :: Подчеркивание / Underline

Доступ: только чтение.

Тип: Число.

Описание: Признак подчеркивания шрифта. 0 - нормальный; 1 - подчеркнутый.


Шрифт::Зачеркивание / StrikeOut

1C++ :: Работа с Табличным Полем | Ранее: Подчеркивание / Underline | Далее: Основной
Шрифт :: Зачеркивание / StrikeOut

Доступ: только чтение.

Тип: Число.

Описание: Признак зачеркивания шрифта. 0 - нормальный; 1 - зачеркнутый.


Шрифт::Основной

1C++ :: Работа с Табличным Полем | Ранее: Зачеркивание / StrikeOut | Далее: Системный
Шрифт :: Основной

Синтаксис: Шрифт(Имя, Размер, Жирный, Наклонный, Подчеркивание, Зачеркивание)

Параметры:

  • Имя - тип Строка. Имя шрифта;
  • Размер - тип: Число. Размер в пунктах;
  • Жирный - тип: Число. Признак жирности шрифта. 0 - нормальный; 1 - жирный;
  • Наклонный - тип: Число. Признак наклона шрифта. 0 - нормальный; 1 - наклонный;
  • Подчеркивание - тип: Число. Признак подчеркивания шрифта. 0 - нормальный; 1 - подчеркнутый;
  • Зачеркивание - тип: Число. Признак зачеркивания шрифта. 0 - нормальный; 1 - зачеркнутый.

Описание: Создается абсолютный шрифт.


Шрифт::Системный

1C++ :: Работа с Табличным Полем | Ранее: Основной | Далее: На основании другого шрифта
Шрифт :: Системный

Синтаксис: Шрифт(Вид)

Параметры:

  • Вид - тип Число. Вид шрифта. Допустимо указывать любой, кроме значения "абсолютный". Необязательный, по умолчанию 0.

Описание: Создается системный шрифт.


Шрифт::На основании другого шрифта

1C++ :: Работа с Табличным Полем | Ранее: Системный | Далее: ФабрикаОбъектов
Шрифт :: На основании другого шрифта

Синтаксис: Шрифт(Шрифт, Имя, Размер, Жирный, Наклонный, Подчеркивание, Зачеркивание)

Параметры:

  • Шрифт - тип Шрифт. Шрифт, на основании которого будет построен новый объект типа шрифт;
  • Имя - тип Строка. Имя шрифта;
  • Размер - тип: Число. Размер в пунктах;
  • Жирный - тип: Число. Признак жирности шрифта. 0 - нормальный; 1 - жирный;
  • Наклонный - тип: Число. Признак наклона шрифта. 0 - нормальный; 1 - наклонный;
  • Подчеркивание - тип: Число. Признак подчеркивания шрифта. 0 - нормальный; 1 - подчеркнутый;
  • Зачеркивание - тип: Число. Признак зачеркивания шрифта. 0 - нормальный; 1 - зачеркнутый.

Описание: Создается шрифт на основании другого шрифта. Все параметры кроме первого - необязательны, и если не указано, то этот показатель шрифта не изменяется.


ФабрикаОбъектов

1C++ :: Работа с Табличным Полем | Ранее: На основании другого шрифта | Далее:
ФабрикаОбъектов

Специальный объект, представляющий из себя сборник конструкторов встроенных классов. Позволяет снабдить процесс создания объектов параметрами. Каждый метод фабрики объектов возвращает объект одноименного типа.

Описание синтаксиса создания расположено в описании самих объектов.

Например:

глФабрика = СоздатьОбъект("ФабрикаОбъектов");
ШрифтАриал10Жирный = глФабрика.Шрифт("Arial", 10, 1);