GUID

GUID

Класс предназначен для работы с глобальным уникальным идентификатором (GUID). После создания объект содержит значение пустого идентификатора.

Методы

ИзСтроки / FromString | позволяет загрузить объект из строки.
ВСтроку / ToString | конвертирует содержимое объекта в строку.
Пустой / IsNil | позволяет проверить содержимое объекта - пустой или нет.
УстПустой / SetNil | формирует пустой идентификатор в объекте.
Равны / IsEqual | позволяет сравнить два идентификатора.
Новый / New | создает новый идентификатор в объекте.


GUID::ИзСтроки / FromString

1C++ :: GUID | Ранее: GUID | Далее: ВСтроку / ToString
GUID :: ИзСтроки / FromString

Синтаксис: ИзСтроки(ИдентификаторСтрокой)

Параметры:

  • ИдентификаторСтрокой - тип: Строка. Строка для загрузки, должна быть в каноническом виде для представления идентификатора.

Описание: позволяет загрузить объект из строки.


GUID::ВСтроку / ToString

1C++ :: GUID | Ранее: ИзСтроки / FromString | Далее: Пустой / IsNil
GUID :: ВСтроку / ToString

Синтаксис: ВСтроку()

Возвращает: тип: Строка. Cтроковое представление идентификатора в каноническом виде.

Описание: конвертирует содержимое объекта в строку.


GUID::Пустой / IsNil

1C++ :: GUID | Ранее: ВСтроку / ToString | Далее: УстПустой / SetNil
GUID :: Пустой / IsNil

Синтаксис: Пустой()

Возвращает: тип: Число. 1 - пустой, 0 - не пустой.

Описание: позволяет проверить содержимое объекта - пустой или нет.


GUID::УстПустой / SetNil

1C++ :: GUID | Ранее: Пустой / IsNil | Далее: Равны / IsEqual
GUID :: УстПустой / SetNil

Синтаксис: УстПустой()

Описание: формирует пустой идентификатор в объекте.


GUID::Равны / IsEqual

1C++ :: GUID | Ранее: УстПустой / SetNil | Далее: Новый / New
GUID :: Равны / IsEqual

Синтаксис: Равны(Идентификатор)

Параметры:

  • Идентификатор - тип: Строка, GUID. Строка или объект для сравнения.

Возвращает: тип: Число. 1 - равны, 0 - не равны.

Описание: позволяет сравнить два идентификатора.


GUID::Новый / New

1C++ :: GUID | Ранее: Равны / IsEqual | Далее:
GUID :: Новый / New

Синтаксис: Новый()

Описание: создает новый идентификатор в объекте.