Выпуск от 03.02.2009, финальный

Интегрированная среда DRAKON языка ДРАКОН

О программе

ДРАКОН – Дружественный Русский Алгоритмический язык, Который Обеспечивает Наглядность.

ГНОМ – Графический Наглядный Очень Маленький язык - декларативный язык.

Автор языков - к.т.н. Владимир Даниелович Паронджанов, из www.npcap.ru - ФГУП "НПЦ Автоматики и приборостроения им. акад. Н.А.Пилюгина".

Смотрите - http://parondzhanov.livejournal.com/ , http://upr.1september.ru/.

Язык ДРАКОН для XXI-го века, родился и вышел из космической колыбели БУРАНа (полет 15 ноября 1988г.).

О создании программного обеспечения БУРАНа - www.buran.ru.

История создания языка ДРАКОН - www.transhumanism-russia.ru.

Книги: "Занимательная информатика" (1998, 2000, 2007) для младшего и среднего школьного возраста,

"Как улучшить работу ума. Алгоритмы без программистов - это очень просто!" (1998, 2001) - www.arbinada.com,

"Почему мудрец похож на обезьяну" (2007).

В теме: “Культурология языка ДРАКОН” http://forum.oberoncore.ru/ - современное изложение от 27.05.2008.

Стандарты: ГОСТ 19.701-90, ISO 5807–85 Схемы алгоритмов, программ, данных и систем. Условные обозначения и правила выполнения.

Форум с участием В.Д. Паронджанова и Wiki на www.oberoncore.ru - Оберон-технологии в России.

Форум http://rus.24bb.ru/ осуществляет поддержку и.с. DRAKON и языка ДРАКОН.

[Паронджанов В.Д. Цитаты из различных источников.]

Опыт Бурана показывает, что вопрос об интеллектуальном взаимопонимании специалистов зачастую играет ключевую, основополагающую роль и во многом определяет успех дела.

Язык в равной степени рассчитан на четыре категории лиц:

1. на людей, совершенно не знакомых (или слабо знакомых) с программированием и вычислительной техникой: механиков, электриков, комплексников, прибористов, испытателей, физиков, химиков, геологов, биологов, медиков, экономистов, юристов, психологов и т. д.;

2. на профессиональных программистов, математиков и разработчиков вычислительной техники, в том числе на специалистов по операционным системам, системному и прикладному программированию, а также микропрограммированию (для персональных, универсальных, управляющих и бортовых компьютеров);

3. на школьников и студентов;

4. на руководителей многих уровней, желающих за минимальное время уяснить суть сложных проблем.

При создании Дракона были предъявлены необычные для программистов, математиков и «технарей» гуманитарные требования:

1. Улучшить работу человеческого ума.

2. Предложить эффективные средства для описания структуры человеческой деятельности.

3. Предоставить человеку такие языковые средства, которые резко упрощают восприятие сложных процедурных проблем, общение с коллегами, делают непонятное понятным и за счет этого буквально заставляют человека мыслить отчетливо, глубоко и продуктивно. В этих условиях вероятность заблуждений, просчетов и ошибок неизбежно падает, а производительность растет.

4. Радикально облегчить межотраслевое и междисциплинарное общение между представителями разных организаций, ведомств, отделов, лабораторий, научных школ и профессий.

5. Устранить или уменьшить барьеры взаимного непонимания между работниками различных специальностей (врачами и физиками, математиками и конструкторами, биологами и экономистами и т. д.), а также программистами и теми, у кого аллергия к любому программированию.

6. Добиться кардинального улучшения качества программного обеспечения по критерию «понимаемость алгоритмов и программ».

Зачем нужен Дракон-редактор?

Разумеется, в случае крайней нужды дракон - схему можно нарисовать и вручную. Однако это не лучший способ. Гораздо удобнее воспользоваться специальной программой, которая называется "ДРАКОН - редактор". Если же нужно создать ДРАКОН - программу, ручное рисование вообще исключается. Без ДРАКОН - редактора ввести ДРАКОН - программу в компьютер невозможно.

http://forum.oberoncore.ru/ 24 Февраля 2008

6.Моя книга — это обращение к творческим умам, призыв к энтузиастам. Ребята! Если вам нравится идея Дракона, создайте на его основе хороший язык. (Дракон-редактор, уточнение Тышова)

7. Мы в ракетной технике на основе Дракона сделали такой язык, какой нужен нам. Но вам он не годится. Так что создайте другой, удобный для вас.

http://forum.oberoncore.ru/ 02 Июня 2008

НЕДОСТАТОК ПОЗИЦИИ АКАДЕМИКА ЕРШОВА

Ершов смотрел на проблему по-крупному, порою не различая деталей (в ту пору это было вполне извинительно). Однако есть деталь, которую следует признать важной. Это различие между ПРОГРАММИРОВАНИЕМ И АЛГОРИТМИЗАЦИЕЙ.

Моя мысль состоит в следующем.

1. Обучение программированию является важной задачей. Но эта задача касается сравнительно небольшого числа людей. Обучение программированию не может и не должно быть массовым.

2. Что касается алгоритмизации (понимаемой, в частности, как формализация собственных процедурных знаний), то эта задача может и должна быть предметом массового обучения.

АЛГОРИТМИЗАЦИЯ — ВТОРАЯ ГРАМОТНОСТЬ?

Развивая идеи академика Ершова, учитывая его ошибки и реалии сегодняшнего дня, можно сделать следующие замечания:

• Массовое обучение программированию невозможно и не нужно по двум причинам. Во-первых, оно неимоверно трудно. Во-вторых, оно дает знания, которые большинству просто не нужны.

• Массовое обучение алгоритмизации, наоборот, полезно и необходимо.

• В обществе знаний во многих случаях возникает острая необходимость формализовать собственные процедурные профессиональные знания специалистов. Такое умение должно стать частью их профессиональной культуры.

• Алгоритмы пригодны для описания человеческой деятельности (работы), которая состоит из действий.

В чем преимущества такого подхода? Они очевидны. Деятельность — это работа. Как известно, все люди работают. Значит, работу каждого человека, можно описать в виде алгоритма (исключения не в счет). Такое умение (умение описать сложную работу в виде алгоритма) во многих случаях оказывается очень полезным. В частности, оно позволяет почти без труда осуществить автоформализацию процедурных профессиональных знаний.

[Конец цитат]

http://forum.oberoncore.ru/ 09 Апреля 2008

Вспомните о детях, которые учились и учатся по книге В.Д. Паронджанова "Занимательная информатика". Книга с 1998 года выдержала 3 издания. Дети ждут Дракон-редактор. Чтобы язык ДРАКОН и Дракон-редактор пришли в школу и высшую школу вместе с языком Компонентный Паскаль, надо рассказать о них на сайте "Информатика-21" http://www.inr.ac.ru/~info21/.

DRAKON © Тышов Г.Н. 2007-2009. Предыдущие рабочие наименования программы - DR, DRT.

DRAKON – интегрированная среда применения языков Дракон и Гном.

DRAKON – это программа для алгоритмизации решений ваших проблем.

DRAKON – это программа для интегрирования решения ваших проблем со средой вашей деятельности.

DRAKON – это текстовая информационная база интегрированная с алгоритмами вашей деятельности.

DRAKON – это инструмент техники вашей мышления..

Варианты применения:

DRAKON.exe – Технология ГРАФИТ, т.е. сочетание ГРАФики И Текста. Для организаций обеспечивается взаимодействие подразделений. Обеспечивается полное использование возможностей интегрированной среды.

DRAKONU.exe – Учеба. Для школы, высшей школы и самообразования. В объеме книги "Занимательная информатика".

DRAKOND.exe – Демонстрация файлов с Дракон - схемами. Для использования Дракон - схем, как средство общения, передачи понятий, знаний, учебника, справочника алгоритмов в разных областях знаний.

Соответственно переименовать исходный файл DRAKON.exe. Переключить вариант применения можно оперативно: нажать клавишу Shift+U или Shift+D, Shift+G.

По технологии ГРАФИТ, применение разнесено на 3-и уровня.

1. Управленческий. Для руководства, менеджеров и заказчика. В управленческих примечаниях записываются ссылки на нормативные и распорядительные документы, выписки из них.

2. Алгоритмический, прикладной. Для прикладных специалистов, постановщиков. Формируется алгоритм в виде графических Дракон - схем. В алгоритмических примечаниях записываются описания и пояснения к графическим Дракон - схемам, указания программисту.

3. Программный. Для программиста. Используется при разработке программы для компьютера, создании ДРАКОН - программы. В программных примечаниях записываются фрагменты программного кода на применяемом языке программирования. При сборке производится объединение текста и получение программного кода. Получение исполнительного файла производится в применяемой среде языка программирования.

Примечания всех уровней имеют структуру дерева: к листу, к схеме, к иконе. При сборке, производится объединение текстов в общий текст в буфере, отображение в окне текстов, запись текстового файла, обработка программой указанной в командной строке. Текст можно корректировать, скопировать и передать во внешний текстовый редактор. Во внешнем текстовом редакторе, текст можно корректировать, форматировать, проверить грамотность, напечатать. Рекомендуется MS Word.

Графику можно сохранить в графическом файле. Графический файл можно загрузить во внешний графический редактор, корректировать, напечатать. Рекомендуется MS Paint.

Файл листа с Дракон - схемами (.drt, текстовый) можно обработать в различных целях вашей внешней программой.

DRAKON.exe – исходный исполнительный файл, DRAKON.chm – файл справки к программе.

Программа имеет русскую локализацию, не требуется инсталлировать, может использоваться на сменном носителе (флэшке).

Программирование и отладка выполнены на ПЭВМ с Delphi7, Windows XP, оперативной памятью 512 Мб.

При использовании в любом виде для коммерческих целей требуется согласование сторон.

Об авторе DRAKON: 1946г.р., 1С программист 2-й категории, из www.spoarktika.ru - ОАО "Северное производственное объединение "Арктика".

Адрес: для письма и на форуме http://forum.oberoncore.ru/.

Ссылка для скачивания программы и информация об обновлении находятся на форуме www.oberoncore.ru.

Скачать последний выпуск программы и справки можно с http://forum.oberoncore.ru/.

О дальнейшем развитии DRAKON: функциональное развитие программы закончено, будут совершенствоваться алгоритмы реализации программы, выполнятся доработки.

Жду и принимаю ваши сообщения о применении, о планах применения, отзывы, советы, предложения, замечания, критику, корректировки.

Благодарю всех за внимание к моему скромному труду и за участие: жену Надежду Сергеевну, Владимира Даниеловича Паронджанова, участников форума на www.oberoncore.ru, коллег из ОАО "СПО "Арктика".

Интеграция среды выполнена в следующих направлениях:

- цель - использование алгоритмического языка Дракон;

- инструментальные средства - отображение и редактирование графической и текстовой информации, сборка текстов;

- объекты - графика, текст;

- система хранения графики и текста;

- деятельность - учеба, творчество, алгоритмизация, распространение алгоритмов, проектирование, разработка;

- область применения - образование, хобби-разработки, наука, управление, производство, бизнес;

- интеграция с интегрированными средами различных языков программирования путем сборки текста программного кода;

- интеграция с другими системами - экспорт и импорт файлов с открытой структурой.

Использование Вами интегрированной среды DRAKON зависит от Вашего творческого подхода.

Популяризатор математики Д. Пойа в конце книги "Как решать задачу" привел следующую интересную обобщенную схему решения задачи: http://msk.treko.ru/

Д. Пойа приводит такую "синтетическую" пословицу: "Ваши лучшие пять друзей: Что, Почему, Где, Когда и Как. Если вам нужен совет, обратитесь к Что, Почему, Где, Когда и Как — и больше ни к кому не обращайтесь. Ничему не верьте, но сомневайтесь только в том, что вызывает сомнение. Найдя первый гриб или сделав первое открытие, осмотритесь вокруг, - они родятся пучками".

Интегрированная среда DRAKON предоставит вам средство работы с друзьями - вопросами: Что, Почему, Где, Когда и Как.

В.Д. Паронджанов ставит вопрос "Как улучшить работу ума”? Обратим внимание на то, что ум такой ограниченный и надо не сойти с него.

Решение находим у Дэвида Аллена в книге “Getting Things Done” (Как разобраться с делами, Как привести дела в порядок) – методика GTD www.transhumanism-russia.ru (http://www.parabox.ru/). Интересно, книги “Как улучшить работу ума ” и ”Как разобраться с делами” оказались рядом и единственными в разделе “Учебники” библиотеки сайта российских трансгуманистов.

Дэвид Аллен предлагает разобрать все дела из корзины для входящих. Разложить по категориям: решение не требуется, для справки, для решения нужно меньше 2-х минут – сразу выполнить, решение дела делегируем другому исполнителю, остальным делам назначаем срок исполнения и соответственно размещаем. После этого в голове хранить ничего не надо, она соответственно не загружена грузом всех проблем и не болит, все рассортировано и размещено. Дэвид Аллен предлагает использовать компьютер и текстовый редактор, другими авторами было предложено использовать различное оборудование, разработаны специализированные программы, смотрите http://ru.wikipedia.org/wiki/Getting_Things_Done.

Интегрированная среда DRAKON предоставит вам средство: хранить сведения о делах, рассортировать по категориям, срокам исполнения, алгоритмам исполнения в соответствии с методикой GTD.


Помощь

Мышка

Левая клавиша: производится выбор. Выбираются:

- лист - от икон дальше интервала (расстояние между соседними иконами);

- схема - рядом с иконой схемы, ближе интервала;

- икона - в зонах текста, идентификатора;

- узел - в пределах квадрата (появится при выборе);

- точка ввода - в пределах квадрата;

- примечание - в проделах квадрата.

Правая клавиша в режиме редактирования: получить контекстное меню.

Вращать колесо: в окне графики сдвинуть поле графики по вертикали на 1 интервал.

Ctrl+Колесо: сдвинуть поле графики по горизонтали.

Или Ctrl+LeftMouse+движение - сдвинуть поле графики, тоже нажать колесо + движение.

Мышка также используется в окне текстов, при редактировании иконы «Сборка текста».

Клавиатура

Стрелка в режиме редактирования - сдвинуть:

- выбран лист - сдвинуть на листе все схемы;

- выбрана схема - сдвинуть схему;

- выбрана икона, узел, точка ввода - сдвинуть вертикальную или горизонтальную линию с иконой, узлом, точкой ввода.

При нажатии Shift+стрелка, шаг сдвига увеличивается в 5 раз.

Горячих клавиш в программе нет.

Клавиша “ESC” используется: при отказе от выполнения операции требующей выбор, при выходе из режима редактирования списка текстов иконы “Сборка текста”.

Контекстное меню

Вызывается кликом правой клавиши мышки.

Видимость и активность пунктов меню зависит от варианта применения и контекста выбора.

Просматриваются все пункты меню данного контекста, в пункте определен объект применения и выполняемое действие.

Страхование

После открытия программы, имеем состояние окончания предыдущего сеанса работы.

Страхование листа производится после значительных изменений, созданием файла …TMP в папке TMP.

Незначительные изменения (ширина, положение икон, изменение текста, метка иконы) сохраняются в текущей копии;

Обязательное страхование производится при выполнении пункта контекстного меню «Обновить».

Перемещаться между страховыми копиями, можно выполняя пункты меню “<<”, “>>”. Можно перейти на любую копию, скопировать копию наверх, удалить диапазон копий.

Заголовок

Содержит: имя программы, дата выпуска, вариант применения, номер отображаемой страховой копии, количество страховых копий, имя файла листа.

Работа производится со страховой копией файла листа. Файл листа обновляется при выполнении пункта меню “Сохранить” или записывается с другим именем при выполнении пункта меню “Сохранит как …”.

Колонтитулы

Сверху и снизу листа в пределах интервала размещены колонтитулы: верхние, нижние, левые, средние, правые. По клику в зоне колонтитулов, тексты колонтитулов выводим в окно текстов.

Главное меню

Видимость и активность пунктов меню зависит от варианта применения и контекста. Производится выполнение действий, выбор режимов, шрифта, формирование и обмен файлами. В меню, пункты могут помечаться галочкой как “установлено” и точкой как “выбран” из нескольких пунктов.

Окно графики

Редактирование графики производится с использованием клавиатуры, мышки и главного меню. Размер поля графики: до 3500 х 2500 пикселей. Графика может находиться за границами поля, не отображаться и не размещаться в графическом файле, для доступа к ней производится сдвиг всех схем на листе.

Примечания для листа, схемы, иконы отображаются 3-мя квадратами, соответственно: управленческие, алгоритмические, программные. Для пустого примечания - пустой квадрат, при наличии текста - сплошной квадрат. У иконы “Сборка текста” имеется 4-й квадрат – список текстов данной иконы, используется для включения списка в другой список.

Разделитель окон

Граница между окнами графики и текста, передвигается мышкой. Присутствует при открытом окне текста.

Окно текста

Текст отображается в режимах просмотра или редактирования. Отображаемый текст выбирается мышкой в поле графики.

Шрифты для окон графики и текстов выбираются раздельно, шрифт графики сохраняется в выходном файле.

При выходе из окна текстов и сохранения - делайте клик мышкой в поле графики.

Можно производить поиск образца в тексте. Образец используется без учета регистра.

Иконы

Иконам можно присвоить идентификаторы (по ГОСТ 19.701–90) для ссылок в документах или описаниях.

Икона может иметь следующие тексты: идентификатор, верхний, нижний, квадраты – управленческое примечание, алгоритмическое примечание, программный код, список сборки текста, уникальный номер иконы. Они выбираются в соответствующих зонах иконы. Использовать табуляцию в отображаемых на графике текстах не рекомендуется. Текст икон в поле графики автоматически делится на строки по ширине иконы, в окне текстов не разделять в пределах абзаца.

Метка устанавливается левее иконы. Смысл меток может быть различным: выполнено, проверено, ошибка и т.д. Проверка содержания с простановкой меток (галочек), иногда называется “скрыжить”. Метки можно убрать повторным выбором и через меню "Правка / Лист, схема: убрать метки". Разрешение редактировать метки включается в меню.

Можно производить поиск образца текста во всех иконах и всех примечаниях. Образец используется без учета регистра.

Строка состояния

Строка состояния имеет поля: наименование выделенного объекта, пояснения к выполняемым действиям и сообщения об их завершении, координаты курсора мышки.

Построение графики ДРАКОН – схем

Изменения вносятся только в верхнюю копию.

В отдельных случаях дракон-схема строятся с дефектами: имеется пересечение линий, наложение линий на иконы, обратное направление линий, большие и малые расстояния между линиями и иконами, наложение схем.

Дефект всегда можно устранить:

- выполнить операций: "Обновить". При этом выполняется горизонтальное и вертикальное объединение линий, т.е. устраняется ступенчатое соединение линий.

- выполнить сдвиг икон, узлов (вертикалей и горизонталей), так чтобы линии не имели пересечений;

- вернуться к предыдущей копии и повторить работу в другой последовательности.

При редактировании схема перестраивается в последовательности: устраняются изломы линий, производится объединение линий, раздвигается и сжимается по горизонтали и вертикали.

При необходимости, для устранения объединения линий, используется операция "Пересадить лиану".

При пересадке или заземлении лианы, ее можно продолжить рисованием ломаной линии до точки присоединения. Рисование производится кликом левой клавиши мышки в очередных узлах ломаной линии, удаление последнего отрезка линии производится кликом правой клавиши мышки. При рисовании линий, исключено появление пересечений с линиями и иконами. Линия может быть извилистой и должна огибать все препятствия.

Пересадкой лианы можно преобразовать развилку или переключатель в обычный цикл или в переключающий цикл. Преобразовать цикл в цикл ЖДАТЬ, вставив икону "Период", а также наоборот.

При вводе иконы, она имеют текст с наименование иконы или её части, в текст включен знак “?”. Знак может присутствовать в иконах “Ветка” и ”Адрес”, если для них не установлено соответствие. Знак может присутствовать рядом с точкой ввода, которая является критической, т.е. конструкция пустая и требуется ввод икон. Все критические точки ввода присутствуют только после выполнения операции “Обновить”. Знак не должен присутствовать в завершенных схемах.

Контролируйте правильность дракон - схемы.

Сборка текстов

В схеме ГНОМ можно установить несколько икон “Сборка текста”.

Икона «Сборка текста» позволяет сформировать список текстов, хранить его, редактировать, производить по списку сборку текста в окно текстов, в буфер, в файл, запускать внешнюю программу. В список можно включить: идентификатор иконы, текст иконы, примечание, другой список. Текущая позиция в списке отмечена маркером – окружностью, включенные тексты имеют нумерацию.

Список отображается при выборе иконы “Сборка текста” и при ее редактировании.

Включить режим редактирования списка текстов: выбрать икону “Сборка текста”, выполните пункт контекстного меню “ Операция / Сборка текста: включить редактирование”.

Установить текущую позицию в списке: выберите мышкой текст в списке и нажмите левую клавишу.

Вставить текст в список после текущей позиции: выберите текст вне списка и нажмите левую клавишу. Так же вставляется другой список текста, у него выберите 4-й квадрат.

Удалить текст из списка: сделайте его текущим и нажмите правую клавишу.

Выключить режим редактирования списка текстов: нажмите клавишу “ESC”.

Можно установить отображение линии сборки текста и без режима редактирования.

При выборе 4-го квадрата иконы “Сборка текста” в окне текстов производится просмотр или редактирование параметров: имя файла, командная строка.

Имя файла: по умолчанию - “Sborka.txt”, при отсутствии имени файл не записывается, при отсутствии пути в имени используется путь папки программы.

Командная строка: по умолчанию - “Sborka.txt”, при отсутствии имени файла или командной строки – командная строка не выполняется. Если при выполнении возникает ошибка, командная строка запускается еще раз с присоединением пути папки программы.

Ошибки при выполнении командной строки

0 Системе не хватает памяти, выполняемый файл испорчен или произошло ошибочное перераспределение памяти.

2 Файл не найден.

3 Путь не найден.

5 Была попытка динамически связаться с задачей, была ошибка многопроцессорного выполнения или ошибка защиты сети.

6 Библиотека требует отдельных сегментов данных для каждой задачи.

8 Недостаточно памяти для запуска приложения.

10 Ошибочная версия Windows.

11 Ошибочный выполняемый файл. Или это не приложение Windows, или ошибка в .exe файле.

12 Приложение спроектировано для другой операционной системы.

13 Приложение спроектировано для MS-DOS 4.0.

14 Неизвестный тип выполняемого файла.

15 Попытка запустить приложение, работающее только на более ранних версиях Windows.

16 Попытка запустить второй экземпляр приложения, содержащего сегменты данных, не помеченные "только для чтения".

19 Попытка запустить архивированный файл. Файл должен быть разархивирован, прежде чем его можно будет загрузить.

20 Ошибочный файл одной из DLL, требуемой для приложения.

21 Приложение требует 32-битного расширения Windows.

31 Нет приложения, связанного с файлом указанного типа, или нет файла, связанного с указанной операцией.

Для программных примечаний возможно выполнять сборку текстов объединением конечной строки с начальной строкой следующего текста. Для этого текст последней строки заканчивается соединителем – “>>”, пробелы за ним игнорируются. Текст первой строки следующего текста может начинаться таким же соединителем “>>”, пробелы перед ним игнорируются.

Отображение графики ДРАКОН – схем

Для графики можно выбрать стиль оформления: чертеж или плакат. При стиле плакат имеется закраска листа – темно-серая и закраска схемы – светло-серая, что способствует снижению утомляемости зрения. Пользователь может изменить стиль оформления, внеся изменения в файл Drakon.ini. Файл можно удалить и корректировать во время работы с программой.

Выбранные зоны текста и идентификатор иконы отмечаются желтым цветом фона, другие выбранные элементы в схеме отмечаются окружностью.

Установка программы. Файлы программы.

Программа устанавливается без инсталляции, не использует реестр, не использует системные каталоги временных файлов. Программу можно переименовать, при применении для учебы или демонстрации имя программы должно заканчиваться буквами “U” или ”D”. Программа создает в папке программы папку “TMP” и файл ”Drakon.ini”. В файле страховой копии помещено имя и путь файла листа. Графический файл создается с именем и путем файла листа. При использовании флэшки и переносе ее на другой компьютер может смениться буква устройства и стать недоступным пункт меню “Файл/Сохранить”, при этом выполните “Файл/Сохранить как …”.

Состояние программы, настройки сохраняются между сеансами работы с программой.

При пуске программы обрабатывается строка вызова. Операционную систему можно настроить для вызова программы по расширению файла .drt .

Настройка программы пользователем

Пользователь может сам выполнить настройку программы, для этоко выполняется корректировка файла “ Drakon.ini ”.

1. Начальная установка имени файла сборки текста, командной строки.

2. Соединитель текстов программных примечаний.

3. Цвета элементов отбражения графики. Изменения можно вносить без закрытия программы.

4. Толщину линий графики. Изменения можно вносить без закрытия программы.


Реализация языков ДРАКОН и ГНОМ в интегрированной среде DRAKON

Графические языки Владимира Даниеловича Паронджанова описаны в его книге "Почему мудрец похож на обезьяну".

ДРАКОН – Дружественный Русский Алгоритмический язык, Который Обеспечивает Наглядность – процедурный язык.

ГНОМ – Графический Наглядный Очень Маленький язык - декларативный язык. Подмножество языка ГРАФ.

МОЛНИЯ – Маленький Очень Легкий Наглядный И удобный Язык. Подмножество языка ГРАФ.

ГРАФ – ГРАФический язык – мощное оружие интеллекта.

Интегрированная среда DRAKON является результатом эволюционного развития предыдущих версий до 2009 года и реализует языки Дракон и Гном. В DRAKONе учтены предложения на форуме http://forum.oberoncore.ru/, возможно не в полной мере.

Среда DRAKON не совместима с предыдущей версией до 01.01.2009 по формату файла .drt. Это оправдывается следующим: согласно принципу экологии программирования - после 7-и модификаций программа должна создаваться вновь; предложения на форуме потребовали значительно переработать и расширить структуры данных и интерфейса программы. Вероятно, программа не имеет широкого практического применения, т.к. отсутствуют такие сообщения.

Дальнейших планов развития программы нет, данную редакцию будем считать финальной. Будут доработки для устранения ошибок, по замечаниям, по предложениям, совершенствоваться алгоритмы функционирования. Всё это позволит пользователям с большим доверием расширить область применения программы с перспективой использовать и в будущем. Скачать последний выпуск программы и справки можно с http://forum.oberoncore.ru/.

В интегрированной среде DRAKON имеется ряд отступлений и расширений от описания языков и от предыдущей версии среды.

1. Добавлена новая схема ГНОМ – для отображения декларативных знаний. В ней полностью реализован язык ГНОМ, т.е. есть “Запоминатель”. Схема расширена иконами: “Комментарий” и “Боковой присоединяемый комментарий”, “Текст в рамке”, “Текст без рамки”, “Сборка текста”.

2. Из языка Дракон отсутствует операции: “Вырезать вставку”, ”Вставить вставку”, используются операции с фрагментом шампура.

3. Так как икона “Вставка” часто воспринимается как вызов процедуры или функции, то к ней можно присоединить икону “Параметры”, аналогично иконе “Заголовок”.

4. К иконе “Заголовок” для отличия схемы-функции от схемы-процедуры можно присоединить признак функции в виде “>”.

5. Вокруг схем можно отобразить рамку. Это позволяет выделить отдельные схемы или облегчит вырезание ножницами схем для последующей компоновки большого чертежа или размещения на демонстрационной поверхности.

6. В языках, иконы имеют только текст. Здесь в среде DRAKON дополнительно может присутствовать идентификатор иконы, отметка (галочка), управленческое, алгоритмическое, программное примечания, список сборки текстов, уникальный номер иконы.

7. При специальных требованиях к функционированию алгоритма, к иконе можно присоединить “Боковой комментарии” с уточнением назначения иконы и функционирования алгоритма.

8. В среде DRAKON термин “точка ввода” заменяет термин языка Дракон “валентная точка”.

9. В среде DRAKON термин “блок” заменяет термин языка Дракон “фрагмент шампура”. В блок входит 1 или несколько икон на шампуре, и иконы связанные с ними, не должно быть связей выходящих за пределы блока.


Вопросы и ответы об интегрированной среде DRAKON http://forum.oberoncore.ru/

1. Для чего нужен язык ГНОМ, что он позволяет сделать?.
У В.Д. Паронжанова, книга "Почему мудрец похож на обезьяну", глава "Учитесь делать графические конспекты".
Для текстовых описаний (конспектов) предложены языки Гном, Молния, Граф.
В Гноме одна конструкция - запоминатель, она состоит из икон: указатель и мнемоблок.
Запоминатель концентрирует внимание на определении, наименование определяемого предмета помещается в указатель, смысловое значение помещается в мнемоблок.
Запоминатели имеются во всех книгах В.Д.П. и воспринимаются как очевидное.

2. Главное, зачем, работать со схемой ГНОМ?
Каких именно "декларативных знаний"?
Схема Гном служит для формирования текстовых описаний, подобно страницы книги, не процедурных, не алгоритмических.

В схеме Гном есть запоминатель и иконы: текст в рамке, текст без рамки, комментарий тоже что в Драконе, сборка текста. В схеме они размещаются сверху вниз без соединительных линий, схему можно поместить в рамку.

Икона сборка текста служит для формирования по отдельному списку общего текста из текстов, которые находятся в других иконах. Такой текст можно использовать как текст программного кода в применяемых языках программирования. В сборку текста можно включить и другой список, т.е. для схем примитив, силуэт формировать текст процедуры или функции, а для листа текст модуля. В схему гном следует помещать программный код модуля, который не вошел в процедуры, т.е. в схемы примитив и силуэт.

3. Замечание по программе: иногда не запускается нормально и не дает создать лист с ошибкой "недостаточно памяти". Иногда справка не открывается, несмотря на неоднократный вызов соответствующего пункта меню.
Программирование и отладка выполняются на ноутбуке, оперативная память 512Мб, Windows XP, формируется в цвете графическое изображение 3500*2500 пикселей. В программе нет настроек на наличие ресурсов. Проблем нет, Ваши проблемы, вероятно, связаны с компьютером, проверьте работу на другом компьютере, но при наличии проблем сообщайте,
Справку можно просматривать и вне программы.
Кстати, работать можно с флэшки, т.е. дома и еще где-нибудь, используется только каталог программы.

4. Можно поподробнее? Что, формат drt понимается каким-то распространенным графическим редактором? Каким?

Говорилось о выводе листа в графический файл .png.
Файл с расширением png прочитайте редактором Paint.
Можете редактировать: убрать ненужное, добавить логотип фирмы, красивый заголовок, угловой штамп для подписей.
Подготовить для печати, т.е. установить параметры страницы: формат бумаги, размер полей = 0, выбрать ориентацию, раскладку картинки на N x M страницах, центрировать, подогнать или масштабировать.
Предварительно просмотреть. Напечатать. Обрезать поля кромки (подумайте часть или все), склеить скотчем или клеем.
Повесить на стену, провести презентацию.

5. Какие выполнены доработки с 25.01.2009 по 01.02.2009, что еще будет делаться?

Дракон-схема по методике GTD проведена в файле “Доработки_2009_02_01.drt” в комплекте обновления.